diff options
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch | 52 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb (renamed from meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb) | 7 |
2 files changed, 3 insertions, 56 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch deleted file mode 100644 index 539a42a7dc..0000000000 --- a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | From ceb47f37582a055bb7f253f813c435ad55c5b6eb Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 22 Apr 2017 10:02:50 -0700 | ||
4 | Subject: [PATCH 1/2] CMakeLists.txt: Add AUTOCONF_HOST_OPT to help cross | ||
5 | compiling | ||
6 | |||
7 | This helps in doing cross compiles for modules which are using | ||
8 | GNU autoconf for build system | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | CMakeLists.txt | 10 ++++++++-- | ||
13 | 1 file changed, 8 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
16 | index b093f9a..ebf0cd7 100644 | ||
17 | --- a/CMakeLists.txt | ||
18 | +++ b/CMakeLists.txt | ||
19 | @@ -290,6 +290,12 @@ else() | ||
20 | endif() | ||
21 | endif() | ||
22 | |||
23 | +if("${GNU_HOST}" STREQUAL "") | ||
24 | + set(AUTOCONF_HOST_OPT "") | ||
25 | +else() | ||
26 | + set(AUTOCONF_HOST_OPT "--host=${GNU_HOST}") | ||
27 | +endif() | ||
28 | + | ||
29 | # Memory Allocator | ||
30 | # ================ | ||
31 | if(FLB_JEMALLOC AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux") | ||
32 | @@ -299,7 +305,7 @@ if(FLB_JEMALLOC AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux") | ||
33 | # Link to Jemalloc as an external dependency | ||
34 | ExternalProject_Add(jemalloc | ||
35 | SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc | ||
36 | - CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR> | ||
37 | + CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure ${AUTOCONF_HOST_OPT} --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR> | ||
38 | CFLAGS=-std=gnu99\ -Wall\ -pipe\ -g3\ -O3\ -funroll-loops | ||
39 | BUILD_COMMAND ${MAKE} | ||
40 | INSTALL_DIR ${CMAKE_CURRENT_BINARY_DIR}/ | ||
41 | @@ -317,7 +323,7 @@ endif() | ||
42 | if(FLB_REGEX) | ||
43 | ExternalProject_Add(onigmo | ||
44 | SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/lib/onigmo | ||
45 | - CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/onigmo/configure --with-pic --disable-shared --enable-static --prefix=<INSTALL_DIR> | ||
46 | + CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/onigmo/configure ${AUTOCONF_HOST_OPT} --with-pic --disable-shared --enable-static --prefix=<INSTALL_DIR> | ||
47 | CFLAGS=-std=gnu99\ -Wall\ -pipe\ -g3\ -O3\ -funroll-loops | ||
48 | BUILD_COMMAND ${MAKE} | ||
49 | INSTALL_DIR ${CMAKE_CURRENT_BINARY_DIR}/ | ||
50 | -- | ||
51 | 2.12.2 | ||
52 | |||
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb index 8d756e6a40..46c47fd55e 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.3.bb +++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb | |||
@@ -3,11 +3,10 @@ HOMEPAGE = "http://fluentbit.io" | |||
3 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" | 3 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" |
4 | 4 | ||
5 | SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \ | 5 | SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \ |
6 | file://0001-CMakeLists.txt-Add-AUTOCONF_HOST_OPT-to-help-cross-c.patch \ | ||
7 | file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \ | 6 | file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \ |
8 | " | 7 | " |
9 | SRC_URI[md5sum] = "9383262339412782b80cc49e7ad15609" | 8 | SRC_URI[md5sum] = "7bce8091c41fb6412b7fe0185b3cb8d6" |
10 | SRC_URI[sha256sum] = "eb8a85c656fa60682b0bf8dd1ad58d848cd251dab4f35a6777acd552c65b0511" | 9 | SRC_URI[sha256sum] = "93b1bdd14db20f2823cd31c6f1a2f3fcb7c94ec3e0c8daefabf130310b7fc4ed" |
11 | 10 | ||
12 | S = "${WORKDIR}/fluent-bit-${PV}" | 11 | S = "${WORKDIR}/fluent-bit-${PV}" |
13 | 12 | ||
@@ -19,6 +18,6 @@ INSANE_SKIP_${PN}-dev += "dev-elf" | |||
19 | 18 | ||
20 | inherit cmake systemd | 19 | inherit cmake systemd |
21 | 20 | ||
22 | EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS}" | 21 | EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1" |
23 | 22 | ||
24 | SYSTEMD_SERVICE_${PN} = "fluent-bit.service" | 23 | SYSTEMD_SERVICE_${PN} = "fluent-bit.service" |