summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/qhull/qhull_2020.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/qhull/qhull_2020.2.bb b/meta-oe/recipes-extended/qhull/qhull_2020.2.bb
new file mode 100644
index 0000000000..4533b0a337
--- /dev/null
+++ b/meta-oe/recipes-extended/qhull/qhull_2020.2.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "library to compute convex hulls, Delaunay triangulations and Voronoi diagrams."
2HOMEPAGE = "http://www.qhull.org/"
3SECTION = "libs"
4LICENSE = "Qhull"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=484ee0cacf0472e8b40225b116f6296c"
6
7SRC_URI = "http://www.qhull.org/download/qhull-2020-src-8.0.2.tgz"
8SRC_URI[sha256sum] = "b5c2d7eb833278881b952c8a52d20179eab87766b00b865000469a45c1838b7e"
9
10CFLAGS += "-fPIC"
11
12EXTRA_OECMAKE += "\
13 -DCMAKE_SKIP_RPATH=ON \
14"
15
16inherit cmake
17
18# The QhullTargets-noconfig.cmake checks for the executables despite not
19# needing to execute them for the build. Staging bindir to the sysroot
20# allows us to pass the check without building qhull natively
21SYSROOT_DIRS:append = " \
22 ${bindir} \
23"