summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy_1.01.bb16
2 files changed, 2 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipy/run-ptest b/meta-python/recipes-devtools/python/python3-ipy/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-ipy/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-ipy_1.01.bb b/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
index 817d04444e..6a35e12ffe 100644
--- a/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
+++ b/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
@@ -11,21 +11,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6"
11 11
12SRC_URI[sha256sum] = "edeca741dea2d54aca568fa23740288c3fe86c0f3ea700344571e9ef14a7cc1a" 12SRC_URI[sha256sum] = "edeca741dea2d54aca568fa23740288c3fe86c0f3ea700344571e9ef14a7cc1a"
13 13
14inherit pypi setuptools3_legacy ptest 14inherit pypi setuptools3_legacy ptest-python-pytest
15 15
16SRC_URI += " \ 16PTEST_PYTEST_DIR = "test"
17 file://run-ptest \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-pytest \
22 python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/test/
27 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test
28}
29 17
30PYPI_PACKAGE = "IPy" 18PYPI_PACKAGE = "IPy"
31UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" 19UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"