diff options
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv/0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch | 49 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_2.4.bb | 3 |
2 files changed, 51 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch b/meta-oe/recipes-support/opencv/opencv/0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch new file mode 100644 index 0000000000..7f809bce12 --- /dev/null +++ b/meta-oe/recipes-support/opencv/opencv/0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From 711f07a34ceb504e8f75e978692201efa58268ca Mon Sep 17 00:00:00 2001 | ||
2 | From: Dinar Valeev <dvaleev@suse.com> | ||
3 | Date: Thu, 16 Jan 2014 21:53:49 +0100 | ||
4 | Subject: [PATCH] Use __vector instead of vector as suggests Eigen | ||
5 | |||
6 | This fixes build on PowerPC where Eigen unsets vector, bool and pixel | ||
7 | |||
8 | Signed-off-by: Dinar Valeev <dvaleev@suse.com> | ||
9 | |||
10 | This patch is already part of OpenCV v3.0. The patch can be obtained | ||
11 | from: | ||
12 | |||
13 | https://github.com/Itseez/opencv/commit/711f07a34ceb504e8f75e978692201efa58268ca.patch | ||
14 | |||
15 | Upstream-Status: Backport [commit 711f07a34c, part of version 3.0] | ||
16 | |||
17 | Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> | ||
18 | --- | ||
19 | 3rdparty/include/opencl/1.2/CL/cl_platform.h | 14 +++++++------- | ||
20 | 1 file changed, 7 insertions(+), 7 deletions(-) | ||
21 | |||
22 | diff --git a/3rdparty/include/opencl/1.2/CL/cl_platform.h b/3rdparty/include/opencl/1.2/CL/cl_platform.h | ||
23 | index e94949a..42c35d5 100644 | ||
24 | --- a/3rdparty/include/opencl/1.2/CL/cl_platform.h | ||
25 | +++ b/3rdparty/include/opencl/1.2/CL/cl_platform.h | ||
26 | @@ -332,13 +332,13 @@ typedef unsigned int cl_GLenum; | ||
27 | /* Define basic vector types */ | ||
28 | #if defined( __VEC__ ) | ||
29 | #include <altivec.h> /* may be omitted depending on compiler. AltiVec spec provides no way to detect whether the header is required. */ | ||
30 | - typedef vector unsigned char __cl_uchar16; | ||
31 | - typedef vector signed char __cl_char16; | ||
32 | - typedef vector unsigned short __cl_ushort8; | ||
33 | - typedef vector signed short __cl_short8; | ||
34 | - typedef vector unsigned int __cl_uint4; | ||
35 | - typedef vector signed int __cl_int4; | ||
36 | - typedef vector float __cl_float4; | ||
37 | + typedef __vector unsigned char __cl_uchar16; | ||
38 | + typedef __vector signed char __cl_char16; | ||
39 | + typedef __vector unsigned short __cl_ushort8; | ||
40 | + typedef __vector signed short __cl_short8; | ||
41 | + typedef __vector unsigned int __cl_uint4; | ||
42 | + typedef __vector signed int __cl_int4; | ||
43 | + typedef __vector float __cl_float4; | ||
44 | #define __CL_UCHAR16__ 1 | ||
45 | #define __CL_CHAR16__ 1 | ||
46 | #define __CL_USHORT8__ 1 | ||
47 | -- | ||
48 | 1.9.3 | ||
49 | |||
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb index 733fe44cc5..3b10b55bcb 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb | |||
@@ -10,7 +10,8 @@ ARM_INSTRUCTION_SET = "arm" | |||
10 | DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0" | 10 | DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0" |
11 | 11 | ||
12 | SRCREV = "2c9547e3147779001811d01936aed38f560929fc" | 12 | SRCREV = "2c9547e3147779001811d01936aed38f560929fc" |
13 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4" | 13 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \ |
14 | file://0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch" | ||
14 | 15 | ||
15 | PV = "2.4.11+git${SRCPV}" | 16 | PV = "2.4.11+git${SRCPV}" |
16 | 17 | ||