summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/libspdm/libspdm/0001-Backport-API-introduced-in-openssl-3.5.0.patch33
-rw-r--r--meta-oe/recipes-support/libspdm/libspdm_3.7.0.bb3
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libspdm/libspdm/0001-Backport-API-introduced-in-openssl-3.5.0.patch b/meta-oe/recipes-support/libspdm/libspdm/0001-Backport-API-introduced-in-openssl-3.5.0.patch
new file mode 100644
index 0000000000..2df9a18c68
--- /dev/null
+++ b/meta-oe/recipes-support/libspdm/libspdm/0001-Backport-API-introduced-in-openssl-3.5.0.patch
@@ -0,0 +1,33 @@
1From 92f6c3d8fa26d9019ba27e0c1aa894517ada93b9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 11 Apr 2025 17:47:05 -0700
4Subject: [PATCH] Backport API introduced in openssl 3.5.0
5
6This commit [1] introduced this new API which is used by pem.h from
7openssl and it should be provided by asn1.h which is vendored here so
8it goes out of sync and causes build errors e.g
9
10In file included from ./os_stub/cryptlib_openssl/pk/x509.c:18:
11/usr/include/openssl/pem.h:399:28: error: unknown type name 'OSSL_i2d_of_void_ctx'
12 399 | int PEM_ASN1_write_bio_ctx(OSSL_i2d_of_void_ctx *i2d, void *vctx,
13
14[1] https://github.com/openssl/openssl/commit/35f6e7ea02b599d5aaf220b4720cbadd946d8023
15
16Upstream-Status: Submitted [https://github.com/DMTF/libspdm/pull/3033]
17Signed-off-by: Khem Raj <raj.khem@gmail.com>
18---
19 os_stub/openssllib/openssl_gen/openssl/asn1.h | 1 +
20 1 file changed, 1 insertion(+)
21
22diff --git a/os_stub/openssllib/openssl_gen/openssl/asn1.h b/os_stub/openssllib/openssl_gen/openssl/asn1.h
23index a90152ee..fcfbe42e 100644
24--- a/os_stub/openssllib/openssl_gen/openssl/asn1.h
25+++ b/os_stub/openssllib/openssl_gen/openssl/asn1.h
26@@ -368,6 +368,7 @@ typedef struct ASN1_VALUE_st ASN1_VALUE;
27
28 typedef void *d2i_of_void(void **, const unsigned char **, long);
29 typedef int i2d_of_void(const void *, unsigned char **);
30+typedef int OSSL_i2d_of_void_ctx(const void *, unsigned char **, void *vctx);
31
32 /*-
33 * The following macros and typedefs allow an ASN1_ITEM
diff --git a/meta-oe/recipes-support/libspdm/libspdm_3.7.0.bb b/meta-oe/recipes-support/libspdm/libspdm_3.7.0.bb
index a3012e10bd..e5915aa795 100644
--- a/meta-oe/recipes-support/libspdm/libspdm_3.7.0.bb
+++ b/meta-oe/recipes-support/libspdm/libspdm_3.7.0.bb
@@ -9,7 +9,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8f9b59a81a88da8e812af43728b72dd7"
9 9
10DEPENDS = "openssl" 10DEPENDS = "openssl"
11 11
12SRC_URI = "git://github.com/DMTF/libspdm.git;branch=main;protocol=https" 12SRC_URI = "git://github.com/DMTF/libspdm.git;branch=main;protocol=https \
13 file://0001-Backport-API-introduced-in-openssl-3.5.0.patch"
13SRCREV = "1be116c7b7713fa9003e1bd53b53a34758549eb9" 14SRCREV = "1be116c7b7713fa9003e1bd53b53a34758549eb9"
14 15
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"