diff options
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod-2.x/0001-bindings-cxx-tests-disable-GPIO-simulator-before-rel.patch | 34 | ||||
-rw-r--r-- | meta-oe/recipes-support/libgpiod/libgpiod_2.2.bb | 5 |
2 files changed, 38 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod-2.x/0001-bindings-cxx-tests-disable-GPIO-simulator-before-rel.patch b/meta-oe/recipes-support/libgpiod/libgpiod-2.x/0001-bindings-cxx-tests-disable-GPIO-simulator-before-rel.patch new file mode 100644 index 0000000000..9747613aa6 --- /dev/null +++ b/meta-oe/recipes-support/libgpiod/libgpiod-2.x/0001-bindings-cxx-tests-disable-GPIO-simulator-before-rel.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 7df2bb4f51281166633d4acbcff5763150add3fa Mon Sep 17 00:00:00 2001 | ||
2 | From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> | ||
3 | Date: Mon, 3 Feb 2025 13:20:41 +0100 | ||
4 | Subject: [PATCH] bindings: cxx: tests: disable GPIO simulator before releasing it | ||
5 | |||
6 | Linux kernel commit 8bd76b3d3f3a ("gpio: sim: lock up configfs that an | ||
7 | instantiated device depends on") uncovered an issue in C++ bindings | ||
8 | tests where the GPIO simulator device is not disabled before removing its | ||
9 | configfs entries. Add a call to gpiosim_dev_disable() to the | ||
10 | gpiosim::chip's destructor. | ||
11 | |||
12 | Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> | ||
13 | |||
14 | Upstream-Status: Submitted [https://lore.kernel.org/all/20250203-fix-gpiosim-in-bindings-v1-1-d2c9e0f3a29d@linaro.org/] | ||
15 | --- | ||
16 | bindings/cxx/tests/gpiosim.cpp | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/bindings/cxx/tests/gpiosim.cpp b/bindings/cxx/tests/gpiosim.cpp | ||
20 | index 4bda5a2..cdecd8d 100644 | ||
21 | --- a/bindings/cxx/tests/gpiosim.cpp | ||
22 | +++ b/bindings/cxx/tests/gpiosim.cpp | ||
23 | @@ -115,7 +115,7 @@ chip::chip(chip&& other) | ||
24 | |||
25 | chip::~chip() | ||
26 | { | ||
27 | - | ||
28 | + ::gpiosim_dev_disable(this->_m_priv->dev.get()); | ||
29 | } | ||
30 | |||
31 | chip& chip::operator=(chip&& other) | ||
32 | -- | ||
33 | 2.45.2 | ||
34 | |||
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_2.2.bb b/meta-oe/recipes-support/libgpiod/libgpiod_2.2.bb index 259ee04d28..054d378451 100644 --- a/meta-oe/recipes-support/libgpiod/libgpiod_2.2.bb +++ b/meta-oe/recipes-support/libgpiod/libgpiod_2.2.bb | |||
@@ -11,7 +11,10 @@ LIC_FILES_CHKSUM = " \ | |||
11 | 11 | ||
12 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}-2.x:" | 12 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}-2.x:" |
13 | 13 | ||
14 | SRC_URI += "file://gpio-manager.init" | 14 | SRC_URI += " \ |
15 | file://gpio-manager.init \ | ||
16 | file://0001-bindings-cxx-tests-disable-GPIO-simulator-before-rel.patch \ | ||
17 | " | ||
15 | 18 | ||
16 | SRC_URI[sha256sum] = "ee29735890eb1cc0e4b494001da5163d1a9c4735343201d22485db313601ca07" | 19 | SRC_URI[sha256sum] = "ee29735890eb1cc0e4b494001da5163d1a9c4735343201d22485db313601ca07" |
17 | 20 | ||