summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch29
-rw-r--r--meta-oe/recipes-graphics/assimp/assimp_3.3.1.bb (renamed from meta-oe/recipes-graphics/assimp/assimp_3.1.1.bb)10
2 files changed, 35 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch b/meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch
new file mode 100644
index 0000000000..c94bb3d58b
--- /dev/null
+++ b/meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch
@@ -0,0 +1,29 @@
1From 614475dcac1cee4d63b764282c578672bc060321 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 29 Jun 2017 14:23:00 -0700
4Subject: [PATCH] Fix build on big-endian architectures
5
6see
7https://github.com/assimp/assimp/pull/986
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 code/glTFAsset.inl | 2 ++
12 1 file changed, 2 insertions(+)
13
14diff --git a/code/glTFAsset.inl b/code/glTFAsset.inl
15index d52c825c..470246c9 100644
16--- a/code/glTFAsset.inl
17+++ b/code/glTFAsset.inl
18@@ -40,6 +40,8 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
19
20 #include "StringUtils.h"
21
22+using namespace Assimp;
23+
24 namespace glTF {
25
26 namespace {
27--
282.13.2
29
diff --git a/meta-oe/recipes-graphics/assimp/assimp_3.1.1.bb b/meta-oe/recipes-graphics/assimp/assimp_3.3.1.bb
index 4da3dc213e..064683a65f 100644
--- a/meta-oe/recipes-graphics/assimp/assimp_3.1.1.bb
+++ b/meta-oe/recipes-graphics/assimp/assimp_3.3.1.bb
@@ -3,13 +3,15 @@ DESCRIPTION = "Open Asset Import Library is a portable Open Source library to im
3HOMEPAGE = "http://www.assimp.org/" 3HOMEPAGE = "http://www.assimp.org/"
4SECTION = "devel" 4SECTION = "devel"
5LICENSE = "BSD" 5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bc4231a2268da8fc55525ad119638a87" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=4cd8c0aedc7a0623476669377d7eeda8"
7 7
8DEPENDS = "boost virtual/libgl" 8DEPENDS = "boost virtual/libgl"
9 9
10SRC_URI = "http://sourceforge.net/projects/${BPN}/files/${BPN}-3.1/${BPN}-${PV}_no_test_models.zip" 10SRCREV = "a8673d4828df5107186f49e5e4efa5316b727482"
11SRC_URI[md5sum] = "ccd4788204509da58a3a53c7aeda7a8b" 11SRC_URI = "git://github.com/assimp/assimp \
12SRC_URI[sha256sum] = "da9827876f10a8b447270368753392cfd502e70a2e9d1361554e5dfcb1fede9e" 12 file://0001-Fix-build-on-big-endian-architectures.patch \
13 "
14S = "${WORKDIR}/git"
13 15
14inherit cmake 16inherit cmake
15 17