diff options
-rw-r--r-- | meta-oe/recipes-extended/bitwise/bitwise_0.43.bb (renamed from meta-oe/recipes-extended/bitwise/bitwise_0.42.bb) | 3 | ||||
-rw-r--r-- | meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch | 27 |
2 files changed, 1 insertions, 29 deletions
diff --git a/meta-oe/recipes-extended/bitwise/bitwise_0.42.bb b/meta-oe/recipes-extended/bitwise/bitwise_0.43.bb index ebf4b3c5e6..f473ccaf5a 100644 --- a/meta-oe/recipes-extended/bitwise/bitwise_0.42.bb +++ b/meta-oe/recipes-extended/bitwise/bitwise_0.43.bb | |||
@@ -12,9 +12,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" | |||
12 | 12 | ||
13 | SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \ | 13 | SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \ |
14 | file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \ | 14 | file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \ |
15 | file://0001-Fix-Werror-format-security-errors-with-mvwprintw.patch \ | ||
16 | " | 15 | " |
17 | SRC_URI[sha256sum] = "d3d43cef47bf8f49e85f7ed381c3eaf1df921ca51805e0962f1a97a517e1d1d2" | 16 | SRC_URI[sha256sum] = "f524f794188a10defc4df673d8cf0b3739f93e58e93aff0cdb8a99fbdcca2ffb" |
18 | 17 | ||
19 | UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases" | 18 | UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases" |
20 | 19 | ||
diff --git a/meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch b/meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch deleted file mode 100644 index ebcb0dd5ee..0000000000 --- a/meta-oe/recipes-extended/bitwise/files/0001-Fix-Werror-format-security-errors-with-mvwprintw.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From 53237c103b06f58ad9c2ce3914fcc7fe73629f11 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 30 Oct 2021 01:11:33 -0700 | ||
4 | Subject: [PATCH] Fix -Werror=format-security errors with mvwprintw() | ||
5 | |||
6 | Here a non-constant is used as a format string which | ||
7 | compiler complains about. Fix by using "%s" as format. | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/mellowcandle/bitwise/pull/49] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/interactive.c | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/src/interactive.c b/src/interactive.c | ||
16 | index cce418a..2c0b152 100644 | ||
17 | --- a/src/interactive.c | ||
18 | +++ b/src/interactive.c | ||
19 | @@ -114,7 +114,7 @@ void update_history_win(void) | ||
20 | break; | ||
21 | } | ||
22 | |||
23 | - mvwprintw(history_win, j, 2, history[history_pos - i].line); | ||
24 | + mvwprintw(history_win, j, 2, "%s", history[history_pos - i].line); | ||
25 | } | ||
26 | |||
27 | if (g_has_color) | ||