summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb8
2 files changed, 3 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest b/meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-requests-toolbelt/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb b/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb
index 9cbe4927a2..8956dee1f1 100644
--- a/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests-toolbelt_1.0.0.bb
@@ -4,14 +4,14 @@ HOMEPAGE = "https://toolbelt.readthedocs.org"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6f14302a4b4099009ab38b4dde5f1075" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=6f14302a4b4099009ab38b4dde5f1075"
6 6
7SRC_URI = "file://run-ptest \ 7SRC_URI = " \
8 file://090856f4159c40a2927fb88546419f2e1697ad5f.patch \ 8 file://090856f4159c40a2927fb88546419f2e1697ad5f.patch \
9 file://720240501dca0b4eacc3295665d7ced8719e11d2.patch \ 9 file://720240501dca0b4eacc3295665d7ced8719e11d2.patch \
10 " 10 "
11 11
12SRC_URI[sha256sum] = "7681a0a3d047012b5bdc0ee37d7f8f07ebe76ab08caeccfc3921ce23c88d5bc6" 12SRC_URI[sha256sum] = "7681a0a3d047012b5bdc0ee37d7f8f07ebe76ab08caeccfc3921ce23c88d5bc6"
13 13
14inherit pypi setuptools3 ptest 14inherit pypi setuptools3 ptest-python-pytest
15 15
16RDEPENDS:${PN} += " \ 16RDEPENDS:${PN} += " \
17 python3-requests (>=2.0.1) \ 17 python3-requests (>=2.0.1) \
@@ -21,12 +21,10 @@ RDEPENDS:${PN}-ptest += " \
21 python3-betamax \ 21 python3-betamax \
22 python3-mock \ 22 python3-mock \
23 python3-multiprocessing \ 23 python3-multiprocessing \
24 python3-pytest \
25 python3-trustme \ 24 python3-trustme \
26 python3-unittest-automake-output \
27" 25"
28 26
29do_install_ptest() { 27do_install_ptest:append() {
30 install -d ${D}${PTEST_PATH}/tests 28 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ 29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32 cp -rf ${S}/setup.py ${D}${PTEST_PATH} 30 cp -rf ${S}/setup.py ${D}${PTEST_PATH}