diff options
-rw-r--r-- | meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb new file mode 100644 index 0000000000..bdab389bcf --- /dev/null +++ b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | # Copyright (C) 2014-2015 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ | ||
6 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
7 | |||
8 | SUMMARY = "Set of Bluetooh related tools for inclusion on images" | ||
9 | DESCRIPTION = "Add bluetooth tools based on the version of BlueZ in use.\ | ||
10 | The tools that have been tested and work the best are pulled in \ | ||
11 | automatically. The same packagegroup can be used in a recipe without \ | ||
12 | the need to know which version of BlueZ is in use. \ | ||
13 | Supports BlueZ4 and BlueZ5." | ||
14 | |||
15 | inherit packagegroup | ||
16 | |||
17 | BLUEZ4_INSTALL = " \ | ||
18 | obexftp \ | ||
19 | " | ||
20 | |||
21 | BLUEZ5_INSTALL = " \ | ||
22 | bluez5-noinst-tools \ | ||
23 | bluez5-obex \ | ||
24 | bluez5-testtools \ | ||
25 | libasound-module-bluez \ | ||
26 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', "pulseaudio-module-bluetooth-discover \ | ||
27 | pulseaudio-module-bluetooth-policy \ | ||
28 | pulseaudio-module-bluez5-discover \ | ||
29 | pulseaudio-module-bluez5-device \ | ||
30 | pulseaudio-module-switch-on-connect \ | ||
31 | pulseaudio-module-loopback", \ | ||
32 | '', d)} \ | ||
33 | " | ||
34 | |||
35 | # Install either bluez4 or bluez5 if they are in distro. | ||
36 | # Otherwise install nothing. | ||
37 | RDEPENDS_${PN} = " \ | ||
38 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', '${BLUEZ5_INSTALL}', "", d)} \ | ||
39 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluez4', '${BLUEZ4_INSTALL}', "", d)} \ | ||
40 | " | ||