diff options
4 files changed, 22 insertions, 20 deletions
diff --git a/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch b/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch index 6c7f3bd30d..130f3c2290 100644 --- a/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch +++ b/meta-oe/recipes-multimedia/esound/esound/0001-audio_alsa09.c-alsa-drain-fix.patch | |||
@@ -1,9 +1,10 @@ | |||
1 | From a860fe0796c43e35eac9783140fcb563cab9f55a Mon Sep 17 00:00:00 2001 | 1 | From 945df2da87a412758ceab4ac5711abbb269a47c1 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Thu, 8 Jun 2017 23:09:51 -0700 | 3 | Date: Thu, 8 Jun 2017 23:09:51 -0700 |
4 | Subject: [PATCH 1/3] audio_alsa09.c: alsa drain fix | 4 | Subject: [PATCH] audio_alsa09.c: alsa drain fix |
5 | 5 | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
7 | |||
7 | --- | 8 | --- |
8 | audio_alsa09.c | 2 +- | 9 | audio_alsa09.c | 2 +- |
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | 10 | 1 file changed, 1 insertion(+), 1 deletion(-) |
@@ -21,6 +22,3 @@ index 534e3db..d9450e6 100644 | |||
21 | 22 | ||
22 | if (alsadbg) | 23 | if (alsadbg) |
23 | print_state(); | 24 | print_state(); |
24 | -- | ||
25 | 2.13.1 | ||
26 | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch b/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch index 337546abe9..10a6ba03ae 100644 --- a/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch +++ b/meta-oe/recipes-multimedia/esound/esound/0002-Undefine-open64-and-fopen64.patch | |||
@@ -1,11 +1,12 @@ | |||
1 | From 1fbee6e96384f340b816e221fe1c2f3ff0b487bf Mon Sep 17 00:00:00 2001 | 1 | From e218d5a0a545ebb9623d62da5cfca478f9c90fce Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Thu, 8 Jun 2017 23:11:31 -0700 | 3 | Date: Thu, 8 Jun 2017 23:11:31 -0700 |
4 | Subject: [PATCH 2/3] Undefine open64 and fopen64 | 4 | Subject: [PATCH] Undefine open64 and fopen64 |
5 | 5 | ||
6 | Since the signatures do not match with libc | 6 | Since the signatures do not match with libc |
7 | 7 | ||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
9 | |||
9 | --- | 10 | --- |
10 | esddsp.c | 2 ++ | 11 | esddsp.c | 2 ++ |
11 | 1 file changed, 2 insertions(+) | 12 | 1 file changed, 2 insertions(+) |
@@ -30,6 +31,3 @@ index d3c6ea9..17b5949 100644 | |||
30 | FILE * | 31 | FILE * |
31 | fopen64 (const char *path, const char *mode) | 32 | fopen64 (const char *path, const char *mode) |
32 | { | 33 | { |
33 | -- | ||
34 | 2.13.1 | ||
35 | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch b/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch index 62c880d9d0..83365b4e6f 100644 --- a/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch +++ b/meta-oe/recipes-multimedia/esound/esound/0003-Use-I-path-in-configure.patch | |||
@@ -1,12 +1,13 @@ | |||
1 | From 979a02d9ec9c28686021cd2b49ca55d2195c9dce Mon Sep 17 00:00:00 2001 | 1 | From 89c62db54716d514e639f9e1bfd3c1f7d82641dd Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Thu, 8 Jun 2017 23:12:36 -0700 | 3 | Date: Thu, 8 Jun 2017 23:12:36 -0700 |
4 | Subject: [PATCH 3/3] Use -I=<path> in configure | 4 | Subject: [PATCH] Use -I=<path> in configure |
5 | 5 | ||
6 | This helps to use proper sysroot in | 6 | This helps to use proper sysroot in |
7 | cross build environment | 7 | cross build environment |
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | |||
10 | --- | 11 | --- |
11 | configure.ac | 4 ++-- | 12 | configure.ac | 4 ++-- |
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | 13 | 1 file changed, 2 insertions(+), 2 deletions(-) |
@@ -33,6 +34,3 @@ index 5645dce..d374cda 100644 | |||
33 | SOUND_LIBS=-lmme | 34 | SOUND_LIBS=-lmme |
34 | esac | 35 | esac |
35 | fi | 36 | fi |
36 | -- | ||
37 | 2.13.1 | ||
38 | |||
diff --git a/meta-oe/recipes-multimedia/esound/esound/no-docs.patch b/meta-oe/recipes-multimedia/esound/esound/no-docs.patch index fc69f1a038..8a546e6db1 100644 --- a/meta-oe/recipes-multimedia/esound/esound/no-docs.patch +++ b/meta-oe/recipes-multimedia/esound/esound/no-docs.patch | |||
@@ -1,11 +1,19 @@ | |||
1 | Index: esound-0.2.36/Makefile.am | 1 | From bfcaa9bdc70440db96f10afc0c2a792870f75acb Mon Sep 17 00:00:00 2001 |
2 | =================================================================== | 2 | From: Koen Kooi <koen@dominion.thruhere.net> |
3 | --- esound-0.2.36.orig/Makefile.am | 3 | Date: Fri, 3 Jun 2011 19:39:02 +0200 |
4 | +++ esound-0.2.36/Makefile.am | 4 | |
5 | --- | ||
6 | Makefile.am | 2 +- | ||
7 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
8 | |||
9 | diff --git a/Makefile.am b/Makefile.am | ||
10 | index 08c4c94..ede9d26 100644 | ||
11 | --- a/Makefile.am | ||
12 | +++ b/Makefile.am | ||
5 | @@ -1,5 +1,5 @@ | 13 | @@ -1,5 +1,5 @@ |
6 | 14 | ||
7 | -SUBDIRS = docs | 15 | -SUBDIRS = docs |
8 | +SUBDIRS = | 16 | +SUBDIRS = |
9 | 17 | ||
10 | ACLOCAL_FLAGS = -I m4 | 18 | ACLOCAL_AMFLAGS = -I m4 |
11 | 19 | ||