diff options
-rw-r--r-- | meta-oe/recipes-security/nmap/files/0001-Include-time.h-header-to-pass-clang-compilation.patch (renamed from meta-oe/recipes-security/nmap/files/0001-include-time.h-for-time-structure-definition.patch) | 59 | ||||
-rw-r--r-- | meta-oe/recipes-security/nmap/nmap_7.80.bb (renamed from meta-oe/recipes-security/nmap/nmap_7.70.bb) | 8 |
2 files changed, 31 insertions, 36 deletions
diff --git a/meta-oe/recipes-security/nmap/files/0001-include-time.h-for-time-structure-definition.patch b/meta-oe/recipes-security/nmap/files/0001-Include-time.h-header-to-pass-clang-compilation.patch index 561c8c82cf..f93af2d793 100644 --- a/meta-oe/recipes-security/nmap/files/0001-include-time.h-for-time-structure-definition.patch +++ b/meta-oe/recipes-security/nmap/files/0001-Include-time.h-header-to-pass-clang-compilation.patch | |||
@@ -1,35 +1,39 @@ | |||
1 | From c774f2b129fd5acd5647d92c57a2079ae638a62b Mon Sep 17 00:00:00 2001 | 1 | From a068952a20880fc864e8cb8b49f8a6b143a5ac30 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Peiran Hong <peiran.hong@windriver.com> |
3 | Date: Sun, 20 Jan 2019 23:07:39 -0800 | 3 | Date: Fri, 20 Sep 2019 15:02:45 -0400 |
4 | Subject: [PATCH] include time.h for time structure definition | 4 | Subject: [PATCH] Include time.h header to pass clang compilation |
5 | 5 | ||
6 | Exposed by musl/clang | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | 6 | --- |
12 | nmap_error.cc | 1 + | 7 | nmap_error.cc | 11 +---------- |
13 | nping/EchoServer.cc | 1 + | 8 | nping/EchoServer.cc | 1 + |
14 | osscan.cc | 1 + | 9 | osscan2.cc | 1 + |
15 | osscan2.cc | 1 + | 10 | service_scan.cc | 1 + |
16 | service_scan.cc | 1 + | 11 | 4 files changed, 4 insertions(+), 10 deletions(-) |
17 | 5 files changed, 5 insertions(+) | ||
18 | 12 | ||
19 | diff --git a/nmap_error.cc b/nmap_error.cc | 13 | diff --git a/nmap_error.cc b/nmap_error.cc |
20 | index 19beafb..ea14e08 100644 | 14 | index 588b13c33..254107ff5 100644 |
21 | --- a/nmap_error.cc | 15 | --- a/nmap_error.cc |
22 | +++ b/nmap_error.cc | 16 | +++ b/nmap_error.cc |
23 | @@ -135,6 +135,7 @@ | 17 | @@ -135,16 +135,7 @@ |
24 | #include "xml.h" | 18 | #include "xml.h" |
25 | 19 | ||
26 | #include <errno.h> | 20 | #include <errno.h> |
21 | -#if TIME_WITH_SYS_TIME | ||
22 | -# include <sys/time.h> | ||
23 | -# include <time.h> | ||
24 | -#else | ||
25 | -# if HAVE_SYS_TIME_H | ||
26 | -# include <sys/time.h> | ||
27 | -# else | ||
28 | -# include <time.h> | ||
29 | -# endif | ||
30 | -#endif | ||
27 | +#include <time.h> | 31 | +#include <time.h> |
28 | 32 | ||
29 | extern NmapOps o; | 33 | extern NmapOps o; |
30 | 34 | ||
31 | diff --git a/nping/EchoServer.cc b/nping/EchoServer.cc | 35 | diff --git a/nping/EchoServer.cc b/nping/EchoServer.cc |
32 | index 70f39b0..40cd4d6 100644 | 36 | index ccdcf9c2d..c403aeda5 100644 |
33 | --- a/nping/EchoServer.cc | 37 | --- a/nping/EchoServer.cc |
34 | +++ b/nping/EchoServer.cc | 38 | +++ b/nping/EchoServer.cc |
35 | @@ -137,6 +137,7 @@ | 39 | @@ -137,6 +137,7 @@ |
@@ -40,20 +44,8 @@ index 70f39b0..40cd4d6 100644 | |||
40 | 44 | ||
41 | extern NpingOps o; | 45 | extern NpingOps o; |
42 | extern EchoServer es; | 46 | extern EchoServer es; |
43 | diff --git a/osscan.cc b/osscan.cc | ||
44 | index f851f60..6ae0c83 100644 | ||
45 | --- a/osscan.cc | ||
46 | +++ b/osscan.cc | ||
47 | @@ -149,6 +149,7 @@ | ||
48 | # include <time.h> | ||
49 | # endif | ||
50 | #endif | ||
51 | +#include <time.h> | ||
52 | |||
53 | #include <algorithm> | ||
54 | #include <list> | ||
55 | diff --git a/osscan2.cc b/osscan2.cc | 47 | diff --git a/osscan2.cc b/osscan2.cc |
56 | index e341947..887fbd2 100644 | 48 | index aa31feb12..89673e108 100644 |
57 | --- a/osscan2.cc | 49 | --- a/osscan2.cc |
58 | +++ b/osscan2.cc | 50 | +++ b/osscan2.cc |
59 | @@ -147,6 +147,7 @@ | 51 | @@ -147,6 +147,7 @@ |
@@ -65,7 +57,7 @@ index e341947..887fbd2 100644 | |||
65 | extern NmapOps o; | 57 | extern NmapOps o; |
66 | #ifdef WIN32 | 58 | #ifdef WIN32 |
67 | diff --git a/service_scan.cc b/service_scan.cc | 59 | diff --git a/service_scan.cc b/service_scan.cc |
68 | index 9780ae3..e07b940 100644 | 60 | index 57a92ed28..ef277bb1f 100644 |
69 | --- a/service_scan.cc | 61 | --- a/service_scan.cc |
70 | +++ b/service_scan.cc | 62 | +++ b/service_scan.cc |
71 | @@ -145,6 +145,7 @@ | 63 | @@ -145,6 +145,7 @@ |
@@ -76,3 +68,6 @@ index 9780ae3..e07b940 100644 | |||
76 | 68 | ||
77 | #if HAVE_OPENSSL | 69 | #if HAVE_OPENSSL |
78 | /* OpenSSL 1.0.0 needs _WINSOCKAPI_ to be defined, otherwise it loads | 70 | /* OpenSSL 1.0.0 needs _WINSOCKAPI_ to be defined, otherwise it loads |
71 | -- | ||
72 | 2.21.0 | ||
73 | |||
diff --git a/meta-oe/recipes-security/nmap/nmap_7.70.bb b/meta-oe/recipes-security/nmap/nmap_7.80.bb index b1b150a7d0..f24194da76 100644 --- a/meta-oe/recipes-security/nmap/nmap_7.70.bb +++ b/meta-oe/recipes-security/nmap/nmap_7.80.bb | |||
@@ -3,17 +3,17 @@ DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utili | |||
3 | SECTION = "security" | 3 | SECTION = "security" |
4 | LICENSE = "GPL-2.0" | 4 | LICENSE = "GPL-2.0" |
5 | 5 | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=1489288f46af415fadc4e8b6345ab9f4" | 6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=66938a7e5b4c118eda78271de14874c2" |
7 | 7 | ||
8 | SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \ | 8 | SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \ |
9 | file://nmap-redefine-the-python-library-dir.patch \ | 9 | file://nmap-redefine-the-python-library-dir.patch \ |
10 | file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \ | 10 | file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \ |
11 | file://0001-include-time.h-for-time-structure-definition.patch \ | 11 | file://0001-Include-time.h-header-to-pass-clang-compilation.patch \ |
12 | file://0002-Fix-building-with-libc.patch \ | 12 | file://0002-Fix-building-with-libc.patch \ |
13 | " | 13 | " |
14 | 14 | ||
15 | SRC_URI[md5sum] = "84eb6fbe788e0d4918c2b1e39421bf79" | 15 | SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5" |
16 | SRC_URI[sha256sum] = "847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18" | 16 | SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa" |
17 | 17 | ||
18 | inherit autotools-brokensep pkgconfig pythonnative | 18 | inherit autotools-brokensep pkgconfig pythonnative |
19 | 19 | ||