summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
new file mode 100644
index 0000000000..8929115fd7
--- /dev/null
+++ b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "A header only library for creating and validating json web tokens in c++"
2HOMEPAGE = "https://thalhammer.github.io/jwt-cpp/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8325a5ce4414c65ffdda392e0d96a9ff"
6
7SRC_URI = "git://github.com/Thalhammer/jwt-cpp.git;branch=master;protocol=https \
8 "
9
10SRCREV = "4a537e969891dde542ad8b1a4a214955a83be29f"
11
12S = "${WORKDIR}/git"
13
14DEPENDS = "openssl"
15
16inherit cmake
17
18EXTRA_OECMAKE += "-DJWT_BUILD_EXAMPLES=OFF -DJWT_CMAKE_FILES_INSTALL_DIR=${libdir}/cmake"