diff options
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort/not-hardcoded-libdir.patch | 279 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb | 1 |
2 files changed, 280 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort/not-hardcoded-libdir.patch b/meta-networking/recipes-connectivity/snort/snort/not-hardcoded-libdir.patch new file mode 100644 index 0000000000..075ec138b1 --- /dev/null +++ b/meta-networking/recipes-connectivity/snort/snort/not-hardcoded-libdir.patch | |||
@@ -0,0 +1,279 @@ | |||
1 | [PATCH] do not hardcoded libdir | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | libdir is hardcoded to ${exec_prefix}/lib, but we want it to support multilib | ||
6 | |||
7 | Signed-off-by: Roy.Li <rongqing.li@windriver.com> | ||
8 | --- | ||
9 | src/dynamic-examples/dynamic-preprocessor/Makefile.am | 2 +- | ||
10 | src/dynamic-examples/dynamic-rule/Makefile.am | 2 +- | ||
11 | src/dynamic-plugins/sf_engine/Makefile.am | 2 +- | ||
12 | src/dynamic-preprocessors/dcerpc2/Makefile.am | 2 +- | ||
13 | src/dynamic-preprocessors/dnp3/Makefile.am | 2 +- | ||
14 | src/dynamic-preprocessors/dns/Makefile.am | 2 +- | ||
15 | src/dynamic-preprocessors/file/Makefile.am | 2 +- | ||
16 | src/dynamic-preprocessors/ftptelnet/Makefile.am | 2 +- | ||
17 | src/dynamic-preprocessors/gtp/Makefile.am | 2 +- | ||
18 | src/dynamic-preprocessors/imap/Makefile.am | 2 +- | ||
19 | src/dynamic-preprocessors/modbus/Makefile.am | 2 +- | ||
20 | src/dynamic-preprocessors/pop/Makefile.am | 2 +- | ||
21 | src/dynamic-preprocessors/reputation/Makefile.am | 2 +- | ||
22 | src/dynamic-preprocessors/rzb_saac/Makefile.am | 2 +- | ||
23 | src/dynamic-preprocessors/sdf/Makefile.am | 2 +- | ||
24 | src/dynamic-preprocessors/sip/Makefile.am | 2 +- | ||
25 | src/dynamic-preprocessors/smtp/Makefile.am | 2 +- | ||
26 | src/dynamic-preprocessors/ssh/Makefile.am | 2 +- | ||
27 | src/dynamic-preprocessors/ssl/Makefile.am | 2 +- | ||
28 | 19 files changed, 19 insertions(+), 19 deletions(-) | ||
29 | |||
30 | diff --git a/src/dynamic-examples/dynamic-preprocessor/Makefile.am b/src/dynamic-examples/dynamic-preprocessor/Makefile.am | ||
31 | index 255755e..1cafead 100644 | ||
32 | --- a/src/dynamic-examples/dynamic-preprocessor/Makefile.am | ||
33 | +++ b/src/dynamic-examples/dynamic-preprocessor/Makefile.am | ||
34 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
35 | |||
36 | INCLUDES = -I../include | ||
37 | |||
38 | -noinst_libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
39 | +noinst_libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
40 | |||
41 | noinst_lib_LTLIBRARIES = lib_sfdynamic_preprocessor_example.la | ||
42 | |||
43 | diff --git a/src/dynamic-examples/dynamic-rule/Makefile.am b/src/dynamic-examples/dynamic-rule/Makefile.am | ||
44 | index e5338d2..82eb212 100644 | ||
45 | --- a/src/dynamic-examples/dynamic-rule/Makefile.am | ||
46 | +++ b/src/dynamic-examples/dynamic-rule/Makefile.am | ||
47 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
48 | |||
49 | INCLUDES = -I../include | ||
50 | |||
51 | -noinst_libdir = ${exec_prefix}/lib/snort_dynamicrules | ||
52 | +noinst_libdir = ${exec_prefix}${base_libdir}/snort_dynamicrules | ||
53 | |||
54 | noinst_lib_LTLIBRARIES = lib_sfdynamic_example_rule.la | ||
55 | |||
56 | diff --git a/src/dynamic-plugins/sf_engine/Makefile.am b/src/dynamic-plugins/sf_engine/Makefile.am | ||
57 | index d6a6200..3d270c3 100644 | ||
58 | --- a/src/dynamic-plugins/sf_engine/Makefile.am | ||
59 | +++ b/src/dynamic-plugins/sf_engine/Makefile.am | ||
60 | @@ -5,7 +5,7 @@ INCLUDES = @INCLUDES@ | ||
61 | |||
62 | lib_LTLIBRARIES = libsf_engine.la | ||
63 | |||
64 | -libdir = ${exec_prefix}/lib/snort_dynamicengine | ||
65 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicengine | ||
66 | |||
67 | libsf_engine_la_LDFLAGS = -export-dynamic -module @XCCFLAGS@ | ||
68 | |||
69 | diff --git a/src/dynamic-preprocessors/dcerpc2/Makefile.am b/src/dynamic-preprocessors/dcerpc2/Makefile.am | ||
70 | index 9843073..8a0caa5 100644 | ||
71 | --- a/src/dynamic-preprocessors/dcerpc2/Makefile.am | ||
72 | +++ b/src/dynamic-preprocessors/dcerpc2/Makefile.am | ||
73 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
74 | |||
75 | INCLUDES = -I../include -I${srcdir}/../libs -I$(srcdir)/includes | ||
76 | |||
77 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
78 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
79 | |||
80 | lib_LTLIBRARIES = libsf_dce2_preproc.la | ||
81 | |||
82 | diff --git a/src/dynamic-preprocessors/dnp3/Makefile.am b/src/dynamic-preprocessors/dnp3/Makefile.am | ||
83 | index 1358862..18e2178 100644 | ||
84 | --- a/src/dynamic-preprocessors/dnp3/Makefile.am | ||
85 | +++ b/src/dynamic-preprocessors/dnp3/Makefile.am | ||
86 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
87 | |||
88 | INCLUDES = -I../include -I${srcdir}/../libs | ||
89 | |||
90 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
91 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
92 | |||
93 | lib_LTLIBRARIES = libsf_dnp3_preproc.la | ||
94 | |||
95 | diff --git a/src/dynamic-preprocessors/dns/Makefile.am b/src/dynamic-preprocessors/dns/Makefile.am | ||
96 | index f22d90e..49d2f55 100644 | ||
97 | --- a/src/dynamic-preprocessors/dns/Makefile.am | ||
98 | +++ b/src/dynamic-preprocessors/dns/Makefile.am | ||
99 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
100 | |||
101 | INCLUDES = -I../include -I${srcdir}/../libs | ||
102 | |||
103 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
104 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
105 | |||
106 | lib_LTLIBRARIES = libsf_dns_preproc.la | ||
107 | |||
108 | diff --git a/src/dynamic-preprocessors/file/Makefile.am b/src/dynamic-preprocessors/file/Makefile.am | ||
109 | index d71c0fd..834f7ac 100644 | ||
110 | --- a/src/dynamic-preprocessors/file/Makefile.am | ||
111 | +++ b/src/dynamic-preprocessors/file/Makefile.am | ||
112 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
113 | |||
114 | INCLUDES = -I../include -I${srcdir}/../libs -I./include | ||
115 | |||
116 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
117 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
118 | |||
119 | lib_LTLIBRARIES = libsf_file_preproc.la | ||
120 | |||
121 | diff --git a/src/dynamic-preprocessors/ftptelnet/Makefile.am b/src/dynamic-preprocessors/ftptelnet/Makefile.am | ||
122 | index fe73835..3457231 100644 | ||
123 | --- a/src/dynamic-preprocessors/ftptelnet/Makefile.am | ||
124 | +++ b/src/dynamic-preprocessors/ftptelnet/Makefile.am | ||
125 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
126 | |||
127 | INCLUDES = -I../include -I${srcdir}/../libs -I$(srcdir)/includes | ||
128 | |||
129 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
130 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
131 | |||
132 | lib_LTLIBRARIES = libsf_ftptelnet_preproc.la | ||
133 | |||
134 | diff --git a/src/dynamic-preprocessors/gtp/Makefile.am b/src/dynamic-preprocessors/gtp/Makefile.am | ||
135 | index 51c961a..d7fb9b2 100644 | ||
136 | --- a/src/dynamic-preprocessors/gtp/Makefile.am | ||
137 | +++ b/src/dynamic-preprocessors/gtp/Makefile.am | ||
138 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
139 | |||
140 | INCLUDES = -I../include -I${srcdir}/../libs -I$(srcdir)/includes | ||
141 | |||
142 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
143 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
144 | |||
145 | lib_LTLIBRARIES = libsf_gtp_preproc.la | ||
146 | |||
147 | diff --git a/src/dynamic-preprocessors/imap/Makefile.am b/src/dynamic-preprocessors/imap/Makefile.am | ||
148 | index 533e43d..9efcbc4 100644 | ||
149 | --- a/src/dynamic-preprocessors/imap/Makefile.am | ||
150 | +++ b/src/dynamic-preprocessors/imap/Makefile.am | ||
151 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
152 | |||
153 | INCLUDES = -I../include -I${srcdir}/../libs | ||
154 | |||
155 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
156 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
157 | |||
158 | lib_LTLIBRARIES = libsf_imap_preproc.la | ||
159 | |||
160 | diff --git a/src/dynamic-preprocessors/modbus/Makefile.am b/src/dynamic-preprocessors/modbus/Makefile.am | ||
161 | index 05fc63e..e4f1415 100644 | ||
162 | --- a/src/dynamic-preprocessors/modbus/Makefile.am | ||
163 | +++ b/src/dynamic-preprocessors/modbus/Makefile.am | ||
164 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
165 | |||
166 | INCLUDES = -I../include -I${srcdir}/../libs | ||
167 | |||
168 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
169 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
170 | |||
171 | lib_LTLIBRARIES = libsf_modbus_preproc.la | ||
172 | |||
173 | diff --git a/src/dynamic-preprocessors/pop/Makefile.am b/src/dynamic-preprocessors/pop/Makefile.am | ||
174 | index d4b07b3..1345bc6 100644 | ||
175 | --- a/src/dynamic-preprocessors/pop/Makefile.am | ||
176 | +++ b/src/dynamic-preprocessors/pop/Makefile.am | ||
177 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
178 | |||
179 | INCLUDES = -I../include -I${srcdir}/../libs | ||
180 | |||
181 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
182 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
183 | |||
184 | lib_LTLIBRARIES = libsf_pop_preproc.la | ||
185 | |||
186 | diff --git a/src/dynamic-preprocessors/reputation/Makefile.am b/src/dynamic-preprocessors/reputation/Makefile.am | ||
187 | index 4e16142..14ba0cb 100644 | ||
188 | --- a/src/dynamic-preprocessors/reputation/Makefile.am | ||
189 | +++ b/src/dynamic-preprocessors/reputation/Makefile.am | ||
190 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
191 | |||
192 | INCLUDES = -I../include -I${srcdir}/../libs -I$(srcdir)/includes | ||
193 | |||
194 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
195 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
196 | |||
197 | lib_LTLIBRARIES = libsf_reputation_preproc.la | ||
198 | |||
199 | diff --git a/src/dynamic-preprocessors/rzb_saac/Makefile.am b/src/dynamic-preprocessors/rzb_saac/Makefile.am | ||
200 | index f0b0912..6ebe04e 100644 | ||
201 | --- a/src/dynamic-preprocessors/rzb_saac/Makefile.am | ||
202 | +++ b/src/dynamic-preprocessors/rzb_saac/Makefile.am | ||
203 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
204 | |||
205 | INCLUDES = -I../include -I${srcdir}/../libs | ||
206 | |||
207 | -pkglibdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
208 | +pkglibdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
209 | |||
210 | pkglib_LTLIBRARIES = sf_rzb_saac_preproc.la | ||
211 | |||
212 | diff --git a/src/dynamic-preprocessors/sdf/Makefile.am b/src/dynamic-preprocessors/sdf/Makefile.am | ||
213 | index 97b416e..04b5ce5 100644 | ||
214 | --- a/src/dynamic-preprocessors/sdf/Makefile.am | ||
215 | +++ b/src/dynamic-preprocessors/sdf/Makefile.am | ||
216 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
217 | |||
218 | INCLUDES = -I../include -I${srcdir}/../libs | ||
219 | |||
220 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
221 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
222 | |||
223 | lib_LTLIBRARIES = libsf_sdf_preproc.la | ||
224 | |||
225 | diff --git a/src/dynamic-preprocessors/sip/Makefile.am b/src/dynamic-preprocessors/sip/Makefile.am | ||
226 | index 67ac1e1..b4f360f 100644 | ||
227 | --- a/src/dynamic-preprocessors/sip/Makefile.am | ||
228 | +++ b/src/dynamic-preprocessors/sip/Makefile.am | ||
229 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
230 | |||
231 | INCLUDES = -I../include -I${srcdir}/../libs -I$(srcdir)/includes | ||
232 | |||
233 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
234 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
235 | |||
236 | lib_LTLIBRARIES = libsf_sip_preproc.la | ||
237 | |||
238 | diff --git a/src/dynamic-preprocessors/smtp/Makefile.am b/src/dynamic-preprocessors/smtp/Makefile.am | ||
239 | index 3b5893f..96750df 100644 | ||
240 | --- a/src/dynamic-preprocessors/smtp/Makefile.am | ||
241 | +++ b/src/dynamic-preprocessors/smtp/Makefile.am | ||
242 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
243 | |||
244 | INCLUDES = -I../include -I${srcdir}/../libs | ||
245 | |||
246 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
247 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
248 | |||
249 | lib_LTLIBRARIES = libsf_smtp_preproc.la | ||
250 | |||
251 | diff --git a/src/dynamic-preprocessors/ssh/Makefile.am b/src/dynamic-preprocessors/ssh/Makefile.am | ||
252 | index 0eab645..5ae9b80 100644 | ||
253 | --- a/src/dynamic-preprocessors/ssh/Makefile.am | ||
254 | +++ b/src/dynamic-preprocessors/ssh/Makefile.am | ||
255 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
256 | |||
257 | INCLUDES = -I../include -I${srcdir}/../libs | ||
258 | |||
259 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
260 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
261 | |||
262 | lib_LTLIBRARIES = libsf_ssh_preproc.la | ||
263 | |||
264 | diff --git a/src/dynamic-preprocessors/ssl/Makefile.am b/src/dynamic-preprocessors/ssl/Makefile.am | ||
265 | index 4ac2943..8d3abe3 100644 | ||
266 | --- a/src/dynamic-preprocessors/ssl/Makefile.am | ||
267 | +++ b/src/dynamic-preprocessors/ssl/Makefile.am | ||
268 | @@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS=foreign no-dependencies | ||
269 | |||
270 | INCLUDES = -I../include -I${srcdir}/../libs | ||
271 | |||
272 | -libdir = ${exec_prefix}/lib/snort_dynamicpreprocessor | ||
273 | +libdir = ${exec_prefix}${base_libdir}/snort_dynamicpreprocessor | ||
274 | |||
275 | lib_LTLIBRARIES = libsf_ssl_preproc.la | ||
276 | |||
277 | -- | ||
278 | 1.9.1 | ||
279 | |||
diff --git a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb index 9c55e9c65f..4d0e34218f 100644 --- a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb +++ b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb | |||
@@ -11,6 +11,7 @@ SRC_URI = " ${GENTOO_MIRROR}/${BP}.tar.gz;name=tarball \ | |||
11 | file://disable-inaddr-none.patch \ | 11 | file://disable-inaddr-none.patch \ |
12 | file://disable-dap-address-space-id.patch \ | 12 | file://disable-dap-address-space-id.patch \ |
13 | file://0001-libpcap-search-sysroot-for-headers.patch \ | 13 | file://0001-libpcap-search-sysroot-for-headers.patch \ |
14 | file://not-hardcoded-libdir.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | SRC_URI[tarball.md5sum] = "18111f6de3989ca89add36077a7c2659" | 17 | SRC_URI[tarball.md5sum] = "18111f6de3989ca89add36077a7c2659" |