diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch | 40 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-requests_2.26.0.bb (renamed from meta-python/recipes-devtools/python/python3-requests_2.25.1.bb) | 4 |
2 files changed, 1 insertions, 43 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch b/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch deleted file mode 100644 index 26332249da..0000000000 --- a/meta-python/recipes-devtools/python/python3-requests/setup.py-Support-idna-version-3.1.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From fc45beed40a86c8fc38fc430765c1c5d2c9961c2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Fabio Berton <fabio.berton@ossystems.com.br> | ||
3 | Date: Thu, 4 Mar 2021 09:26:48 -0300 | ||
4 | Subject: [PATCH] setup.py: Support idna version 3.1 | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | Change idna required version to use python3-idna recipe that currently | ||
8 | is on version 3.1. | ||
9 | |||
10 | Without this change python-request doesn't work as the idna version | ||
11 | doesn't match the required versions. When bump python-request recipe, | ||
12 | verify if the upstream project bumped the idna version and drop this | ||
13 | patch. | ||
14 | |||
15 | As this recipe was tested with python3-idna_3.1 don't allow higher | ||
16 | versions. | ||
17 | |||
18 | Upstream-Status: Inappropriate [embedded specific] | ||
19 | |||
20 | Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> | ||
21 | --- | ||
22 | setup.py | 2 +- | ||
23 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
24 | |||
25 | diff --git a/setup.py b/setup.py | ||
26 | index 7ba4b2a2..9d3b973e 100755 | ||
27 | --- a/setup.py | ||
28 | +++ b/setup.py | ||
29 | @@ -43,7 +43,7 @@ packages = ['requests'] | ||
30 | |||
31 | requires = [ | ||
32 | 'chardet>=3.0.2,<5', | ||
33 | - 'idna>=2.5,<3', | ||
34 | + 'idna>=2.5,<3.2', | ||
35 | 'urllib3>=1.21.1,<1.27', | ||
36 | 'certifi>=2017.4.17' | ||
37 | |||
38 | -- | ||
39 | 2.30.1 | ||
40 | |||
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.25.1.bb b/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb index cea8fd5178..95e6e1a6b6 100644 --- a/meta-python/recipes-devtools/python/python3-requests_2.25.1.bb +++ b/meta-python/recipes-devtools/python/python3-requests_2.26.0.bb | |||
@@ -3,9 +3,7 @@ HOMEPAGE = "http://python-requests.org" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" |
5 | 5 | ||
6 | SRC_URI += "file://setup.py-Support-idna-version-3.1.patch" | 6 | SRC_URI[sha256sum] = "b8aa58f8cf793ffd8782d3d8cb19e66ef36f7aba4353eec859e74678b01b07a7" |
7 | |||
8 | SRC_URI[sha256sum] = "27973dd4a904a4f13b263a19c866c13b92a39ed1c964655f025f3f8d3d75b804" | ||
9 | 7 | ||
10 | inherit pypi setuptools3 | 8 | inherit pypi setuptools3 |
11 | 9 | ||