summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch6
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch44
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan_0.106.bb (renamed from meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan_0.104.bb)5
3 files changed, 5 insertions, 50 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
index 613858f6fd..b8c48d5403 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
+++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-do-not-use-Werror.patch
@@ -10,7 +10,7 @@ Signed-off-by: Alexander Kanavin <alex@linutronix.de>
10 1 file changed, 1 deletion(-) 10 1 file changed, 1 deletion(-)
11 11
12diff --git a/Makefile b/Makefile 12diff --git a/Makefile b/Makefile
13index 0368e41..53d6a9d 100644 13index 97973ce..78273ff 100644
14--- a/Makefile 14--- a/Makefile
15+++ b/Makefile 15+++ b/Makefile
16@@ -8,7 +8,6 @@ BUILDFLAGS = \ 16@@ -8,7 +8,6 @@ BUILDFLAGS = \
@@ -20,7 +20,7 @@ index 0368e41..53d6a9d 100644
20- -Werror \ 20- -Werror \
21 $(NULL) 21 $(NULL)
22 22
23 SRCS = \ 23 TESTFLAGS = \
24-- 24--
252.25.1 252.34.1
26 26
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
deleted file mode 100644
index 2149ee30cd..0000000000
--- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan/0001-Makefile-fix-parallel-build-failure.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From 2e84550b47b475d830622f41576992a1d45d6af0 Mon Sep 17 00:00:00 2001
2From: Zhao Yi <38274519+yizhao1@users.noreply.github.com>
3Date: Tue, 15 Mar 2022 19:28:26 +0800
4Subject: [PATCH] Makefile: fix parallel build failure (#267)
5
6* Makefile: fix parallel build failure
7
8Add src/_features.h as dependency for dbus.o to fix the parallel build
9failure:
10src/dbus.c:17:10: fatal error: _features.h: No such file or directory
11
12Upstream-Status: Backport
13[https://github.com/canonical/netplan/commit/2e84550b47b475d830622f41576992a1d45d6af0]
14
15Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
16---
17 Makefile | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/Makefile b/Makefile
21index 0368e41..8ac7432 100644
22--- a/Makefile
23+++ b/Makefile
24@@ -52,7 +52,7 @@ NOSETESTS3 ?= $(shell command -v nosetests-3 || command -v nosetests3 || echo tr
25
26 default: netplan/_features.py generate netplan-dbus dbus/io.netplan.Netplan.service doc/netplan.html doc/netplan.5 doc/netplan-generate.8 doc/netplan-apply.8 doc/netplan-try.8 doc/netplan-dbus.8 doc/netplan-get.8 doc/netplan-set.8
27
28-%.o: src/%.c
29+%.o: src/%.c src/_features.h
30 $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -c $^ `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
31
32 libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
33@@ -62,7 +62,7 @@ libnetplan.so.$(NETPLAN_SOVER): $(SRCS) abicompat.lds
34 generate: libnetplan.so.$(NETPLAN_SOVER) generate.o
35 $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$^) -L. -lnetplan `pkg-config --cflags --libs glib-2.0 gio-2.0 yaml-0.1 uuid`
36
37-netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) src/_features.h dbus.o
38+netplan-dbus: libnetplan.so.$(NETPLAN_SOVER) dbus.o
39 $(CC) $(BUILDFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(filter-out $<,$(patsubst %.h,,$^)) -L. -lnetplan `pkg-config --cflags --libs libsystemd glib-2.0 gio-2.0 yaml-0.1 uuid`
40
41 src/_features.h: src/[^_]*.[hc]
42--
432.25.1
44
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan_0.104.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan_0.106.bb
index ea944fa9db..b7fe7ae3ed 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan_0.104.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/netplan/netplan_0.106.bb
@@ -11,12 +11,11 @@ LICENSE = "GPL-3.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14SRCREV = "3e522b7255310bdecca6c781137741dfc4abc021" 14SRCREV = "15ce044d1df27b5057556d84d0d14beef8dd4e4d"
15PV = "0.104" 15PV = "0.106"
16 16
17SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \ 17SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main;protocol=https \
18 file://0001-Makefile-do-not-use-Werror.patch \ 18 file://0001-Makefile-do-not-use-Werror.patch \
19 file://0001-Makefile-fix-parallel-build-failure.patch \
20 " 19 "
21 20
22SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch" 21SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"