summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/h-test.patch10
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_2.8.bb1
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
new file mode 100644
index 0000000000..9f07c73803
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
@@ -0,0 +1,10 @@
1--- a/tests/hypothesis/__init__.py
2+++ b/tests/hypothesis/__init__.py
3@@ -3,3 +3,7 @@
4 # for complete details.
5
6 from __future__ import absolute_import, division, print_function
7+
8+import pytest
9+hypothesis = pytest.importorskip("hypothesis")
10+
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb
index c75dabb974..95e903b290 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb
+++ b/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb
@@ -11,6 +11,7 @@ SRC_URI[sha256sum] = "3cda1f0ed8747339bbdf71b9f38ca74c7b592f24f65cdb3ab3765e4b02
11 11
12SRC_URI += " \ 12SRC_URI += " \
13 file://run-ptest \ 13 file://run-ptest \
14 file://h-test.patch \
14" 15"
15 16
16inherit pypi setuptools3 17inherit pypi setuptools3