diff options
-rw-r--r-- | meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch | 19 | ||||
-rw-r--r-- | meta-oe/recipes-support/openipmi/files/openipmi-don-t-rm-.libs.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-support/openipmi/files/openipmi-remove-host-path-from-la_LDFLAGS.patch | 81 | ||||
-rw-r--r-- | meta-oe/recipes-support/openipmi/openipmi_2.0.24.bb (renamed from meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb) | 9 |
4 files changed, 26 insertions, 115 deletions
diff --git a/meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch b/meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch deleted file mode 100644 index 271c5323fd..0000000000 --- a/meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | Add LDFLAGS variable to Makefile.am, make sure the extra linker flags can be passed. | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
6 | |||
7 | diff --git a/swig/perl/Makefile.am b/swig/perl/Makefile.am | ||
8 | index 2f9ee4c..3a18892 100644 | ||
9 | --- a/swig/perl/Makefile.am | ||
10 | +++ b/swig/perl/Makefile.am | ||
11 | @@ -20,7 +20,7 @@ OpenIPMI_SRC = OpenIPMI_perl.c | ||
12 | OpenIPMI_OBJ = OpenIPMI_wrap.lo OpenIPMI_perl.lo | ||
13 | |||
14 | OpenIPMI.so: $(OpenIPMI_OBJ) | ||
15 | - $(LIBTOOL) --mode=link $(CC) -shared -module -avoid-version -o $(@:.so=.la) $^ $(OPENIPMI_SWIG_LIBS) $(PERL_POSIX_LIB) -rpath $(PERL_INSTALL_DIR)/auto/OpenIPMI | ||
16 | + $(LIBTOOL) --mode=link $(CC) -shared -module -avoid-version $(LDFLAGS) -o $(@:.so=.la) $^ $(OPENIPMI_SWIG_LIBS) $(PERL_POSIX_LIB) -rpath $(PERL_INSTALL_DIR)/auto/OpenIPMI | ||
17 | rm -f OpenIPMI.so | ||
18 | mv .libs/OpenIPMI.so . | ||
19 | |||
diff --git a/meta-oe/recipes-support/openipmi/files/openipmi-don-t-rm-.libs.patch b/meta-oe/recipes-support/openipmi/files/openipmi-don-t-rm-.libs.patch deleted file mode 100644 index ee3c660433..0000000000 --- a/meta-oe/recipes-support/openipmi/files/openipmi-don-t-rm-.libs.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From bbd51cf010c80322034f7094e2c6a656aa1f17a7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Wenzong Fan <wenzong.fan@windriver.com> | ||
3 | Date: Fri, 13 Feb 2015 06:55:33 +0000 | ||
4 | Subject: [PATCH] openipmi: don't rm .libs | ||
5 | |||
6 | Don't remove .libs after OpenIPMI.so generated, this may cause | ||
7 | dummystuff.so fails to link from the second build with error: | ||
8 | |||
9 | * error: .libs/dummystuff.o: No such file or directory | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> | ||
14 | --- | ||
15 | swig/perl/Makefile.am | 1 - | ||
16 | 1 file changed, 1 deletion(-) | ||
17 | |||
18 | diff --git a/swig/perl/Makefile.am b/swig/perl/Makefile.am | ||
19 | index 12a282c..2f9ee4c 100644 | ||
20 | --- a/swig/perl/Makefile.am | ||
21 | +++ b/swig/perl/Makefile.am | ||
22 | @@ -23,7 +23,6 @@ OpenIPMI.so: $(OpenIPMI_OBJ) | ||
23 | $(LIBTOOL) --mode=link $(CC) -shared -module -avoid-version -o $(@:.so=.la) $^ $(OPENIPMI_SWIG_LIBS) $(PERL_POSIX_LIB) -rpath $(PERL_INSTALL_DIR)/auto/OpenIPMI | ||
24 | rm -f OpenIPMI.so | ||
25 | mv .libs/OpenIPMI.so . | ||
26 | - rm -rf .libs | ||
27 | |||
28 | dummystuff.lo: dummystuff.c | ||
29 | $(LIBTOOL) --mode=compile $(COMPILE) -c $< | ||
30 | -- | ||
31 | 1.9.1 | ||
32 | |||
diff --git a/meta-oe/recipes-support/openipmi/files/openipmi-remove-host-path-from-la_LDFLAGS.patch b/meta-oe/recipes-support/openipmi/files/openipmi-remove-host-path-from-la_LDFLAGS.patch index 6f16234bc7..83485a9e60 100644 --- a/meta-oe/recipes-support/openipmi/files/openipmi-remove-host-path-from-la_LDFLAGS.patch +++ b/meta-oe/recipes-support/openipmi/files/openipmi-remove-host-path-from-la_LDFLAGS.patch | |||
@@ -13,73 +13,38 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | |||
13 | unix/Makefile.am | 4 ++-- | 13 | unix/Makefile.am | 4 ++-- |
14 | 4 files changed, 6 insertions(+), 6 deletions(-) | 14 | 4 files changed, 6 insertions(+), 6 deletions(-) |
15 | 15 | ||
16 | diff --git a/cmdlang/Makefile.am b/cmdlang/Makefile.am | 16 | Index: OpenIPMI-2.0.24/cmdlang/Makefile.am |
17 | index 00c3d2b..0fa85d7 100644 | 17 | =================================================================== |
18 | --- a/cmdlang/Makefile.am | 18 | --- OpenIPMI-2.0.24.orig/cmdlang/Makefile.am |
19 | +++ b/cmdlang/Makefile.am | 19 | +++ OpenIPMI-2.0.24/cmdlang/Makefile.am |
20 | @@ -16,7 +16,7 @@ libOpenIPMIcmdlang_la_LIBADD = -lm \ | 20 | @@ -15,8 +15,7 @@ libOpenIPMIcmdlang_la_SOURCES = cmdlang. |
21 | libOpenIPMIcmdlang_la_LIBADD = -lm \ | ||
21 | $(top_builddir)/utils/libOpenIPMIutils.la \ | 22 | $(top_builddir)/utils/libOpenIPMIutils.la \ |
22 | $(top_builddir)/lib/libOpenIPMI.la | 23 | $(top_builddir)/lib/libOpenIPMI.la |
23 | libOpenIPMIcmdlang_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ | 24 | -libOpenIPMIcmdlang_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ |
24 | - -Wl,-Map -Wl,libOpenIPMIcmdlang.map -L$(libdir) | 25 | - -L$(libdir) |
25 | + -Wl,-Map -Wl,libOpenIPMIcmdlang.map | 26 | +libOpenIPMIcmdlang_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) |
26 | 27 | ||
27 | bin_PROGRAMS = openipmish | 28 | bin_PROGRAMS = openipmish |
28 | 29 | ||
29 | diff --git a/glib/Makefile.am b/glib/Makefile.am | 30 | Index: OpenIPMI-2.0.24/unix/Makefile.am |
30 | index 671cae2..eff55f3 100644 | 31 | =================================================================== |
31 | --- a/glib/Makefile.am | 32 | --- OpenIPMI-2.0.24.orig/unix/Makefile.am |
32 | +++ b/glib/Makefile.am | 33 | +++ OpenIPMI-2.0.24/unix/Makefile.am |
33 | @@ -11,14 +11,14 @@ libOpenIPMIglib_la_SOURCES = glib_os_hnd.c | 34 | @@ -10,14 +10,12 @@ lib_LTLIBRARIES = libOpenIPMIposix.la li |
34 | libOpenIPMIglib_la_CFLAGS = $(GLIB_CFLAGS) $(AM_CFLAGS) | 35 | libOpenIPMIpthread_la_SOURCES = posix_thread_os_hnd.c selector.c |
35 | libOpenIPMIglib_la_LIBADD = $(GDBM_LIB) | ||
36 | libOpenIPMIglib_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ | ||
37 | - -Wl,-Map -Wl,libOpenIPMIglib.map $(GLIB_LIBS) -L$(libdir) \ | ||
38 | + -Wl,-Map -Wl,libOpenIPMIglib.map $(GLIB_LIBS) \ | ||
39 | -rpath $(libdir) | ||
40 | |||
41 | libOpenIPMIglib12_la_SOURCES = glib_os_hnd.c | ||
42 | libOpenIPMIglib12_la_CFLAGS = $(GLIB12_CFLAGS) $(AM_CFLAGS) | ||
43 | libOpenIPMIglib12_la_LIBADD = $(GDBM_LIB) | ||
44 | libOpenIPMIglib12_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ | ||
45 | - -Wl,-Map -Wl,libOpenIPMIglib12.map $(GLIB12_LIBS) -L$(libdir) \ | ||
46 | + -Wl,-Map -Wl,libOpenIPMIglib12.map $(GLIB12_LIBS) \ | ||
47 | -rpath $(libdir) | ||
48 | |||
49 | CLEANFILES = libOpenIPMIglib.map libOpenIPMIglib12.map | ||
50 | diff --git a/tcl/Makefile.am b/tcl/Makefile.am | ||
51 | index b702819..282619c 100644 | ||
52 | --- a/tcl/Makefile.am | ||
53 | +++ b/tcl/Makefile.am | ||
54 | @@ -11,7 +11,7 @@ libOpenIPMItcl_la_SOURCES = tcl_os_hnd.c | ||
55 | libOpenIPMItcl_la_CFLAGS = $(TCL_CFLAGS) $(AM_CFLAGS) | ||
56 | libOpenIPMItcl_la_LIBADD = $(GDBM_LIB) | ||
57 | libOpenIPMItcl_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ | ||
58 | - -Wl,-Map -Wl,libOpenIPMItcl.map $(TCL_LIBS) -L$(libdir) \ | ||
59 | + -Wl,-Map -Wl,libOpenIPMItcl.map $(TCL_LIBS) \ | ||
60 | -rpath $(libdir) | ||
61 | |||
62 | noinst_PROGRAMS = test_handlers | ||
63 | diff --git a/unix/Makefile.am b/unix/Makefile.am | ||
64 | index a792147..a108bc6 100644 | ||
65 | --- a/unix/Makefile.am | ||
66 | +++ b/unix/Makefile.am | ||
67 | @@ -11,13 +11,13 @@ libOpenIPMIpthread_la_SOURCES = posix_thread_os_hnd.c selector.c | ||
68 | libOpenIPMIpthread_la_LIBADD = -lpthread $(GDBM_LIB) \ | 36 | libOpenIPMIpthread_la_LIBADD = -lpthread $(GDBM_LIB) \ |
69 | $(top_builddir)/utils/libOpenIPMIutils.la | 37 | $(top_builddir)/utils/libOpenIPMIutils.la $(RT_LIB) |
70 | libOpenIPMIpthread_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ | 38 | -libOpenIPMIpthread_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ |
71 | - -Wl,-Map -Wl,libOpenIPMIpthread.map -L$(libdir) | 39 | - -L$(libdir) |
72 | + -Wl,-Map -Wl,libOpenIPMIpthread.map | 40 | +libOpenIPMIpthread_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) |
73 | 41 | ||
74 | libOpenIPMIposix_la_SOURCES = posix_os_hnd.c selector.c | 42 | libOpenIPMIposix_la_SOURCES = posix_os_hnd.c selector.c |
75 | libOpenIPMIposix_la_LIBADD = $(top_builddir)/utils/libOpenIPMIutils.la \ | 43 | libOpenIPMIposix_la_LIBADD = $(top_builddir)/utils/libOpenIPMIutils.la \ |
76 | $(GDBM_LIB) | 44 | $(GDBM_LIB) $(RT_LIB) |
77 | libOpenIPMIposix_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ | 45 | -libOpenIPMIposix_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \ |
78 | - -Wl,-Map -Wl,libOpenIPMIposix.map -L$(libdir) | 46 | - -L$(libdir) |
79 | + -Wl,-Map -Wl,libOpenIPMIposix.map | 47 | +libOpenIPMIposix_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) |
80 | 48 | ||
81 | noinst_HEADERS = heap.h | 49 | noinst_HEADERS = heap.h |
82 | 50 | ||
83 | -- | ||
84 | 1.7.1 | ||
85 | |||
diff --git a/meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb b/meta-oe/recipes-support/openipmi/openipmi_2.0.24.bb index 9f4b0ff266..40395a35c0 100644 --- a/meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb +++ b/meta-oe/recipes-support/openipmi/openipmi_2.0.24.bb | |||
@@ -26,19 +26,16 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/openipmi/OpenIPMI-${PV}.tar.gz \ | |||
26 | file://fix-symlink-install-error-in-cmdlang.patch \ | 26 | file://fix-symlink-install-error-in-cmdlang.patch \ |
27 | file://openipmi-no-openipmigui-man.patch \ | 27 | file://openipmi-no-openipmigui-man.patch \ |
28 | file://openipmi-remove-host-path-from-la_LDFLAGS.patch \ | 28 | file://openipmi-remove-host-path-from-la_LDFLAGS.patch \ |
29 | file://openipmi-don-t-rm-.libs.patch \ | ||
30 | file://ipmi-init-fix-the-arguments.patch \ | 29 | file://ipmi-init-fix-the-arguments.patch \ |
31 | file://makefile-add-ldflags.patch \ | ||
32 | file://do-not-install-pyc-and-pyo.patch \ | 30 | file://do-not-install-pyc-and-pyo.patch \ |
33 | file://include_sys_types.patch \ | 31 | file://include_sys_types.patch \ |
34 | file://openipmi-helper \ | 32 | file://openipmi-helper \ |
35 | file://ipmi.service \ | 33 | file://ipmi.service \ |
36 | " | 34 | " |
37 | 35 | ||
38 | SRC_URI[md5sum] = "9a4e1f6bb073379c494839201ea10aee" | ||
39 | SRC_URI[sha256sum] = "4988900043c35fcfa9b2bf275d6593904f6429221befb770ba6ecb5502108e55" | ||
40 | |||
41 | S = "${WORKDIR}/OpenIPMI-${PV}" | 36 | S = "${WORKDIR}/OpenIPMI-${PV}" |
37 | SRC_URI[md5sum] = "58f9542cbfcb5fe250b77cf88345e1ec" | ||
38 | SRC_URI[sha256sum] = "bca39a27071278a8b74610181ede8df51e155e5e9031bc8eaa3699d1720292b4" | ||
42 | 39 | ||
43 | inherit autotools-brokensep pkgconfig pythonnative perlnative update-rc.d systemd | 40 | inherit autotools-brokensep pkgconfig pythonnative perlnative update-rc.d systemd |
44 | 41 | ||
@@ -46,7 +43,7 @@ EXTRA_OECONF = "--disable-static \ | |||
46 | --with-perl='${STAGING_BINDIR_NATIVE}/perl-native/perl' \ | 43 | --with-perl='${STAGING_BINDIR_NATIVE}/perl-native/perl' \ |
47 | --with-python='${STAGING_BINDIR_NATIVE}/python-native/python' \ | 44 | --with-python='${STAGING_BINDIR_NATIVE}/python-native/python' \ |
48 | --with-pythoninstall='${PYTHON_SITEPACKAGES_DIR}' \ | 45 | --with-pythoninstall='${PYTHON_SITEPACKAGES_DIR}' \ |
49 | --with-glibver=2.0 --with-glib12=no" | 46 | --with-glibver=2.0" |
50 | 47 | ||
51 | PACKAGECONFIG ??= "gdbm" | 48 | PACKAGECONFIG ??= "gdbm" |
52 | PACKAGECONFIG[gdbm] = "ac_cv_header_gdbm_h=yes,ac_cv_header_gdbm_h=no,gdbm," | 49 | PACKAGECONFIG[gdbm] = "ac_cv_header_gdbm_h=yes,ac_cv_header_gdbm_h=no,gdbm," |