summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/enscript/enscript/0001-enscript-does-not-build-with-C23-standard.patch32
-rw-r--r--meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch3
-rw-r--r--meta-oe/recipes-extended/enscript/enscript_1.6.6.bb1
3 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/enscript/enscript/0001-enscript-does-not-build-with-C23-standard.patch b/meta-oe/recipes-extended/enscript/enscript/0001-enscript-does-not-build-with-C23-standard.patch
new file mode 100644
index 0000000000..28f6764319
--- /dev/null
+++ b/meta-oe/recipes-extended/enscript/enscript/0001-enscript-does-not-build-with-C23-standard.patch
@@ -0,0 +1,32 @@
1From 9865262d7287320eba7d2fad2d4fcb12b489fc6c Mon Sep 17 00:00:00 2001
2From: zdohnal <email-is-unavailable>
3Date: Tue, 8 Apr 2025 20:25:47 +0900
4Subject: [PATCH] enscript does not build with C23 standard
5
6* Imported the submitted patch from:
7 https://savannah.gnu.org/bugs/?66845
8 to fix:
9 http://errors.yoctoproject.org/Errors/Details/851187/
10 ../../enscript-1.6.6/compat/regex.c:3565:13: error: too many arguments to function 're_match_2_internal'; expected 0, have 8
11 3565 | val = re_match_2_internal (bufp, string1, size1, string2, size2,
12 | ^~~~~~~~~~~~~~~~~~~ ~~~~
13
14Upstream-Status: Submitted [https://savannah.gnu.org/bugs/?66845]
15Signed-off-by: mark.yang <mark.yang@lge.com>
16---
17 compat/regex.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/compat/regex.c b/compat/regex.c
21index c6907f3..da28664 100644
22--- a/compat/regex.c
23+++ b/compat/regex.c
24@@ -336,7 +336,7 @@ typedef char boolean;
25 #define false 0
26 #define true 1
27
28-static int re_match_2_internal ();
29+static int re_match_2_internal (struct re_pattern_buffer*, const char*, int, const char*, int, int, struct re_registers*, int);
30
31 /* These are the command codes that appear in compiled regular
32 expressions. Some opcodes are followed by argument bytes. A
diff --git a/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch b/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch
index a080b3aef7..e84c2d3937 100644
--- a/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch
+++ b/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch
@@ -3,9 +3,10 @@ From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 2 Sep 2022 21:24:27 -0700 3Date: Fri, 2 Sep 2022 21:24:27 -0700
4Subject: [PATCH] getopt: Include string.h for strcmp/stcncmp functions 4Subject: [PATCH] getopt: Include string.h for strcmp/stcncmp functions
5 5
6Upstream-Status: Pending
7 6
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8Upstream-Status: Backport [http://git.savannah.gnu.org/gitweb/?p=enscript.git;a=commit;h=300ecf85a8fe166a39f9dd818945c7b8a970db39]
9Signed-off-by: mark.yang <mark.yang@lge.com>
9--- 10---
10 compat/getopt.c | 1 + 11 compat/getopt.c | 1 +
11 1 file changed, 1 insertion(+) 12 1 file changed, 1 insertion(+)
diff --git a/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb b/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb
index f6400213c0..4ca7c081ea 100644
--- a/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb
+++ b/meta-oe/recipes-extended/enscript/enscript_1.6.6.bb
@@ -14,6 +14,7 @@ SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
14 file://enscript-autoconf.patch \ 14 file://enscript-autoconf.patch \
15 file://0001-Fix-builds-with-recent-gettext.patch \ 15 file://0001-Fix-builds-with-recent-gettext.patch \
16 file://0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch \ 16 file://0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch \
17 file://0001-enscript-does-not-build-with-C23-standard.patch \
17 " 18 "
18 19
19inherit autotools gettext 20inherit autotools gettext