diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-chardet.inc | 23 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb | 29 |
2 files changed, 23 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python-chardet.inc b/meta-python/recipes-devtools/python/python-chardet.inc deleted file mode 100644 index 6305299780..0000000000 --- a/meta-python/recipes-devtools/python/python-chardet.inc +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | SUMMARY = "Universal encoding detector for Python 2 and 3" | ||
2 | LICENSE = "LGPL-2.1" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343" | ||
4 | |||
5 | inherit pypi | ||
6 | |||
7 | # setup.py of chardet needs this. | ||
8 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | ||
9 | |||
10 | SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c" | ||
11 | SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae" | ||
12 | |||
13 | BBCLASSEXTEND = "native nativesdk" | ||
14 | |||
15 | PACKAGES =+ "${PN}-cli" | ||
16 | RDEPENDS_${PN}-cli = "${PN} " | ||
17 | FILES_${PN}-cli += " \ | ||
18 | ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS_${PN}_class-target += " \ | ||
22 | ${PYTHON_PN}-logging \ | ||
23 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb index 38d8122ce9..80785b8d4e 100644 --- a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb +++ b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb | |||
@@ -1,7 +1,24 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Universal encoding detector for Python 2 and 3" |
2 | require python-chardet.inc | 2 | LICENSE = "LGPL-2.1" |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343" | ||
3 | 4 | ||
4 | do_install_append () { | 5 | SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c" |
5 | # rename scripts that would conflict with the Python 2 build of chardet | 6 | SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae" |
6 | mv ${D}${bindir}/chardetect ${D}${bindir}/chardetect3 | 7 | |
7 | } | 8 | # setup.py of chardet needs this. |
9 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | PACKAGES =+ "${PN}-cli" | ||
14 | FILES_${PN}-cli += " \ | ||
15 | ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS_${PN}-cli = "${PN} " | ||
19 | |||
20 | RDEPENDS_${PN}_class-target += " \ | ||
21 | ${PYTHON_PN}-logging \ | ||
22 | " | ||
23 | |||
24 | BBCLASSEXTEND = "native nativesdk" | ||