summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-kernel/drgn/python3-drgn_0.0.27.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/drgn/python3-drgn_0.0.27.bb b/meta-oe/recipes-kernel/drgn/python3-drgn_0.0.27.bb
new file mode 100644
index 0000000000..10d7c6ffda
--- /dev/null
+++ b/meta-oe/recipes-kernel/drgn/python3-drgn_0.0.27.bb
@@ -0,0 +1,80 @@
1SUMMARY = "drgn (pronounced dragon) is a debugger with an emphasis on \
2programmability. drgn exposes the types and variables in a program for easy, \
3expressive scripting in Python."
4HOMEPAGE = "https://github.com/osandov/drgn"
5LICENSE = " LGPL-2.1-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7c83d30e99508d6b790eacdd3abab846"
7
8SRC_URI = "git://github.com/osandov/drgn.git;protocol=https;branch=main"
9SRCREV = "a8dfc9e31f551d4b3c3d4307fa19ab6b3bfafb1c"
10
11S = "${WORKDIR}/git"
12
13DEPENDS = "\
14 autoconf-native \
15 automake-native \
16 libtool-native \
17 elfutils \
18 "
19
20DEPENDS:append:toolchain-clang:class-target ="\
21 openmp \
22 "
23
24OPENMP_LIB = "libgomp"
25OPENMP_LIB:toolchain-clang:class-target = "openmp"
26
27RDEPENDS:${PN} = "\
28 python3-crypt \
29 python3-io \
30 python3-logging \
31 python3-math \
32 python3-pickle \
33 python3-stringold \
34 python3-compression \
35 "
36
37RDEPENDS:${PN}:append:class-target = "\
38 libdw \
39 libelf \
40 ${OPENMP_LIB} \
41 "
42
43RDEPENDS:${PN}:append:class-native = "\
44 elfutils-native \
45 "
46
47RDEPENDS:${PN}:append:class-nativesdk = "\
48 nativesdk-elfutils \
49 "
50
51OPENMP_LIB_NAME = "gomp"
52OPENMP_LIB_NAME:toolchain-clang:class-target = "omp"
53
54export CONFIGURE_FLAGS = "\
55 --build=${BUILD_SYS}, \
56 --host=${HOST_SYS}, \
57 --target=${TARGET_SYS}, \
58 --prefix=${prefix}, \
59 --exec_prefix=${exec_prefix}, \
60 --bindir=${bindir}, \
61 --sbindir=${sbindir}, \
62 --libexecdir=${libexecdir}, \
63 --datadir=${datadir}, \
64 --sysconfdir=${sysconfdir}, \
65 --sharedstatedir=${sharedstatedir}, \
66 --localstatedir=${localstatedir}, \
67 --libdir=${libdir}, \
68 --includedir=${includedir}, \
69 --oldincludedir=${includedir}, \
70 --infodir=${infodir}, \
71 --mandir=${mandir}, \
72 --enable-openmp=${OPENMP_LIB_NAME} \
73 "
74
75export PYTHON_CPPFLAGS = "-I${STAGING_INCDIR}/${PYTHON_DIR}"
76
77inherit python3native pkgconfig setuptools3
78
79BBCLASSEXTEND = "native nativesdk"
80