summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch32
-rw-r--r--meta-oe/recipes-support/poppler/poppler/basename-include.patch31
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.79.0.bb (renamed from meta-oe/recipes-support/poppler/poppler_0.75.0.bb)5
3 files changed, 23 insertions, 45 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch b/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
deleted file mode 100644
index c364d7372c..0000000000
--- a/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From d488de23b75b2f3e235f1c184b2253d1402b4c0f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 10 May 2018 23:47:56 -0700
4Subject: [PATCH] glib/CMakeLists.txt: Add libpoppler to link along with
5 poppler-glib
6
7This is required since poppler-glib uses symbols from poppler and
8we use --as-needed
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 glib/CMakeLists.txt | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
18index 6f91669..ca5021f 100644
19--- a/glib/CMakeLists.txt
20+++ b/glib/CMakeLists.txt
21@@ -135,7 +135,7 @@ if (HAVE_INTROSPECTION AND BUILD_SHARED_LIBS)
22 get_directory_property(_tmp_includes INCLUDE_DIRECTORIES)
23 _list_prefix(_includes _tmp_includes "-I")
24 set(Poppler_0_18_gir_CFLAGS ${_includes} -L${CMAKE_BINARY_DIR} -L${CMAKE_CURRENT_BINARY_DIR})
25- set(Poppler_0_18_gir_LIBS poppler-glib)
26+ set(Poppler_0_18_gir_LIBS poppler-glib poppler)
27 _list_prefix(_abs_introspection_files introspection_files "${CMAKE_CURRENT_SOURCE_DIR}/")
28 list(APPEND _abs_introspection_files
29 ${CMAKE_CURRENT_BINARY_DIR}/poppler-enums.c
30--
312.20.1
32
diff --git a/meta-oe/recipes-support/poppler/poppler/basename-include.patch b/meta-oe/recipes-support/poppler/poppler/basename-include.patch
index ab6bdb0806..c18a5f5c0e 100644
--- a/meta-oe/recipes-support/poppler/poppler/basename-include.patch
+++ b/meta-oe/recipes-support/poppler/poppler/basename-include.patch
@@ -1,20 +1,31 @@
1Minic GNU basename() API for non-glibc library e.g. musl 1From 2ac679158062b14729f82f513fc7cafbb6f4f7a6 Mon Sep 17 00:00:00 2001
2From: Randy MacLeod <Randy.MacLeod@windriver.com>
3Date: Fri, 26 Jul 2019 14:26:54 -0400
4Subject: [PATCH 3/3] Minic GNU basename() API for non-glibc library e.g. musl
2 5
3Upstream-Status: Pending 6Upstream-Status: Pending
7
4Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
10---
11 goo/gbasename.cc | 4 ++++
12 1 file changed, 4 insertions(+)
5 13
6Index: poppler-0.64.0/utils/pdfsig.cc 14diff --git a/goo/gbasename.cc b/goo/gbasename.cc
7=================================================================== 15index 830c1c80..e93eb368 100644
8--- poppler-0.64.0.orig/utils/pdfsig.cc 16--- a/goo/gbasename.cc
9+++ poppler-0.64.0/utils/pdfsig.cc 17+++ b/goo/gbasename.cc
10@@ -35,6 +35,10 @@ 18@@ -46,6 +46,10 @@
11 #include "numberofcharacters.h" 19 #include <stdlib.h>
12 #include <libgen.h> 20 #include <string.h>
13 21
14+#if !defined(__GLIBC__) 22+#if !defined(__GLIBC__)
15+#define basename(src) (strrchr(src,'/') ? strrchr(src,'/')+1 : src) 23+#define basename(src) (strrchr(src,'/') ? strrchr(src,'/')+1 : src)
16+#endif 24+#endif
17+ 25+
18 static const char * getReadableSigState(SignatureValidationStatus sig_vs) 26 std::string gbasename(const char* filename)
19 { 27 {
20 switch(sig_vs) { 28 #ifdef _MSC_VER
29--
302.17.0
31
diff --git a/meta-oe/recipes-support/poppler/poppler_0.75.0.bb b/meta-oe/recipes-support/poppler/poppler_0.79.0.bb
index 0704f1a2af..0684334754 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.75.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.79.0.bb
@@ -5,11 +5,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \ 5SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \
6 file://0001-Do-not-overwrite-all-our-build-flags.patch \ 6 file://0001-Do-not-overwrite-all-our-build-flags.patch \
7 file://0002-CairoOutputDev.cc-fix-build-error-when-using-fixedpo.patch \ 7 file://0002-CairoOutputDev.cc-fix-build-error-when-using-fixedpo.patch \
8 file://0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch \
9 file://basename-include.patch \ 8 file://basename-include.patch \
10 " 9 "
11SRC_URI[md5sum] = "3fb4ca803d989742695ca586c5cc489e" 10SRC_URI[md5sum] = "0aac1fcb6466f8b7bdf51871264c7e83"
12SRC_URI[sha256sum] = "3bbaedb0fa2797cac933a0659d144303e4d09eec6892c65600da987d8707199a" 11SRC_URI[sha256sum] = "f985a4608fe592d2546d9d37d4182e502ff6b4c42f8db4be0a021a1c369528c8"
13 12
14DEPENDS = "fontconfig zlib cairo lcms glib-2.0" 13DEPENDS = "fontconfig zlib cairo lcms glib-2.0"
15 14