diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-m2crypto/avoid-host-contamination.patch | 23 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb | 3 |
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/avoid-host-contamination.patch b/meta-python/recipes-devtools/python/python3-m2crypto/avoid-host-contamination.patch new file mode 100644 index 0000000000..9d9b8449ba --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-m2crypto/avoid-host-contamination.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Filter out '/usr/include' for swig to avoid host contamination issue. | ||
2 | |||
3 | Upstream-Status: Upstream-Status: Inappropriate [cross compile specific] | ||
4 | |||
5 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
6 | --- | ||
7 | setup.py | 3 ++- | ||
8 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/setup.py b/setup.py | ||
11 | index 5a12981..389d49f 100644 | ||
12 | --- a/setup.py | ||
13 | +++ b/setup.py | ||
14 | @@ -153,7 +153,8 @@ class _M2CryptoBuildExt(build_ext.build_ext): | ||
15 | self.swig_opts.append('-py3') | ||
16 | |||
17 | # swig seems to need the default header file directories | ||
18 | - self.swig_opts.extend(['-I%s' % i for i in _get_additional_includes()]) | ||
19 | + self.swig_opts.extend(['-I%s' % i for i in _get_additional_includes() | ||
20 | + if i != '/usr/include']) | ||
21 | |||
22 | log.debug('self.include_dirs = %s', self.include_dirs) | ||
23 | log.debug('self.library_dirs = %s', self.library_dirs) | ||
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb b/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb index 2284a43a3b..b3da87fb7e 100644 --- a/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb +++ b/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb | |||
@@ -10,6 +10,7 @@ SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \ | |||
10 | file://cross-compile-platform.patch \ | 10 | file://cross-compile-platform.patch \ |
11 | file://0001-Allow-verify_cb_-to-be-called-with-ok-True.patch \ | 11 | file://0001-Allow-verify_cb_-to-be-called-with-ok-True.patch \ |
12 | file://0001-Use-of-RSA_SSLV23_PADDING-has-been-deprecated.patch \ | 12 | file://0001-Use-of-RSA_SSLV23_PADDING-has-been-deprecated.patch \ |
13 | file://avoid-host-contamination.patch \ | ||
13 | " | 14 | " |
14 | SRC_URI[sha256sum] = "e4e42f068b78ccbf113e5d0a72ae5f480f6c3ace4940b91e4fff5598cfff6fb3" | 15 | SRC_URI[sha256sum] = "e4e42f068b78ccbf113e5d0a72ae5f480f6c3ace4940b91e4fff5598cfff6fb3" |
15 | 16 | ||
@@ -42,4 +43,6 @@ SWIG_FEATURES_append_mipsarch = " -D_MIPS_SZPTR=${SITEINFO_BITS}" | |||
42 | SWIG_FEATURES_append_powerpc64le = " -D__powerpc64__" | 43 | SWIG_FEATURES_append_powerpc64le = " -D__powerpc64__" |
43 | export SWIG_FEATURES | 44 | export SWIG_FEATURES |
44 | 45 | ||
46 | export STAGING_DIR | ||
47 | |||
45 | BBCLASSEXTEND = "native" | 48 | BBCLASSEXTEND = "native" |