summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.6.0.bb25
1 files changed, 1 insertions, 24 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.6.0.bb b/meta-oe/recipes-support/opencv/opencv_4.6.0.bb
index fcbafd78a9..1e4c3545be 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.6.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.6.0.bb
@@ -12,40 +12,19 @@ DEPENDS = "libtool swig-native bzip2 zlib glib-2.0 libwebp"
12 12
13SRCREV_opencv = "b0dc474160e389b9c9045da5db49d03ae17c6a6b" 13SRCREV_opencv = "b0dc474160e389b9c9045da5db49d03ae17c6a6b"
14SRCREV_contrib = "7b77c355a8fdc97667b3fa1e7a0d37e4973fc868" 14SRCREV_contrib = "7b77c355a8fdc97667b3fa1e7a0d37e4973fc868"
15SRCREV_ipp = "a56b6ac6f030c312b2dce17430eef13aed9af274"
16SRCREV_boostdesc = "34e4206aef44d50e6bbcd0ab06354b52e7466d26" 15SRCREV_boostdesc = "34e4206aef44d50e6bbcd0ab06354b52e7466d26"
17SRCREV_vgg = "fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d" 16SRCREV_vgg = "fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d"
18SRCREV_face = "8afa57abc8229d611c4937165d20e2a2d9fc5a12" 17SRCREV_face = "8afa57abc8229d611c4937165d20e2a2d9fc5a12"
19SRCREV_wechat-qrcode = "a8b69ccc738421293254aec5ddb38bd523503252" 18SRCREV_wechat-qrcode = "a8b69ccc738421293254aec5ddb38bd523503252"
20 19
21def ipp_filename(d):
22 import re
23 arch = d.getVar('TARGET_ARCH')
24 if re.match("i.86$", arch):
25 return "ippicv_2020_lnx_ia32_20191018_general.tgz"
26 else:
27 return "ippicv_2020_lnx_intel64_20191018_general.tgz"
28
29def ipp_md5sum(d):
30 import re
31 arch = d.getVar('TARGET_ARCH')
32 if re.match("i.86$", arch):
33 return "ad189a940fb60eb71f291321322fe3e8"
34 else:
35 return "7421de0095c7a39162ae13a6098782f9"
36
37IPP_FILENAME = "${@ipp_filename(d)}"
38IPP_MD5 = "${@ipp_md5sum(d)}"
39 20
40SRCREV_FORMAT = "opencv_contrib_ipp_boostdesc_vgg" 21SRCREV_FORMAT = "opencv_contrib_ipp_boostdesc_vgg"
41SRC_URI = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol=https \ 22SRC_URI = "git://github.com/opencv/opencv.git;name=opencv;branch=master;protocol=https \
42 git://github.com/opencv/opencv_contrib.git;destsuffix=git/contrib;name=contrib;branch=master;protocol=https \ 23 git://github.com/opencv/opencv_contrib.git;destsuffix=git/contrib;name=contrib;branch=master;protocol=https \
43 git://github.com/opencv/opencv_3rdparty.git;branch=ippicv/master_20191018;destsuffix=git/ipp;name=ipp;protocol=https \
44 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_boostdesc_20161012;destsuffix=git/boostdesc;name=boostdesc;protocol=https \ 24 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_boostdesc_20161012;destsuffix=git/boostdesc;name=boostdesc;protocol=https \
45 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_vgg_20160317;destsuffix=git/vgg;name=vgg;protocol=https \ 25 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_xfeatures2d_vgg_20160317;destsuffix=git/vgg;name=vgg;protocol=https \
46 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_face_alignment_20170818;destsuffix=git/face;name=face;protocol=https \ 26 git://github.com/opencv/opencv_3rdparty.git;branch=contrib_face_alignment_20170818;destsuffix=git/face;name=face;protocol=https \
47 git://github.com/WeChatCV/opencv_3rdparty.git;branch=wechat_qrcode;destsuffix=git/wechat_qrcode;name=wechat-qrcode;protocol=https \ 27 git://github.com/WeChatCV/opencv_3rdparty.git;branch=wechat_qrcode;destsuffix=git/wechat_qrcode;name=wechat-qrcode;protocol=https \
48 file://0001-3rdparty-ippicv-Use-pre-downloaded-ipp.patch \
49 file://0003-To-fix-errors-as-following.patch \ 28 file://0003-To-fix-errors-as-following.patch \
50 file://0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch \ 29 file://0001-Temporarliy-work-around-deprecated-ffmpeg-RAW-functi.patch \
51 file://0001-Dont-use-isystem.patch \ 30 file://0001-Dont-use-isystem.patch \
@@ -63,7 +42,6 @@ S = "${WORKDIR}/git"
63OPENCV_DLDIR = "${WORKDIR}/downloads" 42OPENCV_DLDIR = "${WORKDIR}/downloads"
64 43
65do_unpack_extra() { 44do_unpack_extra() {
66 tar xzf ${S}/ipp/ippicv/${IPP_FILENAME} -C ${S}
67 45
68 md5() { 46 md5() {
69 # Return the MD5 of $1 47 # Return the MD5 of $1
@@ -92,8 +70,7 @@ EXTRA_OECMAKE = "-DOPENCV_EXTRA_MODULES_PATH=${S}/contrib/modules \
92 -DWITH_1394=OFF \ 70 -DWITH_1394=OFF \
93 -DENABLE_PRECOMPILED_HEADERS=OFF \ 71 -DENABLE_PRECOMPILED_HEADERS=OFF \
94 -DCMAKE_SKIP_RPATH=ON \ 72 -DCMAKE_SKIP_RPATH=ON \
95 -DOPENCV_ICV_HASH=${IPP_MD5} \ 73 -DWITH_IPP=OFF \
96 -DIPPROOT=${S}/ippicv_lnx \
97 -DOPENCV_GENERATE_PKGCONFIG=ON \ 74 -DOPENCV_GENERATE_PKGCONFIG=ON \
98 -DOPENCV_DOWNLOAD_PATH=${OPENCV_DLDIR} \ 75 -DOPENCV_DOWNLOAD_PATH=${OPENCV_DLDIR} \
99 -DOPENCV_ALLOW_DOWNLOADS=OFF \ 76 -DOPENCV_ALLOW_DOWNLOADS=OFF \