diff options
-rw-r--r-- | meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-support/gd/gd_2.2.3.bb (renamed from meta-oe/recipes-support/gd/gd_2.1.1.bb) | 12 |
2 files changed, 49 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch b/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch new file mode 100644 index 0000000000..02cb5ad758 --- /dev/null +++ b/meta-oe/recipes-support/gd/files/fix-gcc-unused-functions.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | gdft.c: remove functions that cause warnings about being unused | ||
2 | |||
3 | Upstream-Status: Backport (Fixed in master branch) | ||
4 | |||
5 | Signed-off-by: Derek Straka <derek@asterius.io> | ||
6 | --- git/src/gdft.c.orig 2016-08-12 10:20:41.418440091 -0400 | ||
7 | +++ git/src/gdft.c 2016-08-12 10:22:34.226442987 -0400 | ||
8 | @@ -139,16 +139,6 @@ | ||
9 | } | ||
10 | #else | ||
11 | |||
12 | -#ifndef HAVE_LIBFONTCONFIG | ||
13 | -static char * font_pattern(char **fontpath, char *fontpattern) | ||
14 | -{ | ||
15 | - (void)fontpath; | ||
16 | - (void)fontpattern; | ||
17 | - | ||
18 | - return "libgd was not built with FontConfig support\n"; | ||
19 | -} | ||
20 | -#endif /* HAVE_LIBFONTCONFIG */ | ||
21 | - | ||
22 | #include "gdcache.h" | ||
23 | /* 2.0.16 Christophe Thomas: starting with FreeType 2.1.6, this is | ||
24 | mandatory, and it has been supported for a long while. */ | ||
25 | @@ -446,16 +436,15 @@ | ||
26 | return (strcmp (a->fontlist, b->fontlist) == 0 && a->flags == b->flags); | ||
27 | } | ||
28 | |||
29 | +#ifdef HAVE_LIBFONTCONFIG | ||
30 | static int useFontConfig(int flag) | ||
31 | { | ||
32 | -#ifdef HAVE_LIBFONTCONFIG | ||
33 | if (fontConfigFlag) { | ||
34 | return (!(flag & gdFTEX_FONTPATHNAME)); | ||
35 | } | ||
36 | -#endif | ||
37 | return flag & gdFTEX_FONTCONFIG; | ||
38 | } | ||
39 | - | ||
40 | +#endif | ||
41 | static void * | ||
42 | fontFetch (char **error, void *key) | ||
43 | { | ||
diff --git a/meta-oe/recipes-support/gd/gd_2.1.1.bb b/meta-oe/recipes-support/gd/gd_2.2.3.bb index 85c7e6a051..80d66c9f7d 100644 --- a/meta-oe/recipes-support/gd/gd_2.1.1.bb +++ b/meta-oe/recipes-support/gd/gd_2.2.3.bb | |||
@@ -12,12 +12,12 @@ LICENSE = "GD" | |||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669" | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669" |
13 | DEPENDS = "freetype libpng jpeg zlib tiff" | 13 | DEPENDS = "freetype libpng jpeg zlib tiff" |
14 | 14 | ||
15 | SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \ | 15 | SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \ |
16 | " | 16 | file://fix-gcc-unused-functions.patch" |
17 | SRC_URI[md5sum] = "d3f1a992ac9c550ebc6da89c147f89af" | ||
18 | SRC_URI[sha256sum] = "895ea9c6fcab187b0a908ae3e9e6b06423756f8a643d362349b0caab4014bd0d" | ||
19 | 17 | ||
20 | S = "${WORKDIR}/libgd-${PV}" | 18 | SRCREV = "46ceef5970bf3a847ff61d1bdde7501d66c11d0c" |
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | 21 | ||
22 | inherit autotools binconfig gettext pkgconfig | 22 | inherit autotools binconfig gettext pkgconfig |
23 | 23 | ||
@@ -25,9 +25,9 @@ EXTRA_OECONF += " --disable-rpath \ | |||
25 | --with-jpeg=${STAGING_LIBDIR}/.. \ | 25 | --with-jpeg=${STAGING_LIBDIR}/.. \ |
26 | --with-freetype=yes \ | 26 | --with-freetype=yes \ |
27 | --without-fontconfig \ | 27 | --without-fontconfig \ |
28 | --without-webp \ | ||
28 | --without-xpm \ | 29 | --without-xpm \ |
29 | --without-x \ | 30 | --without-x \ |
30 | --without-vpx \ | ||
31 | " | 31 | " |
32 | 32 | ||
33 | EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"' | 33 | EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"' |