diff options
-rw-r--r-- | meta-oe/recipes-extended/rsyslog/libfastjson/0001-fix-jump-misses-init-gcc-8-warning.patch | 46 | ||||
-rw-r--r-- | meta-oe/recipes-extended/rsyslog/libfastjson_0.99.9.bb (renamed from meta-oe/recipes-extended/rsyslog/libfastjson_0.99.8.bb) | 5 |
2 files changed, 2 insertions, 49 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/libfastjson/0001-fix-jump-misses-init-gcc-8-warning.patch b/meta-oe/recipes-extended/rsyslog/libfastjson/0001-fix-jump-misses-init-gcc-8-warning.patch deleted file mode 100644 index 25e5efa4b6..0000000000 --- a/meta-oe/recipes-extended/rsyslog/libfastjson/0001-fix-jump-misses-init-gcc-8-warning.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From d697182f18a421b7f80ea9de4914251b55d82532 Mon Sep 17 00:00:00 2001 | ||
2 | From: Rainer Gerhards <rgerhards@adiscon.com> | ||
3 | Date: Sun, 15 Jul 2018 17:24:59 +0200 | ||
4 | Subject: [PATCH] "fix" "jump-misses-init" gcc-8 warning | ||
5 | |||
6 | Actually, that warning is overly conservative, and so we | ||
7 | have changed the code in a somewhat suboptimal way to "fix" | ||
8 | it. In this spots, it's not that bad and we wanted to avoid | ||
9 | totally disabling this warning. | ||
10 | |||
11 | If it were more costly in terms of cleanness, we would probaly | ||
12 | have done that. Just mention it to tell anyone else the | ||
13 | cure is not really a good one, just selected due to the | ||
14 | circumstances in this special case. | ||
15 | |||
16 | Upstream-Status: Backport | ||
17 | |||
18 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | ||
19 | --- | ||
20 | json_object.c | 3 ++- | ||
21 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/json_object.c b/json_object.c | ||
24 | index 35338e1..6e67891 100644 | ||
25 | --- a/json_object.c | ||
26 | +++ b/json_object.c | ||
27 | @@ -396,6 +396,7 @@ fjson_child_get_empty_etry(struct fjson_object *const __restrict__ jso) | ||
28 | { | ||
29 | struct _fjson_child *chld = NULL; | ||
30 | struct _fjson_child_pg *pg; | ||
31 | + int pg_idx; | ||
32 | |||
33 | if (jso->o.c_obj.ndeleted > 0) { | ||
34 | /* we first fill deleted spots */ | ||
35 | @@ -415,7 +416,7 @@ fjson_child_get_empty_etry(struct fjson_object *const __restrict__ jso) | ||
36 | goto done; | ||
37 | } | ||
38 | |||
39 | - const int pg_idx = jso->o.c_obj.nelem % FJSON_OBJECT_CHLD_PG_SIZE; | ||
40 | + pg_idx = jso->o.c_obj.nelem % FJSON_OBJECT_CHLD_PG_SIZE; | ||
41 | if (jso->o.c_obj.nelem > 0 && pg_idx == 0) { | ||
42 | if((pg = calloc(1, sizeof(struct _fjson_child_pg))) == NULL) { | ||
43 | errno = ENOMEM; | ||
44 | -- | ||
45 | 2.11.0 | ||
46 | |||
diff --git a/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.8.bb b/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.9.bb index b84dde3d37..88ba9edaa1 100644 --- a/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.8.bb +++ b/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.9.bb | |||
@@ -6,10 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a958bb07122368f3e1d9b2efe07d231f" | |||
6 | 6 | ||
7 | DEPENDS = "" | 7 | DEPENDS = "" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/rsyslog/libfastjson.git;protocol=https \ | 9 | SRC_URI = "git://github.com/rsyslog/libfastjson.git;protocol=https" |
10 | file://0001-fix-jump-misses-init-gcc-8-warning.patch" | ||
11 | 10 | ||
12 | SRCREV = "4758b1caf69ada911ef79e1d80793fe489b98dff" | 11 | SRCREV = "0293afb3913f760c449348551cca4d2df59c1a00" |
13 | 12 | ||
14 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
15 | 14 | ||