diff options
-rw-r--r-- | meta-networking/recipes-protocols/vsomeip/vsomeip/0001-Fix-pkgconfig-dir-for-multilib.patch | 6 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/vsomeip/vsomeip/0002-Install-example-configuration-files-to-etc-vsomeip.patch | 6 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/vsomeip/vsomeip/0003-Do-not-build-external-gtest.patch | 59 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/vsomeip/vsomeip/0004-Do-not-specify-PIE-flag-explicitly.patch | 8 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/vsomeip/vsomeip/0005-test-common-CMakeLists.txt-add-missing-link-with-dlt.patch | 41 | ||||
-rw-r--r-- | meta-networking/recipes-protocols/vsomeip/vsomeip_3.4.10.bb (renamed from meta-networking/recipes-protocols/vsomeip/vsomeip_3.3.8.bb) | 5 |
6 files changed, 98 insertions, 27 deletions
diff --git a/meta-networking/recipes-protocols/vsomeip/vsomeip/0001-Fix-pkgconfig-dir-for-multilib.patch b/meta-networking/recipes-protocols/vsomeip/vsomeip/0001-Fix-pkgconfig-dir-for-multilib.patch index 1c7eb17b28..0ddcb642bc 100644 --- a/meta-networking/recipes-protocols/vsomeip/vsomeip/0001-Fix-pkgconfig-dir-for-multilib.patch +++ b/meta-networking/recipes-protocols/vsomeip/vsomeip/0001-Fix-pkgconfig-dir-for-multilib.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From e8a1b7a176398c2a9b5969f1b48ae0e1aa30f4ec Mon Sep 17 00:00:00 2001 | 1 | From 2f931baf290477b586309189445bf87e3bc5d5ba Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Wed, 2 Mar 2022 14:51:13 +0800 | 3 | Date: Wed, 2 Mar 2022 14:51:13 +0800 |
4 | Subject: [PATCH] Fix pkgconfig dir for multilib | 4 | Subject: [PATCH] Fix pkgconfig dir for multilib |
@@ -11,10 +11,10 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | 11 | 1 file changed, 1 insertion(+), 1 deletion(-) |
12 | 12 | ||
13 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 13 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
14 | index add3edda..fea80b4a 100644 | 14 | index ab399a69..beae6eaf 100644 |
15 | --- a/CMakeLists.txt | 15 | --- a/CMakeLists.txt |
16 | +++ b/CMakeLists.txt | 16 | +++ b/CMakeLists.txt |
17 | @@ -602,7 +602,7 @@ endif() | 17 | @@ -637,7 +637,7 @@ endif() |
18 | # create pkg-config file | 18 | # create pkg-config file |
19 | if(NOT WIN32) | 19 | if(NOT WIN32) |
20 | configure_file(${VSOMEIP_NAME}.pc.in ${PROJECT_BINARY_DIR}/${VSOMEIP_NAME}.pc @ONLY) | 20 | configure_file(${VSOMEIP_NAME}.pc.in ${PROJECT_BINARY_DIR}/${VSOMEIP_NAME}.pc @ONLY) |
diff --git a/meta-networking/recipes-protocols/vsomeip/vsomeip/0002-Install-example-configuration-files-to-etc-vsomeip.patch b/meta-networking/recipes-protocols/vsomeip/vsomeip/0002-Install-example-configuration-files-to-etc-vsomeip.patch index c22ef697b2..bdaf343606 100644 --- a/meta-networking/recipes-protocols/vsomeip/vsomeip/0002-Install-example-configuration-files-to-etc-vsomeip.patch +++ b/meta-networking/recipes-protocols/vsomeip/vsomeip/0002-Install-example-configuration-files-to-etc-vsomeip.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From aea4c06ee2a0661d0c7b4773e846276a4f10e2e8 Mon Sep 17 00:00:00 2001 | 1 | From ebaa3206ee125741314272cddafa04fa71bd2d1e Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Wed, 9 Mar 2022 11:48:44 +0800 | 3 | Date: Wed, 9 Mar 2022 11:48:44 +0800 |
4 | Subject: [PATCH] Install example configuration files to /etc/vsomeip | 4 | Subject: [PATCH] Install example configuration files to /etc/vsomeip |
@@ -11,10 +11,10 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | 11 | 1 file changed, 1 insertion(+), 1 deletion(-) |
12 | 12 | ||
13 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 13 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
14 | index fea80b4a..e7a92ec6 100644 | 14 | index beae6eaf..d791c12e 100644 |
15 | --- a/CMakeLists.txt | 15 | --- a/CMakeLists.txt |
16 | +++ b/CMakeLists.txt | 16 | +++ b/CMakeLists.txt |
17 | @@ -501,7 +501,7 @@ install(FILES ${PROJECT_BINARY_DIR}/vsomeip.pc DESTINATION lib/pkgconfig) | 17 | @@ -536,7 +536,7 @@ install(FILES ${PROJECT_BINARY_DIR}/vsomeip.pc DESTINATION lib/pkgconfig) |
18 | endif () | 18 | endif () |
19 | 19 | ||
20 | install ( | 20 | install ( |
diff --git a/meta-networking/recipes-protocols/vsomeip/vsomeip/0003-Do-not-build-external-gtest.patch b/meta-networking/recipes-protocols/vsomeip/vsomeip/0003-Do-not-build-external-gtest.patch index 370d8a0fe0..09dab9a8b0 100644 --- a/meta-networking/recipes-protocols/vsomeip/vsomeip/0003-Do-not-build-external-gtest.patch +++ b/meta-networking/recipes-protocols/vsomeip/vsomeip/0003-Do-not-build-external-gtest.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From e012f91a73af7469ef6f660c3a6a752430a4d649 Mon Sep 17 00:00:00 2001 | 1 | From b1bf398015bc090020459954e5cd1ec3b51b8ac3 Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Tue, 11 Jul 2023 16:53:46 +0800 | 3 | Date: Tue, 11 Jul 2023 16:53:46 +0800 |
4 | Subject: [PATCH] Do not build external gtest | 4 | Subject: [PATCH] Do not build external gtest |
@@ -10,15 +10,16 @@ Upstream-Status: Inappropriate [embedded specific] | |||
10 | 10 | ||
11 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | 11 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> |
12 | --- | 12 | --- |
13 | CMakeLists.txt | 30 ++---------- | 13 | CMakeLists.txt | 11 ---- |
14 | test/network_tests/CMakeLists.txt | 80 ------------------------------- | 14 | test/CMakeLists.txt | 22 +------ |
15 | 2 files changed, 3 insertions(+), 107 deletions(-) | 15 | test/network_tests/CMakeLists.txt | 99 ------------------------------- |
16 | 3 files changed, 3 insertions(+), 129 deletions(-) | ||
16 | 17 | ||
17 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 18 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
18 | index e7a92ec6..f6c680d4 100644 | 19 | index d791c12e..f1bcba27 100644 |
19 | --- a/CMakeLists.txt | 20 | --- a/CMakeLists.txt |
20 | +++ b/CMakeLists.txt | 21 | +++ b/CMakeLists.txt |
21 | @@ -18,14 +18,6 @@ set (VSOMEIP_VERSION ${VSOMEIP_MAJOR_VERSION}.${VSOMEIP_MINOR_VERSION}.${VSOMEIP | 22 | @@ -18,17 +18,6 @@ set (VSOMEIP_VERSION ${VSOMEIP_MAJOR_VERSION}.${VSOMEIP_MINOR_VERSION}.${VSOMEIP |
22 | set (PACKAGE_VERSION ${VSOMEIP_VERSION}) # Used in documentation/doxygen.in | 23 | set (PACKAGE_VERSION ${VSOMEIP_VERSION}) # Used in documentation/doxygen.in |
23 | set (CMAKE_VERBOSE_MAKEFILE off) | 24 | set (CMAKE_VERBOSE_MAKEFILE off) |
24 | 25 | ||
@@ -26,16 +27,23 @@ index e7a92ec6..f6c680d4 100644 | |||
26 | - if (DEFINED ENV{GTEST_ROOT}) | 27 | - if (DEFINED ENV{GTEST_ROOT}) |
27 | - set(GTEST_ROOT $ENV{GTEST_ROOT}) | 28 | - set(GTEST_ROOT $ENV{GTEST_ROOT}) |
28 | - else() | 29 | - else() |
29 | - set(GTEST_ROOT "n/a" CACHE STRING "Path to root folder of googletest. Must be set for building the tests.") | 30 | - include(FetchContent) |
31 | - FetchContent_Declare(googletest GIT_REPOSITORY https://github.com/google/googletest.git GIT_TAG v1.14.0) | ||
32 | - FetchContent_Populate(googletest) | ||
33 | - set(GTEST_ROOT ${googletest_SOURCE_DIR}) | ||
30 | - endif() | 34 | - endif() |
31 | -endif() | 35 | -endif() |
32 | - | 36 | - |
33 | ################################################################################################### | 37 | ################################################################################################### |
34 | # see http://www.cmake.org/Wiki/CMake/Tutorials/How_to_create_a_ProjectConfig.cmake_file | 38 | # see http://www.cmake.org/Wiki/CMake/Tutorials/How_to_create_a_ProjectConfig.cmake_file |
35 | ################################################################################################### | 39 | ################################################################################################### |
36 | @@ -630,27 +622,11 @@ find_package(benchmark) | 40 | diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt |
37 | ############################################################################## | 41 | index f66ac5d3..6f09bf40 100644 |
38 | # google test | 42 | --- a/test/CMakeLists.txt |
43 | +++ b/test/CMakeLists.txt | ||
44 | @@ -17,27 +17,11 @@ find_package(benchmark) | ||
45 | # remove export symbols from the cxx flags | ||
46 | string(REPLACE "${EXPORTSYMBOLS}" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}") | ||
39 | 47 | ||
40 | -# check for set environment variable | 48 | -# check for set environment variable |
41 | -if(${GTEST_ROOT} STREQUAL "n/a") | 49 | -if(${GTEST_ROOT} STREQUAL "n/a") |
@@ -62,13 +70,13 @@ index e7a92ec6..f6c680d4 100644 | |||
62 | - set(BUILD_SHARED_LIBS_AUTOMATIC_OFF 0) | 70 | - set(BUILD_SHARED_LIBS_AUTOMATIC_OFF 0) |
63 | -endif() | 71 | -endif() |
64 | 72 | ||
65 | 73 | ############################################################################## | |
66 | 74 | # build tests | |
67 | diff --git a/test/network_tests/CMakeLists.txt b/test/network_tests/CMakeLists.txt | 75 | diff --git a/test/network_tests/CMakeLists.txt b/test/network_tests/CMakeLists.txt |
68 | index 6a148604..a501b6a7 100644 | 76 | index 883cc5cf..9a2a4f5e 100644 |
69 | --- a/test/network_tests/CMakeLists.txt | 77 | --- a/test/network_tests/CMakeLists.txt |
70 | +++ b/test/network_tests/CMakeLists.txt | 78 | +++ b/test/network_tests/CMakeLists.txt |
71 | @@ -3633,86 +3633,6 @@ if(NOT ${TESTS_BAT}) | 79 | @@ -4116,105 +4116,6 @@ if(NOT ${TESTS_BAT}) |
72 | 80 | ||
73 | endif() | 81 | endif() |
74 | 82 | ||
@@ -97,6 +105,12 @@ index 6a148604..a501b6a7 100644 | |||
97 | - add_dependencies(${TEST_CLIENT_ID_UTILITY} gtest) | 105 | - add_dependencies(${TEST_CLIENT_ID_UTILITY} gtest) |
98 | - add_dependencies(${TEST_DEBOUNCE_CLIENT} gtest) | 106 | - add_dependencies(${TEST_DEBOUNCE_CLIENT} gtest) |
99 | - add_dependencies(${TEST_DEBOUNCE_SERVICE} gtest) | 107 | - add_dependencies(${TEST_DEBOUNCE_SERVICE} gtest) |
108 | - add_dependencies(${TEST_DEBOUNCE_FILTER_CLIENT} gtest) | ||
109 | - add_dependencies(${TEST_DEBOUNCE_FILTER_SERVICE} gtest) | ||
110 | - add_dependencies(${TEST_DEBOUNCE_CALLBACK_CLIENT} gtest) | ||
111 | - add_dependencies(${TEST_DEBOUNCE_CALLBACK_SERVICE} gtest) | ||
112 | - add_dependencies(${TEST_DEBOUNCE_FREQUENCY_CLIENT} gtest) | ||
113 | - add_dependencies(${TEST_DEBOUNCE_FREQUENCY_SERVICE} gtest) | ||
100 | - add_dependencies(${TEST_SUBSCRIBE_NOTIFY_SERVICE} gtest) | 114 | - add_dependencies(${TEST_SUBSCRIBE_NOTIFY_SERVICE} gtest) |
101 | - add_dependencies(${TEST_SUBSCRIBE_NOTIFY_ONE_EVENT_TWO_EVENTGROUPS_SERVICE} gtest) | 115 | - add_dependencies(${TEST_SUBSCRIBE_NOTIFY_ONE_EVENT_TWO_EVENTGROUPS_SERVICE} gtest) |
102 | - add_dependencies(${TEST_SUBSCRIBE_NOTIFY_ONE_EVENT_TWO_EVENTGROUPS_CLIENT} gtest) | 116 | - add_dependencies(${TEST_SUBSCRIBE_NOTIFY_ONE_EVENT_TWO_EVENTGROUPS_CLIENT} gtest) |
@@ -127,8 +141,13 @@ index 6a148604..a501b6a7 100644 | |||
127 | - add_dependencies(${TEST_E2E_PROFILE_04_SERVICE} gtest) | 141 | - add_dependencies(${TEST_E2E_PROFILE_04_SERVICE} gtest) |
128 | - add_dependencies(${TEST_E2E_PROFILE_04_CLIENT} gtest) | 142 | - add_dependencies(${TEST_E2E_PROFILE_04_CLIENT} gtest) |
129 | - endif() | 143 | - endif() |
144 | - if (${TEST_E2E_PROFILE_07}) | ||
145 | - add_dependencies(${TEST_E2E_PROFILE_07_SERVICE} gtest) | ||
146 | - add_dependencies(${TEST_E2E_PROFILE_07_CLIENT} gtest) | ||
147 | - endif() | ||
130 | - add_dependencies(${TEST_EVENT_SERVICE} gtest) | 148 | - add_dependencies(${TEST_EVENT_SERVICE} gtest) |
131 | - add_dependencies(${TEST_EVENT_CLIENT} gtest) | 149 | - add_dependencies(${TEST_EVENT_CLIENT} gtest) |
150 | - if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "QNX") | ||
132 | - add_dependencies(${TEST_NPDU_SERVICE_ONE} gtest) | 151 | - add_dependencies(${TEST_NPDU_SERVICE_ONE} gtest) |
133 | - add_dependencies(${TEST_NPDU_SERVICE_TWO} gtest) | 152 | - add_dependencies(${TEST_NPDU_SERVICE_TWO} gtest) |
134 | - add_dependencies(${TEST_NPDU_SERVICE_THREE} gtest) | 153 | - add_dependencies(${TEST_NPDU_SERVICE_THREE} gtest) |
@@ -139,6 +158,7 @@ index 6a148604..a501b6a7 100644 | |||
139 | - add_dependencies(${TEST_NPDU_CLIENT_FOUR} gtest) | 158 | - add_dependencies(${TEST_NPDU_CLIENT_FOUR} gtest) |
140 | - add_dependencies(${TEST_NPDU_DAEMON_CLIENT} gtest) | 159 | - add_dependencies(${TEST_NPDU_DAEMON_CLIENT} gtest) |
141 | - add_dependencies(${TEST_NPDU_DAEMON_SERVICE} gtest) | 160 | - add_dependencies(${TEST_NPDU_DAEMON_SERVICE} gtest) |
161 | - endif() | ||
142 | - add_dependencies(${TEST_SOMEIPTP_CLIENT} gtest) | 162 | - add_dependencies(${TEST_SOMEIPTP_CLIENT} gtest) |
143 | - add_dependencies(${TEST_SOMEIPTP_SERVICE} gtest) | 163 | - add_dependencies(${TEST_SOMEIPTP_SERVICE} gtest) |
144 | - if(${TEST_SECOND_ADDRESS}) | 164 | - if(${TEST_SECOND_ADDRESS}) |
@@ -148,13 +168,20 @@ index 6a148604..a501b6a7 100644 | |||
148 | - add_dependencies(${TEST_SUSPEND_RESUME_CLIENT} gtest) | 168 | - add_dependencies(${TEST_SUSPEND_RESUME_CLIENT} gtest) |
149 | - add_dependencies(${TEST_SUSPEND_RESUME_SERVICE} gtest) | 169 | - add_dependencies(${TEST_SUSPEND_RESUME_SERVICE} gtest) |
150 | -else() | 170 | -else() |
171 | - add_dependencies(${TEST_APPLICATION} gtest) | ||
172 | - add_dependencies(${TEST_HEADER_FACTORY} gtest) | ||
173 | - add_dependencies(${TEST_HEADER_FACTORY_CLIENT} gtest) | ||
174 | - add_dependencies(${TEST_HEADER_FACTORY_SERVICE} gtest) | ||
175 | - add_dependencies(${TEST_PAYLOAD_SERVICE} gtest) | ||
176 | - add_dependencies(${TEST_PAYLOAD_CLIENT} gtest) | ||
177 | - add_dependencies(${TEST_BIG_PAYLOAD_SERVICE} gtest) | ||
178 | - add_dependencies(${TEST_BIG_PAYLOAD_CLIENT} gtest) | ||
151 | - add_dependencies(${TEST_LOCAL_ROUTING_SERVICE} gtest) | 179 | - add_dependencies(${TEST_LOCAL_ROUTING_SERVICE} gtest) |
152 | - add_dependencies(${TEST_LOCAL_ROUTING_CLIENT} gtest) | 180 | - add_dependencies(${TEST_LOCAL_ROUTING_CLIENT} gtest) |
153 | -endif() | 181 | -endif() |
154 | - | 182 | |
155 | ############################################################################## | 183 | ############################################################################## |
156 | # Add tests to the target build_network_tests | 184 | # Add tests to the target build_network_tests |
157 | ############################################################################## | ||
158 | -- | 185 | -- |
159 | 2.25.1 | 186 | 2.25.1 |
160 | 187 | ||
diff --git a/meta-networking/recipes-protocols/vsomeip/vsomeip/0004-Do-not-specify-PIE-flag-explicitly.patch b/meta-networking/recipes-protocols/vsomeip/vsomeip/0004-Do-not-specify-PIE-flag-explicitly.patch index 970a37e50f..4bb2318555 100644 --- a/meta-networking/recipes-protocols/vsomeip/vsomeip/0004-Do-not-specify-PIE-flag-explicitly.patch +++ b/meta-networking/recipes-protocols/vsomeip/vsomeip/0004-Do-not-specify-PIE-flag-explicitly.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 69805f9c8973a7a4d29297f8d50c29c88f981bee Mon Sep 17 00:00:00 2001 | 1 | From ec2d36466c9050ee282ea1c3bb1b5f1f61c96ecb Mon Sep 17 00:00:00 2001 |
2 | From: Yi Zhao <yi.zhao@windriver.com> | 2 | From: Yi Zhao <yi.zhao@windriver.com> |
3 | Date: Mon, 17 Jul 2023 14:33:32 +0800 | 3 | Date: Mon, 17 Jul 2023 14:33:32 +0800 |
4 | Subject: [PATCH] Do not specify PIE flag explicitly | 4 | Subject: [PATCH] Do not specify PIE flag explicitly |
@@ -24,15 +24,15 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
24 | 1 file changed, 2 insertions(+), 2 deletions(-) | 24 | 1 file changed, 2 insertions(+), 2 deletions(-) |
25 | 25 | ||
26 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 26 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
27 | index f6c680d4..dce1e701 100644 | 27 | index f1bcba27..2653a4df 100644 |
28 | --- a/CMakeLists.txt | 28 | --- a/CMakeLists.txt |
29 | +++ b/CMakeLists.txt | 29 | +++ b/CMakeLists.txt |
30 | @@ -60,12 +60,12 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "Linux") | 30 | @@ -60,12 +60,12 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "Linux") |
31 | if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU") | 31 | if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU") |
32 | # This is only relevant for GCC and causes warnings on Clang | 32 | # This is only relevant for GCC and causes warnings on Clang |
33 | set(EXPORTSYMBOLS "-Wl,-export-dynamic -Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exportmap.gcc") | 33 | set(EXPORTSYMBOLS "-Wl,-export-dynamic -Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exportmap.gcc") |
34 | - set(OS_CXX_FLAGS "${OS_CXX_FLAGS} -pie -Wl,-z,relro,-z,now") | 34 | - set(OS_CXX_FLAGS "${OS_CXX_FLAGS} -pie -Wno-tsan -Wl,-z,relro,-z,now") |
35 | + set(OS_CXX_FLAGS "${OS_CXX_FLAGS} -Wl,-z,relro,-z,now") | 35 | + set(OS_CXX_FLAGS "${OS_CXX_FLAGS} -Wno-tsan -Wl,-z,relro,-z,now") |
36 | endif() | 36 | endif() |
37 | 37 | ||
38 | set(NO_DEPRECATED "") | 38 | set(NO_DEPRECATED "") |
diff --git a/meta-networking/recipes-protocols/vsomeip/vsomeip/0005-test-common-CMakeLists.txt-add-missing-link-with-dlt.patch b/meta-networking/recipes-protocols/vsomeip/vsomeip/0005-test-common-CMakeLists.txt-add-missing-link-with-dlt.patch new file mode 100644 index 0000000000..25d66514f8 --- /dev/null +++ b/meta-networking/recipes-protocols/vsomeip/vsomeip/0005-test-common-CMakeLists.txt-add-missing-link-with-dlt.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From 8676ef287bb25b49668be4336387bdf83a0cae5c Mon Sep 17 00:00:00 2001 | ||
2 | From: Yi Zhao <yi.zhao@windriver.com> | ||
3 | Date: Mon, 1 Jan 2024 17:02:41 +0800 | ||
4 | Subject: [PATCH] test/common/CMakeLists.txt: add missing link with dlt | ||
5 | |||
6 | The libvsomeip_utilities library uses functions e.g. | ||
7 | dlt_check_library_version/dlt_register_app/dlt_unregister_app which are | ||
8 | provided by dlt therefore add it to linker flags. | ||
9 | |||
10 | Fixes: | ||
11 | x86_64-poky-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: dlt_check_library_version | ||
12 | >>> referenced by test/common/libvsomeip_utilities.so | ||
13 | |||
14 | x86_64-poky-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: dlt_register_app | ||
15 | >>> referenced by test/common/libvsomeip_utilities.so | ||
16 | |||
17 | x86_64-poky-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: dlt_unregister_app | ||
18 | >>> referenced by test/common/libvsomeip_utilities.so | ||
19 | |||
20 | Upstream-Status: Submitted [https://github.com/COVESA/vsomeip/pull/602] | ||
21 | |||
22 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
23 | --- | ||
24 | test/common/CMakeLists.txt | 1 + | ||
25 | 1 file changed, 1 insertion(+) | ||
26 | |||
27 | diff --git a/test/common/CMakeLists.txt b/test/common/CMakeLists.txt | ||
28 | index d4d14534..afc8c2d6 100644 | ||
29 | --- a/test/common/CMakeLists.txt | ||
30 | +++ b/test/common/CMakeLists.txt | ||
31 | @@ -27,6 +27,7 @@ TARGET_LINK_LIBRARIES ( | ||
32 | ${Boost_LIBRARIES} | ||
33 | ${DL_LIBRARY} | ||
34 | ${TEST_LINK_LIBRARIES} | ||
35 | + ${DLT_LIBRARIES} | ||
36 | ) | ||
37 | |||
38 | # ---------------------------------------------------------------------------- | ||
39 | -- | ||
40 | 2.25.1 | ||
41 | |||
diff --git a/meta-networking/recipes-protocols/vsomeip/vsomeip_3.3.8.bb b/meta-networking/recipes-protocols/vsomeip/vsomeip_3.4.10.bb index b45bd2d63e..4c38970205 100644 --- a/meta-networking/recipes-protocols/vsomeip/vsomeip_3.3.8.bb +++ b/meta-networking/recipes-protocols/vsomeip/vsomeip_3.4.10.bb | |||
@@ -12,9 +12,10 @@ SRC_URI = "git://github.com/GENIVI/${BPN}.git;branch=master;protocol=https;name= | |||
12 | file://0002-Install-example-configuration-files-to-etc-vsomeip.patch \ | 12 | file://0002-Install-example-configuration-files-to-etc-vsomeip.patch \ |
13 | file://0003-Do-not-build-external-gtest.patch \ | 13 | file://0003-Do-not-build-external-gtest.patch \ |
14 | file://0004-Do-not-specify-PIE-flag-explicitly.patch \ | 14 | file://0004-Do-not-specify-PIE-flag-explicitly.patch \ |
15 | file://0005-test-common-CMakeLists.txt-add-missing-link-with-dlt.patch \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | SRCREV = "07464840f503670bc75997b8e926b54734ffa410" | 18 | SRCREV = "02c199dff8aba814beebe3ca417fd991058fe90c" |
18 | 19 | ||
19 | COMPATIBLE_HOST:mips = "null" | 20 | COMPATIBLE_HOST:mips = "null" |
20 | COMPATIBLE_HOST:mips64 = "null" | 21 | COMPATIBLE_HOST:mips64 = "null" |
@@ -55,6 +56,8 @@ do_install:append() { | |||
55 | install -d ${D}/opt/${PN}-test/test/test/common | 56 | install -d ${D}/opt/${PN}-test/test/test/common |
56 | cp -rf ${S}/test/common/examples_policies \ | 57 | cp -rf ${S}/test/common/examples_policies \ |
57 | ${D}/opt/${PN}-test/test/test/common/ | 58 | ${D}/opt/${PN}-test/test/test/common/ |
59 | install -m 0755 ${B}/test/common/libvsomeip_utilities.so \ | ||
60 | ${D}/opt/${PN}-test/test/test/common/ | ||
58 | 61 | ||
59 | for d in unit_tests network_tests; do | 62 | for d in unit_tests network_tests; do |
60 | install -d ${D}/opt/${PN}-test/test/$d | 63 | install -d ${D}/opt/${PN}-test/test/$d |