summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.4.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
index ed8f21ac1b..cfced50a0e 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
4 4
5inherit autotools pkgconfig systemd python3native 5inherit autotools pkgconfig systemd python3native
6 6
7DEPENDS = "ell readline python3-docutils-native" 7DEPENDS = "ell"
8 8
9SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \ 9SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
10 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \ 10 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
@@ -13,7 +13,15 @@ SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
13SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261" 13SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 16PACKAGECONFIG ??= " \
17 client \
18 monitor \
19 manual-pages \
20 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
21"
22PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
24PACKAGECONFIG[manual-pages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
17PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" 25PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
18PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" 26PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
19PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" 27PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
@@ -27,6 +35,8 @@ do_configure_prepend () {
27do_install_append() { 35do_install_append() {
28 mkdir --parents ${D}${docdir}/${BPN} 36 mkdir --parents ${D}${docdir}/${BPN}
29 install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN} 37 install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN}
38 # If client and monitor are disabled, bindir is empty, causing a QA error
39 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
30} 40}
31 41
32FILES_${PN} += "${datadir}/dbus-1 ${nonarch_libdir}/modules-load.d ${systemd_unitdir}/network/" 42FILES_${PN} += "${datadir}/dbus-1 ${nonarch_libdir}/modules-load.d ${systemd_unitdir}/network/"