diff options
-rw-r--r-- | meta-gnome/recipes-gnome/bonobo/files/0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch | 49 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb | 4 |
2 files changed, 52 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/bonobo/files/0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch b/meta-gnome/recipes-gnome/bonobo/files/0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch new file mode 100644 index 0000000000..e9aebb853e --- /dev/null +++ b/meta-gnome/recipes-gnome/bonobo/files/0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From b75879e8c3e24d338c0e5843d616bc9b02da4d04 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 26 Aug 2017 09:52:17 -0700 | ||
4 | Subject: [PATCH] bonobo-ui-node: qualify functions with G_GNUC_PRINTF | ||
5 | |||
6 | This helps compiler in doing format checking correctly | ||
7 | Fixes | ||
8 | bonobo-ui-node.c:864:38: error: format string is not a string literal [-Werror,-Wformat-nonliteral] | ||
9 | | g_logv ("XML", G_LOG_LEVEL_ERROR, msg, args); | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | bonobo/bonobo-ui-node.c | 6 +++--- | ||
14 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/bonobo/bonobo-ui-node.c b/bonobo/bonobo-ui-node.c | ||
17 | index 9bab5e5..6ec66e2 100644 | ||
18 | --- a/bonobo/bonobo-ui-node.c | ||
19 | +++ b/bonobo/bonobo-ui-node.c | ||
20 | @@ -835,7 +835,7 @@ uiCharacters (ParseState *ps, const xmlChar *chars, int len) | ||
21 | g_string_append_len (ps->content, chars, len); | ||
22 | } | ||
23 | |||
24 | -static void | ||
25 | +static G_GNUC_PRINTF(2, 3) void | ||
26 | uiWarning (ParseState *ps, const char *msg, ...) | ||
27 | { | ||
28 | va_list args; | ||
29 | @@ -845,7 +845,7 @@ uiWarning (ParseState *ps, const char *msg, ...) | ||
30 | va_end (args); | ||
31 | } | ||
32 | |||
33 | -static void | ||
34 | +static G_GNUC_PRINTF(2, 3) void | ||
35 | uiError (ParseState *ps, const char *msg, ...) | ||
36 | { | ||
37 | va_list args; | ||
38 | @@ -855,7 +855,7 @@ uiError (ParseState *ps, const char *msg, ...) | ||
39 | va_end (args); | ||
40 | } | ||
41 | |||
42 | -static void | ||
43 | +static G_GNUC_PRINTF(2, 3) void | ||
44 | uiFatalError (ParseState *ps, const char *msg, ...) | ||
45 | { | ||
46 | va_list args; | ||
47 | -- | ||
48 | 2.14.1 | ||
49 | |||
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb b/meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb index 627f37ed93..b3ca0a4657 100644 --- a/meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb +++ b/meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb | |||
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | |||
5 | 5 | ||
6 | inherit gnomebase pkgconfig gtk-doc | 6 | inherit gnomebase pkgconfig gtk-doc |
7 | 7 | ||
8 | SRC_URI += "file://gcc5.patch" | 8 | SRC_URI += "file://gcc5.patch \ |
9 | file://0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch \ | ||
10 | " | ||
9 | 11 | ||
10 | SRC_URI[archive.md5sum] = "853be8e28aaa4ce48ba60be7d9046bf4" | 12 | SRC_URI[archive.md5sum] = "853be8e28aaa4ce48ba60be7d9046bf4" |
11 | SRC_URI[archive.sha256sum] = "fab5f2ac6c842d949861c07cb520afe5bee3dce55805151ce9cd01be0ec46fcd" | 13 | SRC_URI[archive.sha256sum] = "fab5f2ac6c842d949861c07cb520afe5bee3dce55805151ce9cd01be0ec46fcd" |