diff options
-rw-r--r-- | meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch | 37 | ||||
-rw-r--r-- | meta-oe/recipes-extended/icewm/icewm_1.5.5.bb | 39 |
2 files changed, 76 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch b/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch new file mode 100644 index 0000000000..7943948550 --- /dev/null +++ b/meta-oe/recipes-extended/icewm/icewm/0001-configure.ac-skip-running-test-program-when-cross-co.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From c2a67c1f62175ab061bc03d10dd766f968c6a097 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Fri, 2 Aug 2019 10:41:26 +0800 | ||
4 | Subject: [PATCH] configure.ac: skip running test program when cross-compiling | ||
5 | |||
6 | Upstream-Status: Inappropriate [OE-Specific] | ||
7 | |||
8 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
9 | --- | ||
10 | configure.ac | 4 ++-- | ||
11 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/configure.ac b/configure.ac | ||
14 | index c5e3ca03..4b89396a 100644 | ||
15 | --- a/configure.ac | ||
16 | +++ b/configure.ac | ||
17 | @@ -140,7 +140,7 @@ AC_CHECK_FUNC([getloadavg],[AC_DEFINE([HAVE_GETLOADAVG2], 1, [getloadavg() is av | ||
18 | AC_FUNC_SELECT_ARGTYPES | ||
19 | |||
20 | AC_MSG_CHECKING([for strlcpy]) | ||
21 | -AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <string.h>]],[[ | ||
22 | +AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <string.h>]],[[ | ||
23 | char a[2]; | ||
24 | if (strlcpy(a, "yes", 2) != 3) | ||
25 | return 1;]])], | ||
26 | @@ -156,7 +156,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <string.h>]],[[ | ||
27 | ]) | ||
28 | |||
29 | AC_MSG_CHECKING([for strlcat]) | ||
30 | -AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <string.h>]],[[ | ||
31 | +AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <string.h>]],[[ | ||
32 | char a[4] = "no"; | ||
33 | if (strlcat(a, "yes", 4) != 5) | ||
34 | return 1;]])], | ||
35 | -- | ||
36 | 2.17.1 | ||
37 | |||
diff --git a/meta-oe/recipes-extended/icewm/icewm_1.5.5.bb b/meta-oe/recipes-extended/icewm/icewm_1.5.5.bb new file mode 100644 index 0000000000..63fca1dd11 --- /dev/null +++ b/meta-oe/recipes-extended/icewm/icewm_1.5.5.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | DESCRIPTION = "Ice Window Manager (IceWM)" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4a26952467ef79a7efca4a9cf52d417b" | ||
4 | |||
5 | SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz \ | ||
6 | file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \ | ||
7 | " | ||
8 | SRC_URI[md5sum] = "6eba94a7935a0531d2c14eeb1426aeef" | ||
9 | SRC_URI[sha256sum] = "f1c1344b20a9e8635143f70ee27930b55f813c15ca61f84d77584d311b6ac027" | ||
10 | |||
11 | inherit autotools pkgconfig gettext perlnative distro_features_check qemu | ||
12 | REQUIRED_DISTRO_FEATURES = "x11" | ||
13 | |||
14 | EXTRA_OECONF += "--with-libdir=${datadir}/icewm \ | ||
15 | --with-cfgdir=${sysconfdir}/icewm \ | ||
16 | --with-docdir=${docdir}/icewm \ | ||
17 | --enable-fribidi \ | ||
18 | --enable-xinerama \ | ||
19 | --enable-shape" | ||
20 | |||
21 | DEPENDS = "asciidoc-native fontconfig gdk-pixbuf libxft libxpm libxrandr libxinerama libice libsm libx11 libxext libxrender" | ||
22 | DEPENDS_append = " qemu-native" | ||
23 | RDEPENDS_${PN} = "perl fribidi" | ||
24 | |||
25 | do_compile_prepend_class-target() { | ||
26 | |||
27 | cd ${B} | ||
28 | oe_runmake -C src genpref | ||
29 | |||
30 | qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}',['${B}/src/.libs','${STAGING_DIR_TARGET}/${libdir}','${STAGING_DIR_TARGET}/${base_libdir}'])}" | ||
31 | cat >qemuwrapper <<EOF | ||
32 | #!/bin/sh | ||
33 | ${qemu_binary} src/genpref "\$@" | ||
34 | EOF | ||
35 | chmod +x qemuwrapper | ||
36 | ./qemuwrapper > src/preferences | ||
37 | } | ||
38 | |||
39 | FILES_${PN} += "${datadir}/xsessions" | ||