summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/webkitgtk/webkitgtk3/no-musttail-arm.patch21
-rw-r--r--meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb1
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/webkitgtk/webkitgtk3/no-musttail-arm.patch b/meta-oe/recipes-support/webkitgtk/webkitgtk3/no-musttail-arm.patch
new file mode 100644
index 0000000000..c660baa1f7
--- /dev/null
+++ b/meta-oe/recipes-support/webkitgtk/webkitgtk3/no-musttail-arm.patch
@@ -0,0 +1,21 @@
1clang/arm: Do not use MUST_TAIL_CALL
2
3This causes clang-17 to crash see [1]
4this code is new in webkit 2.42[2] thats why we do not see the crash in older webkit
5
6[1] https://github.com/llvm/llvm-project/issues/67767
7[2] https://github.com/WebKit/WebKit/commit/4d816460b765acd8aef90ab474615850b91ecc35
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11--- a/Source/WTF/wtf/Compiler.h
12+++ b/Source/WTF/wtf/Compiler.h
13@@ -284,7 +284,7 @@
14 /* MUST_TAIL_CALL */
15
16 #if !defined(MUST_TAIL_CALL) && defined(__cplusplus) && defined(__has_cpp_attribute)
17-#if __has_cpp_attribute(clang::musttail)
18+#if __has_cpp_attribute(clang::musttail) && !defined(__arm__)
19 #define MUST_TAIL_CALL [[clang::musttail]]
20 #endif
21 #endif
diff --git a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb
index 8962dbfe7d..f682cd9f03 100644
--- a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb
+++ b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.42.0.bb
@@ -13,6 +13,7 @@ SRC_URI = "https://www.webkitgtk.org/releases/webkitgtk-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \ 13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://reproducibility.patch \ 14 file://reproducibility.patch \
15 file://0d3344e17d258106617b0e6d783d073b188a2548.patch \ 15 file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
16 file://no-musttail-arm.patch \
16 " 17 "
17SRC_URI[sha256sum] = "828f95935861fae583fb8f2ae58cf64c63c178ae2b7c2d6f73070813ad64ed1b" 18SRC_URI[sha256sum] = "828f95935861fae583fb8f2ae58cf64c63c178ae2b7c2d6f73070813ad64ed1b"
18 19