diff options
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/1296.patch | 52 | ||||
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | 3 |
2 files changed, 54 insertions, 1 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/1296.patch b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/1296.patch new file mode 100644 index 0000000000..ae84bcb569 --- /dev/null +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/1296.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | Upstream-Status: submitted https://github.com/mongodb/mongo/pull/1296 | ||
2 | From 362be06fc16a5ad0f9e9aa90cc763c5242e8e35c Mon Sep 17 00:00:00 2001 | ||
3 | From: Fabrice Fontaine <fontaine.fabrice@gmail.com> | ||
4 | Date: Sat, 9 Feb 2019 12:41:45 +0100 | ||
5 | Subject: [PATCH] ssl_manager.cpp: fix build with gcc 7 and -fpermissive | ||
6 | |||
7 | Change prototype of DERToken::parse function from | ||
8 | parse(ConstDataRange cdr, size_t* outLength); | ||
9 | to parse(ConstDataRange cdr, uint64_t* outLength); | ||
10 | |||
11 | Otherwise, we got the following error: | ||
12 | |||
13 | src/mongo/util/net/ssl_manager.cpp: In static member function 'static mongo::StatusWith<mongo::{anonymous}::DERToken> mongo::{anonymous}::DERToken::parse(mongo::ConstDataRange, size_t*)': | ||
14 | src/mongo/util/net/ssl_manager.cpp:575:79: error: invalid conversion from 'size_t* {aka unsigned int*}' to 'long unsigned int*' [-fpermissive] | ||
15 | if (mongoUnsignedAddOverflow64(tagAndLengthByteCount, derLength, outLength) || | ||
16 | |||
17 | Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> | ||
18 | --- | ||
19 | src/mongo/util/net/ssl_manager.cpp | 6 +++--- | ||
20 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
21 | |||
22 | diff --git a/src/mongo/util/net/ssl_manager.cpp b/src/mongo/util/net/ssl_manager.cpp | ||
23 | index b93ebe84a4a3..3511eb5d998f 100644 | ||
24 | --- a/src/mongo/util/net/ssl_manager.cpp | ||
25 | +++ b/src/mongo/util/net/ssl_manager.cpp | ||
26 | @@ -782,7 +782,7 @@ class DERToken { | ||
27 | * | ||
28 | * Returns a DERToken which consists of the (tag, length, value) tuple. | ||
29 | */ | ||
30 | - static StatusWith<DERToken> parse(ConstDataRange cdr, size_t* outLength); | ||
31 | + static StatusWith<DERToken> parse(ConstDataRange cdr, uint64_t* outLength); | ||
32 | |||
33 | private: | ||
34 | DERType _type{DERType::EndOfContent}; | ||
35 | @@ -799,7 +799,7 @@ struct DataType::Handler<DERToken> { | ||
36 | size_t length, | ||
37 | size_t* advanced, | ||
38 | std::ptrdiff_t debug_offset) { | ||
39 | - size_t outLength; | ||
40 | + uint64_t outLength; | ||
41 | |||
42 | auto swPair = DERToken::parse(ConstDataRange(ptr, length), &outLength); | ||
43 | |||
44 | @@ -844,7 +844,7 @@ StatusWith<std::string> readDERString(ConstDataRangeCursor& cdc) { | ||
45 | } | ||
46 | |||
47 | |||
48 | -StatusWith<DERToken> DERToken::parse(ConstDataRange cdr, size_t* outLength) { | ||
49 | +StatusWith<DERToken> DERToken::parse(ConstDataRange cdr, uint64_t* outLength) { | ||
50 | const size_t kTagLength = 1; | ||
51 | const size_t kTagLengthAndInitialLengthByteLength = kTagLength + 1; | ||
52 | |||
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb index 6f460bf762..5c3b806f22 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | |||
@@ -23,6 +23,7 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.2 \ | |||
23 | file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \ | 23 | file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \ |
24 | file://0001-Support-deprecated-resolver-functions.patch \ | 24 | file://0001-Support-deprecated-resolver-functions.patch \ |
25 | file://0003-Fix-unknown-prefix-env.patch \ | 25 | file://0003-Fix-unknown-prefix-env.patch \ |
26 | file://1296.patch \ | ||
26 | " | 27 | " |
27 | SRC_URI_append_libc-musl ="\ | 28 | SRC_URI_append_libc-musl ="\ |
28 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ | 29 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ |
@@ -36,7 +37,7 @@ SRC_URI_append_toolchain-clang = "\ | |||
36 | 37 | ||
37 | S = "${WORKDIR}/git" | 38 | S = "${WORKDIR}/git" |
38 | 39 | ||
39 | COMPATIBLE_HOST ?= '(x86_64|powerpc64|aarch64).*-linux' | 40 | COMPATIBLE_HOST ?= '(x86_64|i.86|powerpc64|arm|aarch64).*-linux' |
40 | 41 | ||
41 | PACKAGECONFIG ??= "tcmalloc system-pcre" | 42 | PACKAGECONFIG ??= "tcmalloc system-pcre" |
42 | # gperftools compilation fails for arm below v7 because of missing support of | 43 | # gperftools compilation fails for arm below v7 because of missing support of |