diff options
-rw-r--r-- | meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch | 32 | ||||
-rw-r--r-- | meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb | 10 |
2 files changed, 38 insertions, 4 deletions
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch new file mode 100644 index 0000000000..12a6c06e82 --- /dev/null +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi-17/0001-change-order-of-detecting-libegl-and-libgles2.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 21524598110e7a55113205dda4bc1a6d5987111c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 9 May 2017 06:41:33 +0000 | ||
4 | Subject: [PATCH] change order of detecting libegl and libgles2 | ||
5 | |||
6 | This actually helps building it on rpi/userland | ||
7 | where libEGL depends on few functions from libGLESv2 | ||
8 | see | ||
9 | https://www.raspberrypi.org/forums/viewtopic.php?t=7090 | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | configure.ac | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index b9e4240..1ca0297 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -951,8 +951,8 @@ if test "$use_gles" = "yes"; then | ||
21 | AC_MSG_RESULT(== WARNING: OpenGLES support is assumed.) | ||
22 | LIBS="$LIBS -lEGL -lGLESv2 -lbcm_host -lvcos -lvchiq_arm -lmmal -lmmal_core -lmmal_util -lvcsm" | ||
23 | else | ||
24 | - AC_CHECK_LIB([EGL], [main],, AC_MSG_ERROR($missing_library)) | ||
25 | AC_CHECK_LIB([GLESv2],[main],, AC_MSG_ERROR($missing_library)) | ||
26 | + AC_CHECK_LIB([EGL], [main],, AC_MSG_ERROR($missing_library)) | ||
27 | fi | ||
28 | fi | ||
29 | else | ||
30 | -- | ||
31 | 1.9.1 | ||
32 | |||
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb index 8f75bb48de..23f09af51b 100644 --- a/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb +++ b/meta-multimedia/recipes-mediacenter/kodi/kodi_17.bb | |||
@@ -77,6 +77,7 @@ SRC_URI = "git://github.com/xbmc/xbmc.git;branch=Krypton \ | |||
77 | file://0010-RssReader-Fix-compiler-warning-comparing-pointer-to-.patch \ | 77 | file://0010-RssReader-Fix-compiler-warning-comparing-pointer-to-.patch \ |
78 | file://0011-Let-configure-pass-on-unknown-architectures-setting-.patch \ | 78 | file://0011-Let-configure-pass-on-unknown-architectures-setting-.patch \ |
79 | file://0012-Revert-droid-fix-builds-with-AML-disabled.patch \ | 79 | file://0012-Revert-droid-fix-builds-with-AML-disabled.patch \ |
80 | file://0001-change-order-of-detecting-libegl-and-libgles2.patch \ | ||
80 | " | 81 | " |
81 | 82 | ||
82 | SRC_URI_append_libc-musl = " \ | 83 | SRC_URI_append_libc-musl = " \ |
@@ -86,7 +87,9 @@ SRC_URI_append_libc-musl = " \ | |||
86 | SRC_URI[addons.md5sum] = "719614fa764011a18665d08af5c8c92f" | 87 | SRC_URI[addons.md5sum] = "719614fa764011a18665d08af5c8c92f" |
87 | SRC_URI[addons.sha256sum] = "350da57408c27473eaf40e7f544bc94841bf101dc4346085260c5c4af0adac97" | 88 | SRC_URI[addons.sha256sum] = "350da57408c27473eaf40e7f544bc94841bf101dc4346085260c5c4af0adac97" |
88 | 89 | ||
89 | inherit autotools-brokensep gettext pythonnative | 90 | inherit autotools-brokensep gettext pythonnative distro_features_check |
91 | |||
92 | REQUIRED_DISTRO_FEATURES += "opengl" | ||
90 | 93 | ||
91 | S = "${WORKDIR}/git" | 94 | S = "${WORKDIR}/git" |
92 | 95 | ||
@@ -97,9 +100,8 @@ ACCEL ?= "" | |||
97 | ACCEL_x86 = "vaapi vdpau" | 100 | ACCEL_x86 = "vaapi vdpau" |
98 | ACCEL_x86-64 = "vaapi vdpau" | 101 | ACCEL_x86-64 = "vaapi vdpau" |
99 | 102 | ||
100 | PACKAGECONFIG ??= "${ACCEL}" | 103 | PACKAGECONFIG ??= "${ACCEL} opengl" |
101 | PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', '', d)}" | 104 | PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', ' openglesv2', d)}" |
102 | PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', ' opengl', ' openglesv2', d)}" | ||
103 | 105 | ||
104 | PACKAGECONFIG[opengl] = "--enable-gl,--enable-gles," | 106 | PACKAGECONFIG[opengl] = "--enable-gl,--enable-gles," |
105 | PACKAGECONFIG[openglesv2] = "--enable-gles,--enable-gl,virtual/egl" | 107 | PACKAGECONFIG[openglesv2] = "--enable-gles,--enable-gl,virtual/egl" |