summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch4
-rw-r--r--meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch2
-rw-r--r--meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch2
-rw-r--r--meta-oe/recipes-devtools/php/php/0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch4
-rw-r--r--meta-oe/recipes-devtools/php/php/0008-ext-imap-config.m4-fix-include-paths.patch4
-rw-r--r--meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch3
-rw-r--r--meta-oe/recipes-devtools/php/php/0010-iconv-fix-detection.patch2
-rw-r--r--meta-oe/recipes-devtools/php/php_8.2.26.bb (renamed from meta-oe/recipes-devtools/php/php_8.2.20.bb)2
8 files changed, 12 insertions, 11 deletions
diff --git a/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch b/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch
index c743697469..009d4d650f 100644
--- a/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch
+++ b/meta-oe/recipes-devtools/php/php/0001-ext-opcache-config.m4-enable-opcache.patch
@@ -247,8 +247,8 @@ index 6bf07ad3..5d645b86 100644
247+ have_shm_mmap_posix=yes 247+ have_shm_mmap_posix=yes
248+ PHP_CHECK_LIBRARY(rt, shm_unlink, [PHP_ADD_LIBRARY(rt,1,OPCACHE_SHARED_LIBADD)]) 248+ PHP_CHECK_LIBRARY(rt, shm_unlink, [PHP_ADD_LIBRARY(rt,1,OPCACHE_SHARED_LIBADD)])
249 249
250 PHP_NEW_EXTENSION(opcache, 250 AX_CHECK_COMPILE_FLAG([-Wno-implicit-fallthrough],
251 ZendAccelerator.c \ 251 [PHP_OPCACHE_CFLAGS="$PHP_OPCACHE_CFLAGS -Wno-implicit-fallthrough"],,
252-- 252--
2532.40.0 2532.40.0
254 254
diff --git a/meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch b/meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch
index 6183f49c28..2e1e752d61 100644
--- a/meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch
+++ b/meta-oe/recipes-devtools/php/php/0002-build-php.m4-don-t-unset-cache-variables.patch
@@ -31,7 +31,7 @@ index 9746ba28f3..93551d9ca7 100644
31 unset found 31 unset found
32 AC_CHECK_LIB($2, $1, [found=yes], [ 32 AC_CHECK_LIB($2, $1, [found=yes], [
33 AC_CHECK_LIB($2, __$1, [found=yes], [found=no]) 33 AC_CHECK_LIB($2, __$1, [found=yes], [found=no])
34@@ -1601,8 +1599,6 @@ dnl and as a fall back in the specified library. Defines HAVE_func and 34@@ -1604,8 +1602,6 @@ dnl and as a fall back in the specified library. Defines HAVE_func and
35 dnl HAVE_library if found and adds the library to LIBS. 35 dnl HAVE_library if found and adds the library to LIBS.
36 dnl 36 dnl
37 AC_DEFUN([PHP_CHECK_FUNC],[ 37 AC_DEFUN([PHP_CHECK_FUNC],[
diff --git a/meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch b/meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch
index 9637ed9516..1aa28e2add 100644
--- a/meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch
+++ b/meta-oe/recipes-devtools/php/php/0003-php-remove-host-specific-info-from-header-file.patch
@@ -22,7 +22,7 @@ diff --git a/configure.ac b/configure.ac
22index 1eafd62a44..90c94323aa 100644 22index 1eafd62a44..90c94323aa 100644
23--- a/configure.ac 23--- a/configure.ac
24+++ b/configure.ac 24+++ b/configure.ac
25@@ -1289,7 +1289,7 @@ PHP_REMOVE_USR_LIB(LDFLAGS) 25@@ -1462,7 +1462,7 @@ PHP_REMOVE_USR_LIB(LDFLAGS)
26 EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS" 26 EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
27 EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS" 27 EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
28 28
diff --git a/meta-oe/recipes-devtools/php/php/0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch b/meta-oe/recipes-devtools/php/php/0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch
index acf2940839..04bd40f4ff 100644
--- a/meta-oe/recipes-devtools/php/php/0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch
+++ b/meta-oe/recipes-devtools/php/php/0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch
@@ -18,9 +18,11 @@ Signed-off-by: Claude Bing <cbing@cybernetics.com>
18 ext/phar/Makefile.frag | 17 +++-------------- 18 ext/phar/Makefile.frag | 17 +++--------------
19 1 file changed, 3 insertions(+), 14 deletions(-) 19 1 file changed, 3 insertions(+), 14 deletions(-)
20 20
21diff --git a/ext/phar/Makefile.frag b/ext/phar/Makefile.frag
22index 7a867dd7..4dbcafd4 100644
21--- a/ext/phar/Makefile.frag 23--- a/ext/phar/Makefile.frag
22+++ b/ext/phar/Makefile.frag 24+++ b/ext/phar/Makefile.frag
23@@ -10,20 +10,9 @@ pharcmd: $(builddir)/phar.php $(builddir 25@@ -10,20 +10,9 @@ pharcmd: $(builddir)/phar.php $(builddir)/phar.phar
24 26
25 PHP_PHARCMD_SETTINGS = -n -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 27 PHP_PHARCMD_SETTINGS = -n -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0
26 PHP_PHARCMD_EXECUTABLE = ` \ 28 PHP_PHARCMD_EXECUTABLE = ` \
diff --git a/meta-oe/recipes-devtools/php/php/0008-ext-imap-config.m4-fix-include-paths.patch b/meta-oe/recipes-devtools/php/php/0008-ext-imap-config.m4-fix-include-paths.patch
index 78bae58e00..a1b93a2369 100644
--- a/meta-oe/recipes-devtools/php/php/0008-ext-imap-config.m4-fix-include-paths.patch
+++ b/meta-oe/recipes-devtools/php/php/0008-ext-imap-config.m4-fix-include-paths.patch
@@ -16,7 +16,7 @@ diff --git a/ext/imap/config.m4 b/ext/imap/config.m4
16index 5086a312d0..0e938bd544 100644 16index 5086a312d0..0e938bd544 100644
17--- a/ext/imap/config.m4 17--- a/ext/imap/config.m4
18+++ b/ext/imap/config.m4 18+++ b/ext/imap/config.m4
19@@ -110,7 +110,7 @@ if test "$PHP_IMAP" != "no"; then 19@@ -122,7 +122,7 @@ if test "$PHP_IMAP" != "no"; then
20 PHP_NEW_EXTENSION(imap, php_imap.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1) 20 PHP_NEW_EXTENSION(imap, php_imap.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
21 AC_DEFINE(HAVE_IMAP,1,[ ]) 21 AC_DEFINE(HAVE_IMAP,1,[ ])
22 22
@@ -25,7 +25,7 @@ index 5086a312d0..0e938bd544 100644
25 IMAP_INC_CHK() 25 IMAP_INC_CHK()
26 el[]IMAP_INC_CHK(/include/c-client) 26 el[]IMAP_INC_CHK(/include/c-client)
27 el[]IMAP_INC_CHK(/include/imap) 27 el[]IMAP_INC_CHK(/include/imap)
28@@ -199,13 +199,7 @@ if test "$PHP_IMAP" != "no"; then 28@@ -211,13 +211,7 @@ if test "$PHP_IMAP" != "no"; then
29 AC_MSG_ERROR(Cannot find rfc822.h. Please check your c-client installation.) 29 AC_MSG_ERROR(Cannot find rfc822.h. Please check your c-client installation.)
30 fi 30 fi
31 31
diff --git a/meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch b/meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch
index b5a33cca7f..d329387e6c 100644
--- a/meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch
+++ b/meta-oe/recipes-devtools/php/php/0009-php-don-t-use-broken-wrapper-for-mkdir.patch
@@ -10,9 +10,8 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
10 10
11update patch to version 8.0.12 11update patch to version 8.0.12
12Signed-off-by: Claude Bing <cbing@cybernetics.com> 12Signed-off-by: Claude Bing <cbing@cybernetics.com>
13---
14Upstream-Status: Pending 13Upstream-Status: Pending
15 14---
16 build/Makefile.global | 2 +- 15 build/Makefile.global | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-) 16 1 file changed, 1 insertion(+), 1 deletion(-)
18 17
diff --git a/meta-oe/recipes-devtools/php/php/0010-iconv-fix-detection.patch b/meta-oe/recipes-devtools/php/php/0010-iconv-fix-detection.patch
index e3b8cd4707..49fb3a5886 100644
--- a/meta-oe/recipes-devtools/php/php/0010-iconv-fix-detection.patch
+++ b/meta-oe/recipes-devtools/php/php/0010-iconv-fix-detection.patch
@@ -20,7 +20,7 @@ diff --git a/build/php.m4 b/build/php.m4
20index 93551d9ca7..dba50825fb 100644 20index 93551d9ca7..dba50825fb 100644
21--- a/build/php.m4 21--- a/build/php.m4
22+++ b/build/php.m4 22+++ b/build/php.m4
23@@ -1919,7 +1919,8 @@ AC_DEFUN([PHP_SETUP_ICONV], [ 23@@ -1945,7 +1945,8 @@ AC_DEFUN([PHP_SETUP_ICONV], [
24 unset ICONV_DIR 24 unset ICONV_DIR
25 25
26 dnl Check libc first if no path is provided in --with-iconv. 26 dnl Check libc first if no path is provided in --with-iconv.
diff --git a/meta-oe/recipes-devtools/php/php_8.2.20.bb b/meta-oe/recipes-devtools/php/php_8.2.26.bb
index f306b16931..f5e57ab36a 100644
--- a/meta-oe/recipes-devtools/php/php_8.2.20.bb
+++ b/meta-oe/recipes-devtools/php/php_8.2.26.bb
@@ -34,7 +34,7 @@ SRC_URI:append:class-target = " \
34 " 34 "
35 35
36S = "${WORKDIR}/php-${PV}" 36S = "${WORKDIR}/php-${PV}"
37SRC_URI[sha256sum] = "5dec6fa61c7b9c47aa1d76666be651f2642ed2bcf6cd8638c57e3571ce2aac61" 37SRC_URI[sha256sum] = "be57c347d451c905bcb4336832a864d9928dd0e20989b872705fea0ba6476c6b"
38 38
39CVE_STATUS_GROUPS += "CVE_STATUS_PHP" 39CVE_STATUS_GROUPS += "CVE_STATUS_PHP"
40CVE_STATUS_PHP[status] = "fixed-version: The name of this product is exactly the same as github.com/emlog/emlog. CVE can be safely ignored." 40CVE_STATUS_PHP[status] = "fixed-version: The name of this product is exactly the same as github.com/emlog/emlog. CVE can be safely ignored."