summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch44
-rw-r--r--meta-networking/recipes-support/ncp/libowfat_0.32.bb4
2 files changed, 47 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch b/meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch
new file mode 100644
index 0000000000..6226e2c038
--- /dev/null
+++ b/meta-networking/recipes-support/ncp/libowfat/0001-Depend-on-haveuint128.h-for-umult64.c.patch
@@ -0,0 +1,44 @@
1From 7f6a104a682d59f28f7df889129f4467cc45e912 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 6 Nov 2019 19:55:42 -0800
4Subject: [PATCH] Depend on haveuint128.h for umult64.c
5
6This fixes parallel build issue e.g.
7mult/umult64.c:9:10: fatal error: 'haveuint128.h' file not found
8 ^~~~~~~~~~~~~~~
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 GNUmakefile | 1 +
14 Makefile | 2 +-
15 2 files changed, 2 insertions(+), 1 deletion(-)
16
17diff --git a/GNUmakefile b/GNUmakefile
18index 3f3193d..751ca60 100644
19--- a/GNUmakefile
20+++ b/GNUmakefile
21@@ -126,6 +126,7 @@ $(CDB_OBJS): cdb.h uint32.h
22 $(CRITBIT_OBJS): critbit.h
23
24 mult64.o: haveuint128.h
25+umult64.o: haveuint128.h
26
27
28 iob_addbuf.o iob_addfile.o iob_new.o iob_reset.o iob_send.o: iob_internal.h iob.h
29diff --git a/Makefile b/Makefile
30index 0d08da4..02df6c6 100644
31--- a/Makefile
32+++ b/Makefile
33@@ -430,7 +430,7 @@ range_str4inbuf.o: mult/range_str4inbuf.c rangecheck.h
34 range_strinbuf.o: mult/range_strinbuf.c rangecheck.h
35 umult16.o: mult/umult16.c uint16.h
36 umult32.o: mult/umult32.c uint32.h
37-umult64.o: mult/umult64.c uint64.h
38+umult64.o: mult/umult64.c uint64.h haveuint128.h
39 open_append.o: open/open_append.c open.h
40 open_excl.o: open/open_excl.c open.h
41 open_read.o: open/open_read.c open.h
42--
432.24.0
44
diff --git a/meta-networking/recipes-support/ncp/libowfat_0.32.bb b/meta-networking/recipes-support/ncp/libowfat_0.32.bb
index a5e2c21cf0..24f4135551 100644
--- a/meta-networking/recipes-support/ncp/libowfat_0.32.bb
+++ b/meta-networking/recipes-support/ncp/libowfat_0.32.bb
@@ -6,7 +6,9 @@ HOMEPAGE = "http://www.fefe.de/libowfat"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" 7LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
8 8
9SRC_URI = "https://www.fefe.de/${BPN}/${BP}.tar.xz" 9SRC_URI = "https://www.fefe.de/${BPN}/${BP}.tar.xz \
10 file://0001-Depend-on-haveuint128.h-for-umult64.c.patch \
11 "
10SRC_URI[md5sum] = "ee015ccf45cb2bc61c942642038c2bdc" 12SRC_URI[md5sum] = "ee015ccf45cb2bc61c942642038c2bdc"
11SRC_URI[sha256sum] = "f4b9b3d9922dc25bc93adedf9e9ff8ddbebaf623f14c8e7a5f2301bfef7998c1" 13SRC_URI[sha256sum] = "f4b9b3d9922dc25bc93adedf9e9ff8ddbebaf623f14c8e7a5f2301bfef7998c1"
12 14