diff options
-rw-r--r-- | meta-oe/recipes-extended/zstd/zstd_1.4.4.bb | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/zstd/zstd_1.4.4.bb b/meta-oe/recipes-extended/zstd/zstd_1.4.4.bb new file mode 100644 index 0000000000..eb201f4139 --- /dev/null +++ b/meta-oe/recipes-extended/zstd/zstd_1.4.4.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "Zstandard - Fast real-time compression algorithm" | ||
2 | DESCRIPTION = "Zstandard is a fast lossless compression algorithm, targeting \ | ||
3 | real-time compression scenarios at zlib-level and better compression ratios. \ | ||
4 | It's backed by a very fast entropy stage, provided by Huff0 and FSE library." | ||
5 | HOMEPAGE = "http://www.zstd.net/" | ||
6 | SECTION = "console/utils" | ||
7 | |||
8 | LICENSE = "BSD-3-Clause & GPLv2" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c7f0b161edbe52f5f345a3d1311d0b32 \ | ||
10 | file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0" | ||
11 | |||
12 | SRC_URI = "git://github.com/facebook/zstd.git;nobranch=1" | ||
13 | |||
14 | SRCREV = "10f0e6993f9d2f682da6d04aa2385b7d53cbb4ee" | ||
15 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | PACKAGECONFIG ??= "" | ||
20 | PACKAGECONFIG[lz4] = "HAVE_LZ4=1,HAVE_LZ4=0,lz4" | ||
21 | PACKAGECONFIG[lzma] = "HAVE_LZMA=1,HAVE_LZMA=0,xz" | ||
22 | PACKAGECONFIG[zlib] = "HAVE_ZLIB=1,HAVE_ZLIB=0,zlib" | ||
23 | |||
24 | # See programs/README.md for how to use this | ||
25 | ZSTD_LEGACY_SUPPORT ??= "4" | ||
26 | |||
27 | do_compile () { | ||
28 | oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT} | ||
29 | } | ||
30 | |||
31 | do_install () { | ||
32 | oe_runmake install 'DESTDIR=${D}' | ||
33 | } | ||
34 | |||
35 | BBCLASSEXTEND = "native nativesdk" | ||