summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/Check-response-existence-on-upgrade.patch49
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.55.bb (renamed from meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.53.bb)7
2 files changed, 2 insertions, 54 deletions
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/Check-response-existence-on-upgrade.patch b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/Check-response-existence-on-upgrade.patch
deleted file mode 100644
index a02bbd4d03..0000000000
--- a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd/Check-response-existence-on-upgrade.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From: jose.bollo@iot.bzh
2Date: Thu, 4 May 2017 21:47:38 +0200
3Subject: [PATCH] Check response existence on upgrade
4MIME-Version: 1.0
5Content-Type: text/plain; charset=UTF-8
6Content-Transfer-Encoding: 8bit
7
8When a connection upgrade is requested and when the
9request sent an error reply, the response is most of
10the time already sent when the test on
11connection->response->upgrade_handler is made, leading
12to dereferencing NULL.
13
14Two possibilities exist:
15
16 NULL == connection->response || NULL == connection->response->upgrade_handler
17
18or
19
20 NULL != connection->response && NULL == connection->response->upgrade_handler
21
22The first is prefered because it is probably safer to close the connection
23in that case.
24
25Upstream-Status: Accepted [https://gnunet.org/git/libmicrohttpd.git/commit/?id=b4216c60fdb5b48f6cfec416301fc63a1167e6cd]
26
27Change-Id: Ie6e7fc165f7fe3635ade0952bb34a0b937d38716
28Signed-off-by: José Bollo <jobol@nonadev.net>
29Signed-off-by: José Bollo <jose.bollo@iot.bzh>
30---
31 src/microhttpd/connection.c | 2 +-
32 1 file changed, 1 insertion(+), 1 deletion(-)
33
34diff --git a/src/microhttpd/connection.c b/src/microhttpd/connection.c
35index a495524..d39c110 100644
36--- a/src/microhttpd/connection.c
37+++ b/src/microhttpd/connection.c
38@@ -882,7 +882,7 @@ keepalive_possible (struct MHD_Connection *connection)
39 #ifdef UPGRADE_SUPPORT
40 if ( (MHD_str_equal_caseless_ (end,
41 "upgrade")) &&
42- (NULL == connection->response->upgrade_handler) )
43+ (NULL == connection->response || NULL == connection->response->upgrade_handler) )
44 return MHD_NO;
45 #endif /* UPGRADE_SUPPORT */
46
47--
482.9.3
49
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.53.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.55.bb
index 45f2460d0a..ee399a7645 100644
--- a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.53.bb
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.55.bb
@@ -6,11 +6,8 @@ SECTION = "net"
6DEPENDS = "libgcrypt gnutls file" 6DEPENDS = "libgcrypt gnutls file"
7 7
8SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz" 8SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9SRC_URI[md5sum] = "5a425e993a0f5295aecb5d6607a1c242" 9SRC_URI[md5sum] = "1c20f84a8b9cf692dd50b558b3571a3a"
10SRC_URI[sha256sum] = "9b15ec2d381f44936323adfd4f989fa35add517cccbbfa581896b02a393c2cc4" 10SRC_URI[sha256sum] = "0c1cab8dc9f2588bd3076a28f77a7f8de9560cbf2d80e53f9a8696ada80ed0f8"
11
12FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
13SRC_URI += " file://Check-response-existence-on-upgrade.patch"
14 11
15inherit autotools lib_package pkgconfig gettext 12inherit autotools lib_package pkgconfig gettext
16 13