diff options
-rw-r--r-- | meta-networking/recipes-connectivity/kea/files/0001-Added-option-to-provide-kea-msg-compiler.patch | 235 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/kea/files/0001-Makefile.am-fix-compile-error-about-kea-msg-compiler.patch | 72 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/kea/files/0001-asiolink-fix-build-with-boost-1.66.patch | 103 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/kea/files/0003-Makefile.am-update-hooksdir-for-lease_cmds.patch (renamed from meta-networking/recipes-connectivity/kea/files/0001-Makefile.am-update-hooksdir-for-lease_cmds.patch) | 7 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/kea/kea_1.4.0.bb (renamed from meta-networking/recipes-connectivity/kea/kea_1.3.0.bb) | 29 |
5 files changed, 18 insertions, 428 deletions
diff --git a/meta-networking/recipes-connectivity/kea/files/0001-Added-option-to-provide-kea-msg-compiler.patch b/meta-networking/recipes-connectivity/kea/files/0001-Added-option-to-provide-kea-msg-compiler.patch deleted file mode 100644 index b58a658b92..0000000000 --- a/meta-networking/recipes-connectivity/kea/files/0001-Added-option-to-provide-kea-msg-compiler.patch +++ /dev/null | |||
@@ -1,235 +0,0 @@ | |||
1 | From c7806af2957627151ef603ad4aa893ca1a4bf59e Mon Sep 17 00:00:00 2001 | ||
2 | From: Siyu Zhang <siyu.zhang@windriver.com> | ||
3 | Date: Sat, 10 Sep 2016 15:44:10 +0200 | ||
4 | Subject: [PATCH 1/1] Added option to provide kea-msg-compiler | ||
5 | |||
6 | Upstream-Status: Inappropriate[oe specific] | ||
7 | |||
8 | Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> | ||
9 | --- | ||
10 | configure.ac | 18 ++++++++++++++++++ | ||
11 | src/bin/d2/Makefile.am | 2 +- | ||
12 | src/bin/dhcp4/Makefile.am | 2 +- | ||
13 | src/bin/dhcp6/Makefile.am | 2 +- | ||
14 | src/bin/lfc/Makefile.am | 2 +- | ||
15 | src/hooks/dhcp/user_chk/Makefile.am | 2 +- | ||
16 | src/lib/asiodns/Makefile.am | 2 +- | ||
17 | src/lib/config/Makefile.am | 2 +- | ||
18 | src/lib/dhcp_ddns/Makefile.am | 2 +- | ||
19 | src/lib/dhcpsrv/Makefile.am | 6 +++--- | ||
20 | src/lib/eval/Makefile.am | 2 +- | ||
21 | src/lib/hooks/Makefile.am | 2 +- | ||
22 | src/lib/log/Makefile.am | 8 +++++++- | ||
23 | src/lib/log/tests/Makefile.am | 2 +- | ||
24 | 14 files changed, 39 insertions(+), 15 deletions(-) | ||
25 | |||
26 | diff --git a/configure.ac b/configure.ac | ||
27 | index ea41f08..edb5120 100644 | ||
28 | --- a/configure.ac | ||
29 | +++ b/configure.ac | ||
30 | @@ -202,6 +202,24 @@ case "$host" in | ||
31 | esac | ||
32 | KEA_CXXFLAGS="$KEA_CXXFLAGS $MULTITHREADING_FLAG" | ||
33 | |||
34 | +AC_MSG_CHECKING(whether kea-msg-compiler is provided) | ||
35 | +AC_ARG_WITH(msg-compiler, | ||
36 | + AC_HELP_STRING([--with-msg-compiler=PATH], [use provided kea-msg-compiler instead of local build]), | ||
37 | + [ | ||
38 | + dnl TODO: Validate provided kea-msg-compiler | ||
39 | + AC_SUBST([KEA_MSG_COMPILER], [${withval}]) | ||
40 | + AC_MSG_RESULT(${withval})], | ||
41 | + [ | ||
42 | + AC_MSG_RESULT([no]) | ||
43 | + if test x"$host" != x"$build" && test x"$host" == x"$target"; then | ||
44 | + AC_MSG_ERROR(native kea-msg-compiler not provided for cross compilation: build=${build} host=${host} target=${target}) | ||
45 | + else | ||
46 | + AC_SUBST([KEA_MSG_COMPILER], ['$(top_builddir)/src/lib/log/compiler/kea-msg-compiler']) | ||
47 | + with_msg_compiler=no | ||
48 | + fi]) | ||
49 | + | ||
50 | +AM_CONDITIONAL([HAVE_MSG_COMPILER], [test x"$with_msg_compiler" != x"no"]) | ||
51 | + | ||
52 | # Disable -Werror by default. Only use it if specifically enabled. | ||
53 | # The usage of this flag is: | ||
54 | # | ||
55 | diff --git a/src/bin/d2/Makefile.am b/src/bin/d2/Makefile.am | ||
56 | index 0b4e7d5..40cc094 100644 | ||
57 | --- a/src/bin/d2/Makefile.am | ||
58 | +++ b/src/bin/d2/Makefile.am | ||
59 | @@ -53,7 +53,7 @@ spec_config.h: spec_config.h.pre | ||
60 | d2_messages.h d2_messages.cc: s-messages | ||
61 | |||
62 | s-messages: d2_messages.mes | ||
63 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/bin/d2/d2_messages.mes | ||
64 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/bin/d2/d2_messages.mes | ||
65 | touch $@ | ||
66 | |||
67 | BUILT_SOURCES = d2_messages.h d2_messages.cc | ||
68 | diff --git a/src/bin/dhcp4/Makefile.am b/src/bin/dhcp4/Makefile.am | ||
69 | index 8360677..57acb91 100644 | ||
70 | --- a/src/bin/dhcp4/Makefile.am | ||
71 | +++ b/src/bin/dhcp4/Makefile.am | ||
72 | @@ -47,7 +47,7 @@ spec_config.h: spec_config.h.pre | ||
73 | dhcp4_messages.h dhcp4_messages.cc: s-messages | ||
74 | |||
75 | s-messages: dhcp4_messages.mes | ||
76 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/bin/dhcp4/dhcp4_messages.mes | ||
77 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/bin/dhcp4/dhcp4_messages.mes | ||
78 | touch $@ | ||
79 | |||
80 | BUILT_SOURCES = spec_config.h dhcp4_messages.h dhcp4_messages.cc | ||
81 | diff --git a/src/bin/dhcp6/Makefile.am b/src/bin/dhcp6/Makefile.am | ||
82 | index 47155ae..d7ed722 100644 | ||
83 | --- a/src/bin/dhcp6/Makefile.am | ||
84 | +++ b/src/bin/dhcp6/Makefile.am | ||
85 | @@ -48,7 +48,7 @@ spec_config.h: spec_config.h.pre | ||
86 | dhcp6_messages.h dhcp6_messages.cc: s-messages | ||
87 | |||
88 | s-messages: dhcp6_messages.mes | ||
89 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/bin/dhcp6/dhcp6_messages.mes | ||
90 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/bin/dhcp6/dhcp6_messages.mes | ||
91 | touch $@ | ||
92 | |||
93 | BUILT_SOURCES = spec_config.h dhcp6_messages.h dhcp6_messages.cc | ||
94 | diff --git a/src/bin/lfc/Makefile.am b/src/bin/lfc/Makefile.am | ||
95 | index 7bfeb96..09a700e 100644 | ||
96 | --- a/src/bin/lfc/Makefile.am | ||
97 | +++ b/src/bin/lfc/Makefile.am | ||
98 | @@ -32,7 +32,7 @@ endif | ||
99 | lfc_messages.h lfc_messages.cc: s-messages | ||
100 | |||
101 | s-messages: lfc_messages.mes | ||
102 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/bin/lfc/lfc_messages.mes | ||
103 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/bin/lfc/lfc_messages.mes | ||
104 | touch $@ | ||
105 | |||
106 | BUILT_SOURCES = lfc_messages.h lfc_messages.cc | ||
107 | diff --git a/src/hooks/dhcp/user_chk/Makefile.am b/src/hooks/dhcp/user_chk/Makefile.am | ||
108 | index 41ad7b2..32a93412 100644 | ||
109 | --- a/src/hooks/dhcp/user_chk/Makefile.am | ||
110 | +++ b/src/hooks/dhcp/user_chk/Makefile.am | ||
111 | @@ -7,7 +7,7 @@ AM_CXXFLAGS = $(KEA_CXXFLAGS) | ||
112 | # Define rule to build logging source files from message file | ||
113 | user_chk_messages.h user_chk_messages.cc: s-messages | ||
114 | s-messages: user_chk_messages.mes | ||
115 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/hooks/dhcp/user_chk/user_chk_messages.mes | ||
116 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/hooks/dhcp/user_chk/user_chk_messages.mes | ||
117 | touch $@ | ||
118 | |||
119 | # Tell automake that the message files are built as part of the build process | ||
120 | diff --git a/src/lib/asiodns/Makefile.am b/src/lib/asiodns/Makefile.am | ||
121 | index 24dfe05..60c9f80 100644 | ||
122 | --- a/src/lib/asiodns/Makefile.am | ||
123 | +++ b/src/lib/asiodns/Makefile.am | ||
124 | @@ -11,7 +11,7 @@ CLEANFILES = *.gcno *.gcda asiodns_messages.h asiodns_messages.cc s-messages | ||
125 | asiodns_messages.h asiodns_messages.cc: s-messages | ||
126 | |||
127 | s-messages: asiodns_messages.mes | ||
128 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/asiodns/asiodns_messages.mes | ||
129 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/asiodns/asiodns_messages.mes | ||
130 | touch $@ | ||
131 | |||
132 | BUILT_SOURCES = asiodns_messages.h asiodns_messages.cc | ||
133 | diff --git a/src/lib/config/Makefile.am b/src/lib/config/Makefile.am | ||
134 | index a89d530..26894ad 100644 | ||
135 | --- a/src/lib/config/Makefile.am | ||
136 | +++ b/src/lib/config/Makefile.am | ||
137 | @@ -7,7 +7,7 @@ AM_CPPFLAGS += $(BOOST_INCLUDES) | ||
138 | config_messages.h config_messages.cc: s-messages | ||
139 | |||
140 | s-messages: config_messages.mes | ||
141 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/config/config_messages.mes | ||
142 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/config/config_messages.mes | ||
143 | touch $@ | ||
144 | |||
145 | BUILT_SOURCES = config_messages.h config_messages.cc | ||
146 | diff --git a/src/lib/dhcp_ddns/Makefile.am b/src/lib/dhcp_ddns/Makefile.am | ||
147 | index 820f448..fe15533 100644 | ||
148 | --- a/src/lib/dhcp_ddns/Makefile.am | ||
149 | +++ b/src/lib/dhcp_ddns/Makefile.am | ||
150 | @@ -8,7 +8,7 @@ AM_CXXFLAGS = $(KEA_CXXFLAGS) | ||
151 | dhcp_ddns_messages.h dhcp_ddns_messages.cc: s-messages | ||
152 | |||
153 | s-messages: dhcp_ddns_messages.mes | ||
154 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/dhcp_ddns/dhcp_ddns_messages.mes | ||
155 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/dhcp_ddns/dhcp_ddns_messages.mes | ||
156 | touch $@ | ||
157 | |||
158 | # Tell automake that the message files are built as part of the build process | ||
159 | diff --git a/src/lib/dhcpsrv/Makefile.am b/src/lib/dhcpsrv/Makefile.am | ||
160 | index db95dbd..6499b9f 100644 | ||
161 | --- a/src/lib/dhcpsrv/Makefile.am | ||
162 | +++ b/src/lib/dhcpsrv/Makefile.am | ||
163 | @@ -52,11 +52,11 @@ alloc_engine_messages.h alloc_engine_messages.cc dhcpsrv_messages.h \ | ||
164 | dhcpsrv_messages.cc hosts_messages.h hosts_messages.cc: s-messages | ||
165 | |||
166 | s-messages: alloc_engine_messages.mes dhcpsrv_messages.mes hosts_messages.mes | ||
167 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/dhcpsrv/alloc_engine_messages.mes | ||
168 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/dhcpsrv/alloc_engine_messages.mes | ||
169 | touch $@ | ||
170 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/dhcpsrv/dhcpsrv_messages.mes | ||
171 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/dhcpsrv/dhcpsrv_messages.mes | ||
172 | touch $@ | ||
173 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/dhcpsrv/hosts_messages.mes | ||
174 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/dhcpsrv/hosts_messages.mes | ||
175 | touch $@ | ||
176 | |||
177 | # Tell Automake that the {alloc_engine,dhcpsrv,hosts}_messages.{cc,h} source files | ||
178 | diff --git a/src/lib/eval/Makefile.am b/src/lib/eval/Makefile.am | ||
179 | index e4968c1..f8464f8 100644 | ||
180 | --- a/src/lib/eval/Makefile.am | ||
181 | +++ b/src/lib/eval/Makefile.am | ||
182 | @@ -47,7 +47,7 @@ EXTRA_DIST += lexer.ll parser.yy | ||
183 | eval_messages.h eval_messages.cc: s-messages | ||
184 | |||
185 | s-messages: eval_messages.mes | ||
186 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/eval/eval_messages.mes | ||
187 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/eval/eval_messages.mes | ||
188 | touch $@ | ||
189 | |||
190 | # Tell Automake that the eval_messages.{cc,h} source files are created in the | ||
191 | diff --git a/src/lib/hooks/Makefile.am b/src/lib/hooks/Makefile.am | ||
192 | index 624e227..3458da8 100644 | ||
193 | --- a/src/lib/hooks/Makefile.am | ||
194 | +++ b/src/lib/hooks/Makefile.am | ||
195 | @@ -8,7 +8,7 @@ AM_CXXFLAGS = $(KEA_CXXFLAGS) | ||
196 | hooks_messages.h hooks_messages.cc: s-messages | ||
197 | |||
198 | s-messages: hooks_messages.mes | ||
199 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/hooks/hooks_messages.mes | ||
200 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/hooks/hooks_messages.mes | ||
201 | touch $@ | ||
202 | |||
203 | # Tell automake that the message files are built as part of the build process | ||
204 | diff --git a/src/lib/log/Makefile.am b/src/lib/log/Makefile.am | ||
205 | index e1185cd..22e9ce6 100644 | ||
206 | --- a/src/lib/log/Makefile.am | ||
207 | +++ b/src/lib/log/Makefile.am | ||
208 | @@ -1,4 +1,10 @@ | ||
209 | -SUBDIRS = interprocess . compiler tests | ||
210 | +SUBDIRS = interprocess . | ||
211 | + | ||
212 | +if !HAVE_MSG_COMPILER | ||
213 | +SUBDIRS += compiler | ||
214 | +endif | ||
215 | + | ||
216 | +SUBDIRS += tests | ||
217 | |||
218 | AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib | ||
219 | AM_CPPFLAGS += $(BOOST_INCLUDES) | ||
220 | diff --git a/src/lib/log/tests/Makefile.am b/src/lib/log/tests/Makefile.am | ||
221 | index 03806f9..caf9cab 100644 | ||
222 | --- a/src/lib/log/tests/Makefile.am | ||
223 | +++ b/src/lib/log/tests/Makefile.am | ||
224 | @@ -17,7 +17,7 @@ BUILT_SOURCES = log_test_messages.h log_test_messages.cc | ||
225 | log_test_messages.h log_test_messages.cc: s-messages | ||
226 | |||
227 | s-messages: log_test_messages.mes | ||
228 | - $(AM_V_GEN) $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/log/tests/log_test_messages.mes | ||
229 | + $(AM_V_GEN) @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/log/tests/log_test_messages.mes | ||
230 | touch $@ | ||
231 | |||
232 | CLEANFILES += log_test_messages.h log_test_messages.cc s-messages | ||
233 | -- | ||
234 | 1.8.4.2 | ||
235 | |||
diff --git a/meta-networking/recipes-connectivity/kea/files/0001-Makefile.am-fix-compile-error-about-kea-msg-compiler.patch b/meta-networking/recipes-connectivity/kea/files/0001-Makefile.am-fix-compile-error-about-kea-msg-compiler.patch deleted file mode 100644 index e8a4ae41b5..0000000000 --- a/meta-networking/recipes-connectivity/kea/files/0001-Makefile.am-fix-compile-error-about-kea-msg-compiler.patch +++ /dev/null | |||
@@ -1,72 +0,0 @@ | |||
1 | From d800c6017962e358c8b2ada6803acb0f4011a763 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <Mingli.Yu@windriver.com> | ||
3 | Date: Fri, 16 Mar 2018 08:03:20 +0000 | ||
4 | Subject: [PATCH] Makefile.am: fix compile error about kea-msg-compiler | ||
5 | |||
6 | fix compile error about kea-msg-compiler | ||
7 | |||
8 | Upstream-Status: Inappropriate[oe specific] | ||
9 | |||
10 | Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> | ||
11 | --- | ||
12 | src/bin/agent/Makefile.am | 2 +- | ||
13 | src/hooks/dhcp/lease_cmds/Makefile.am | 2 +- | ||
14 | src/lib/http/Makefile.am | 2 +- | ||
15 | src/lib/process/Makefile.am | 2 +- | ||
16 | 4 files changed, 4 insertions(+), 4 deletions(-) | ||
17 | |||
18 | diff --git a/src/bin/agent/Makefile.am b/src/bin/agent/Makefile.am | ||
19 | index e67c572..b646325 100644 | ||
20 | --- a/src/bin/agent/Makefile.am | ||
21 | +++ b/src/bin/agent/Makefile.am | ||
22 | @@ -33,7 +33,7 @@ endif | ||
23 | ca_messages.h ca_messages.cc: s-messages | ||
24 | |||
25 | s-messages: ca_messages.mes | ||
26 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/bin/agent/ca_messages.mes | ||
27 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/bin/agent/ca_messages.mes | ||
28 | touch $@ | ||
29 | |||
30 | BUILT_SOURCES = ca_messages.h ca_messages.cc | ||
31 | diff --git a/src/hooks/dhcp/lease_cmds/Makefile.am b/src/hooks/dhcp/lease_cmds/Makefile.am | ||
32 | index 90abfda..cfd6779 100644 | ||
33 | --- a/src/hooks/dhcp/lease_cmds/Makefile.am | ||
34 | +++ b/src/hooks/dhcp/lease_cmds/Makefile.am | ||
35 | @@ -7,7 +7,7 @@ AM_CXXFLAGS = $(KEA_CXXFLAGS) | ||
36 | # Define rule to build logging source files from message file | ||
37 | lease_cmds_messages.h lease_cmds_messages.cc: s-messages | ||
38 | s-messages: lease_cmds_messages.mes | ||
39 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/hooks/dhcp/lease_cmds/lease_cmds_messages.mes | ||
40 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/hooks/dhcp/lease_cmds/lease_cmds_messages.mes | ||
41 | touch $@ | ||
42 | |||
43 | # Tell automake that the message files are built as part of the build process | ||
44 | diff --git a/src/lib/http/Makefile.am b/src/lib/http/Makefile.am | ||
45 | index 2b0eed5..db3bb0e 100644 | ||
46 | --- a/src/lib/http/Makefile.am | ||
47 | +++ b/src/lib/http/Makefile.am | ||
48 | @@ -8,7 +8,7 @@ AM_CXXFLAGS = $(KEA_CXXFLAGS) | ||
49 | http_messages.h http_messages.cc: s-messages | ||
50 | |||
51 | s-messages: http_messages.mes | ||
52 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/http/http_messages.mes | ||
53 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/http/http_messages.mes | ||
54 | touch $@ | ||
55 | |||
56 | # Tell automake that the message files are built as part of the build process | ||
57 | diff --git a/src/lib/process/Makefile.am b/src/lib/process/Makefile.am | ||
58 | index c7746c6..71998ed 100644 | ||
59 | --- a/src/lib/process/Makefile.am | ||
60 | +++ b/src/lib/process/Makefile.am | ||
61 | @@ -19,7 +19,7 @@ AM_CXXFLAGS = $(KEA_CXXFLAGS) | ||
62 | process_messages.h process_messages.cc: s-messages | ||
63 | |||
64 | s-messages: process_messages.mes | ||
65 | - $(top_builddir)/src/lib/log/compiler/kea-msg-compiler $(top_srcdir)/src/lib/process/process_messages.mes | ||
66 | + @KEA_MSG_COMPILER@ $(top_srcdir)/src/lib/process/process_messages.mes | ||
67 | touch $@ | ||
68 | |||
69 | spec_config.h: spec_config.h.pre | ||
70 | -- | ||
71 | 2.13.3 | ||
72 | |||
diff --git a/meta-networking/recipes-connectivity/kea/files/0001-asiolink-fix-build-with-boost-1.66.patch b/meta-networking/recipes-connectivity/kea/files/0001-asiolink-fix-build-with-boost-1.66.patch deleted file mode 100644 index 9262381d5b..0000000000 --- a/meta-networking/recipes-connectivity/kea/files/0001-asiolink-fix-build-with-boost-1.66.patch +++ /dev/null | |||
@@ -1,103 +0,0 @@ | |||
1 | From 4fd11ef050438adeb1e0ae0d9d2d8ec3a2cb659c Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <bpiotrowski@archlinux.org> | ||
3 | Date: Sat, 30 Dec 2017 14:40:24 +0100 | ||
4 | Subject: [PATCH] asiolink: fix build with boost 1.66 | ||
5 | |||
6 | - use native_handle() for getting native socket type | ||
7 | - use io_context instead of io_service | ||
8 | |||
9 | Upstream-Status: Backport | ||
10 | |||
11 | Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> | ||
12 | --- | ||
13 | src/lib/asiolink/io_acceptor.h | 4 ++++ | ||
14 | src/lib/asiolink/io_service.h | 5 +++++ | ||
15 | src/lib/asiolink/tcp_socket.h | 4 ++++ | ||
16 | src/lib/asiolink/udp_socket.h | 4 ++++ | ||
17 | src/lib/asiolink/unix_domain_socket.cc | 4 ++++ | ||
18 | 5 files changed, 21 insertions(+) | ||
19 | |||
20 | diff --git a/src/lib/asiolink/io_acceptor.h b/src/lib/asiolink/io_acceptor.h | ||
21 | index c493d3427..913a3280b 100644 | ||
22 | --- a/src/lib/asiolink/io_acceptor.h | ||
23 | +++ b/src/lib/asiolink/io_acceptor.h | ||
24 | @@ -47,7 +47,11 @@ public: | ||
25 | |||
26 | /// @brief Returns file descriptor of the underlying socket. | ||
27 | virtual int getNative() const { | ||
28 | +#if BOOST_VERSION < 106600 | ||
29 | return (acceptor_->native()); | ||
30 | +#else | ||
31 | + return (acceptor_->native_handle()); | ||
32 | +#endif | ||
33 | } | ||
34 | |||
35 | /// @brief Opens acceptor socket given the endpoint. | ||
36 | diff --git a/src/lib/asiolink/io_service.h b/src/lib/asiolink/io_service.h | ||
37 | index e9e402d11..e0832b2c0 100644 | ||
38 | --- a/src/lib/asiolink/io_service.h | ||
39 | +++ b/src/lib/asiolink/io_service.h | ||
40 | @@ -11,7 +11,12 @@ | ||
41 | |||
42 | namespace boost { | ||
43 | namespace asio { | ||
44 | +#if BOOST_VERSION < 106600 | ||
45 | class io_service; | ||
46 | +#else | ||
47 | + class io_context; | ||
48 | + typedef io_context io_service; | ||
49 | +#endif | ||
50 | } | ||
51 | } | ||
52 | |||
53 | diff --git a/src/lib/asiolink/tcp_socket.h b/src/lib/asiolink/tcp_socket.h | ||
54 | index adf74d1f0..83b8264c8 100644 | ||
55 | --- a/src/lib/asiolink/tcp_socket.h | ||
56 | +++ b/src/lib/asiolink/tcp_socket.h | ||
57 | @@ -75,7 +75,11 @@ public: | ||
58 | |||
59 | /// \brief Return file descriptor of underlying socket | ||
60 | virtual int getNative() const { | ||
61 | +#if BOOST_VERSION < 106600 | ||
62 | return (socket_.native()); | ||
63 | +#else | ||
64 | + return (socket_.native_handle()); | ||
65 | +#endif | ||
66 | } | ||
67 | |||
68 | /// \brief Return protocol of socket | ||
69 | diff --git a/src/lib/asiolink/udp_socket.h b/src/lib/asiolink/udp_socket.h | ||
70 | index 07ba44743..5b040cfe1 100644 | ||
71 | --- a/src/lib/asiolink/udp_socket.h | ||
72 | +++ b/src/lib/asiolink/udp_socket.h | ||
73 | @@ -61,7 +61,11 @@ public: | ||
74 | |||
75 | /// \brief Return file descriptor of underlying socket | ||
76 | virtual int getNative() const { | ||
77 | +#if BOOST_VERSION < 106600 | ||
78 | return (socket_.native()); | ||
79 | +#else | ||
80 | + return (socket_.native_handle()); | ||
81 | +#endif | ||
82 | } | ||
83 | |||
84 | /// \brief Return protocol of socket | ||
85 | diff --git a/src/lib/asiolink/unix_domain_socket.cc b/src/lib/asiolink/unix_domain_socket.cc | ||
86 | index f17ec2e8f..d1ad9ec30 100644 | ||
87 | --- a/src/lib/asiolink/unix_domain_socket.cc | ||
88 | +++ b/src/lib/asiolink/unix_domain_socket.cc | ||
89 | @@ -287,7 +287,11 @@ UnixDomainSocket::UnixDomainSocket(IOService& io_service) | ||
90 | |||
91 | int | ||
92 | UnixDomainSocket::getNative() const { | ||
93 | +#if BOOST_VERSION < 106600 | ||
94 | return (impl_->socket_.native()); | ||
95 | +#else | ||
96 | + return (impl_->socket_.native_handle()); | ||
97 | +#endif | ||
98 | } | ||
99 | |||
100 | int | ||
101 | -- | ||
102 | 2.11.0 | ||
103 | |||
diff --git a/meta-networking/recipes-connectivity/kea/files/0001-Makefile.am-update-hooksdir-for-lease_cmds.patch b/meta-networking/recipes-connectivity/kea/files/0003-Makefile.am-update-hooksdir-for-lease_cmds.patch index 72fa113b00..381a3a7eb8 100644 --- a/meta-networking/recipes-connectivity/kea/files/0001-Makefile.am-update-hooksdir-for-lease_cmds.patch +++ b/meta-networking/recipes-connectivity/kea/files/0003-Makefile.am-update-hooksdir-for-lease_cmds.patch | |||
@@ -1,13 +1,14 @@ | |||
1 | From 77ab10015512e9cc0c7a160bd6b534bf4174bc95 Mon Sep 17 00:00:00 2001 | 1 | From cd902b8b588681a27d5321f1ee078a1c8f6e6935 Mon Sep 17 00:00:00 2001 |
2 | From: Mingli Yu <Mingli.Yu@windriver.com> | 2 | From: Mingli Yu <Mingli.Yu@windriver.com> |
3 | Date: Wed, 21 Mar 2018 06:01:38 +0000 | 3 | Date: Wed, 21 Mar 2018 06:01:38 +0000 |
4 | Subject: [PATCH] Makefile.am: update hooksdir for lease_cmds | 4 | Subject: [PATCH 3/3] Makefile.am: update hooksdir for lease_cmds |
5 | 5 | ||
6 | update hooksdir for lease_cmds | 6 | update hooksdir for lease_cmds |
7 | 7 | ||
8 | Upstream-Status: Pending | 8 | Upstream-Status: Pending |
9 | 9 | ||
10 | Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> | 10 | Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> |
11 | |||
11 | --- | 12 | --- |
12 | src/hooks/dhcp/lease_cmds/Makefile.am | 2 +- | 13 | src/hooks/dhcp/lease_cmds/Makefile.am | 2 +- |
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
@@ -26,5 +27,5 @@ index cfd6779..22cc4a9 100644 | |||
26 | 27 | ||
27 | libdhcp_lease_cmds_la_SOURCES = | 28 | libdhcp_lease_cmds_la_SOURCES = |
28 | -- | 29 | -- |
29 | 2.13.3 | 30 | 2.18.0 |
30 | 31 | ||
diff --git a/meta-networking/recipes-connectivity/kea/kea_1.3.0.bb b/meta-networking/recipes-connectivity/kea/kea_1.4.0.bb index 946c1e17dd..40db22bf02 100644 --- a/meta-networking/recipes-connectivity/kea/kea_1.3.0.bb +++ b/meta-networking/recipes-connectivity/kea/kea_1.4.0.bb | |||
@@ -2,31 +2,31 @@ SUMMARY = "ISC Kea DHCP Server" | |||
2 | DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS." | 2 | DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS." |
3 | HOMEPAGE = "http://kea.isc.org" | 3 | HOMEPAGE = "http://kea.isc.org" |
4 | SECTION = "connectivity" | 4 | SECTION = "connectivity" |
5 | LICENSE = "MPL-2.0 & BSL-1.0 & Apache-2.0" | 5 | LICENSE = "MPL-2.0 & Apache-2.0" |
6 | LIC_FILES_CHKSUM = "\ | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1666a9c4bb55adbc8939d85643096bd3" |
7 | file://COPYING;md5=9310b19bc010f85f4ad19637f168f23f \ | 7 | |
8 | file://ext/coroutine/LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \ | 8 | DEPENDS += "kea-native" |
9 | " | ||
10 | 9 | ||
11 | SRC_URI = "\ | 10 | SRC_URI = "\ |
12 | http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \ | 11 | http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \ |
13 | file://0001-Added-option-to-provide-kea-msg-compiler.patch \ | 12 | file://0003-Makefile.am-update-hooksdir-for-lease_cmds.patch \ |
14 | file://0001-Makefile.am-fix-compile-error-about-kea-msg-compiler.patch \ | ||
15 | file://0001-asiolink-fix-build-with-boost-1.66.patch \ | ||
16 | file://0001-Makefile.am-update-hooksdir-for-lease_cmds.patch \ | ||
17 | file://kea-dhcp4.service \ | 13 | file://kea-dhcp4.service \ |
18 | file://kea-dhcp6.service \ | 14 | file://kea-dhcp6.service \ |
19 | file://kea-dhcp-ddns.service \ | 15 | file://kea-dhcp-ddns.service \ |
20 | " | 16 | " |
21 | 17 | SRC_URI[md5sum] = "26eedd749101642757d788431605aaa5" | |
22 | SRC_URI[md5sum] = "f93bf836fd555a221f9ed0d4520058db" | 18 | SRC_URI[sha256sum] = "c0f8ecb93657adfc5ab970c91706754e601084828493f053f159661d21b31128" |
23 | SRC_URI[sha256sum] = "6edfcdbf2526c218426a1d1a6a6694a4050c97bb8412953a230285d63415c391" | ||
24 | 19 | ||
25 | inherit autotools systemd | 20 | inherit autotools systemd |
26 | 21 | ||
27 | SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" | 22 | SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" |
28 | SYSTEMD_AUTO_ENABLE = "disable" | 23 | SYSTEMD_AUTO_ENABLE = "disable" |
29 | 24 | ||
25 | do_configure_prepend_class-target() { | ||
26 | mkdir -p ${B}/src/lib/log/compiler/ | ||
27 | ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler | ||
28 | } | ||
29 | |||
30 | do_install_append_class-target() { | 30 | do_install_append_class-target() { |
31 | install -d ${D}${systemd_system_unitdir} | 31 | install -d ${D}${systemd_system_unitdir} |
32 | install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir} | 32 | install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir} |
@@ -39,14 +39,13 @@ do_install_append() { | |||
39 | rm -rf "${D}${localstatedir}" | 39 | rm -rf "${D}${localstatedir}" |
40 | } | 40 | } |
41 | 41 | ||
42 | PACKAGECONFIG_class-target ??= "kmc openssl log4cplus boost" | 42 | PACKAGECONFIG ??= "openssl log4cplus boost" |
43 | PACKAGECONFIG_class-native ??= "openssl log4cplus boost" | ||
44 | 43 | ||
45 | PACKAGECONFIG[kmc] = "--with-msg-compiler=${STAGING_BINDIR_NATIVE}/kea-msg-compiler,,kea-native," | ||
46 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl" | 44 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl" |
47 | PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus" | 45 | PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus" |
48 | PACKAGECONFIG[boost] = "--with-boost-include=${STAGING_INCDIR} --with-boost-lib-dir=${STAGING_LIBDIR} --with-boost-libs=-lboost_system,,boost,boost" | 46 | PACKAGECONFIG[boost] = "--with-boost-include=${STAGING_INCDIR} --with-boost-lib-dir=${STAGING_LIBDIR} --with-boost-libs=-lboost_system,,boost,boost" |
49 | 47 | ||
50 | FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a" | 48 | FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a" |
49 | FILES_${PN} += "${libdir}/hooks/*.so" | ||
51 | 50 | ||
52 | BBCLASSEXTEND += "native" | 51 | BBCLASSEXTEND += "native" |