diff options
-rw-r--r-- | meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch | 49 | ||||
-rw-r--r-- | meta-oe/recipes-security/audit/audit_4.0.2.bb (renamed from meta-oe/recipes-security/audit/audit_4.0.1.bb) | 4 |
2 files changed, 1 insertions, 52 deletions
diff --git a/meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch b/meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch deleted file mode 100644 index b1f324f22d..0000000000 --- a/meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 88c9b2c5cebebf13f90890baebbadc60d9fe8d16 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 9 Aug 2022 23:57:03 -0700 | ||
4 | Subject: [PATCH] Replace __attribute_malloc__ with __attribute__((__malloc__)) | ||
5 | |||
6 | __attribute_malloc__ is not available on musl | ||
7 | |||
8 | Fixes | ||
9 | | ../../git/auparse/auparse.h:54:2: error: expected function body after function declarator | ||
10 | | __attribute_malloc__ __attr_dealloc (auparse_destroy, 1); | ||
11 | | ^ | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | |||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | audisp/plugins/remote/queue.h | 2 +- | ||
18 | auparse/auparse.h | 2 +- | ||
19 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
20 | |||
21 | diff --git a/audisp/plugins/remote/queue.h b/audisp/plugins/remote/queue.h | ||
22 | index 36b70d04..031507dc 100644 | ||
23 | --- a/audisp/plugins/remote/queue.h | ||
24 | +++ b/audisp/plugins/remote/queue.h | ||
25 | @@ -53,7 +53,7 @@ void q_close(struct queue *q); | ||
26 | * On error, return NULL and set errno. */ | ||
27 | struct queue *q_open(int q_flags, const char *path, size_t num_entries, | ||
28 | size_t entry_size) | ||
29 | - __attribute_malloc__ __attr_dealloc (q_close, 1) __wur; | ||
30 | + __attribute__((__malloc__)) __attr_dealloc (q_close, 1) __wur; | ||
31 | |||
32 | /* Add DATA to tail of Q. Return 0 on success, -1 on error and set errno. */ | ||
33 | int q_append(struct queue *q, const char *data); | ||
34 | diff --git a/auparse/auparse.h b/auparse/auparse.h | ||
35 | index c27f1ff9..87c52965 100644 | ||
36 | --- a/auparse/auparse.h | ||
37 | +++ b/auparse/auparse.h | ||
38 | @@ -55,7 +55,7 @@ typedef void (*auparse_callback_ptr)(auparse_state_t *au, | ||
39 | void auparse_destroy(auparse_state_t *au); | ||
40 | void auparse_destroy_ext(auparse_state_t *au, auparse_destroy_what_t what); | ||
41 | auparse_state_t *auparse_init(ausource_t source, const void *b) | ||
42 | - __attribute_malloc__ __attr_dealloc (auparse_destroy, 1); | ||
43 | + __attribute__((__malloc__)) __attr_dealloc (auparse_destroy, 1); | ||
44 | int auparse_new_buffer(auparse_state_t *au, const char *data, size_t data_len) | ||
45 | __attr_access ((__read_only__, 2, 3)); | ||
46 | int auparse_feed(auparse_state_t *au, const char *data, size_t data_len) | ||
47 | -- | ||
48 | 2.25.1 | ||
49 | |||
diff --git a/meta-oe/recipes-security/audit/audit_4.0.1.bb b/meta-oe/recipes-security/audit/audit_4.0.2.bb index c189cfea55..d6742c9eb0 100644 --- a/meta-oe/recipes-security/audit/audit_4.0.1.bb +++ b/meta-oe/recipes-security/audit/audit_4.0.2.bb | |||
@@ -13,10 +13,8 @@ SRC_URI = "git://github.com/linux-audit/${BPN}-userspace.git;branch=master;proto | |||
13 | file://audit-volatile.conf \ | 13 | file://audit-volatile.conf \ |
14 | " | 14 | " |
15 | 15 | ||
16 | SRC_URI:append:libc-musl = " file://0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch" | ||
17 | |||
18 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
19 | SRCREV = "22ccbd984e493524050ac445f796e9a7e90e1149" | 17 | SRCREV = "4e6deae41d4646d28bb3ba9524a8a227a38ccd0b" |
20 | 18 | ||
21 | inherit autotools python3targetconfig update-rc.d systemd | 19 | inherit autotools python3targetconfig update-rc.d systemd |
22 | 20 | ||