diff options
3 files changed, 137 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm/0001-Fix-implicit-declaration-error.patch b/meta-networking/recipes-support/linux-atm/linux-atm/0001-Fix-implicit-declaration-error.patch new file mode 100644 index 0000000000..1c5f79c9d8 --- /dev/null +++ b/meta-networking/recipes-support/linux-atm/linux-atm/0001-Fix-implicit-declaration-error.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From 1435d613ee632bd7a2aa15180acf06ff3723da41 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <martin.jansa@gmail.com> | ||
3 | Date: Sat, 26 Apr 2025 13:03:35 +0200 | ||
4 | Subject: [PATCH] Fix implicit-declaration error | ||
5 | |||
6 | * taken from: | ||
7 | https://github.com/sbwml/package_network_utils_linux-atm/blob/main/patches/900-fix-implicit-declaration-error.patch | ||
8 | |||
9 | * fixes: | ||
10 | http://errors.yoctoproject.org/Errors/Details/766901/ | ||
11 | linux-atm-2.5.2/src/led/conn.c:414:57: error: passing argument 3 of 'accept' from incompatible pointer type [-Wincompatible-pointer-types] | ||
12 | |||
13 | Upstream-Status: Inappropriate [Upstream is dead] | ||
14 | Signed-off-by: Martin Jansa <martin.jansa@gmail.com> | ||
15 | --- | ||
16 | src/led/conn.c | 2 +- | ||
17 | src/maint/hediag.c | 1 + | ||
18 | 2 files changed, 2 insertions(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/src/led/conn.c b/src/led/conn.c | ||
21 | index 99da5e4..89639e1 100644 | ||
22 | --- a/src/led/conn.c | ||
23 | +++ b/src/led/conn.c | ||
24 | @@ -405,7 +405,7 @@ Conn_t *accept_conn(Conn_t *conn) | ||
25 | { | ||
26 | Conn_t *new; | ||
27 | struct sockaddr_atmsvc addr; | ||
28 | - size_t len; | ||
29 | + socklen_t len; | ||
30 | int fd; | ||
31 | char buff[MAX_ATM_ADDR_LEN+1]; | ||
32 | |||
33 | diff --git a/src/maint/hediag.c b/src/maint/hediag.c | ||
34 | index a4f792f..3b1b7fb 100644 | ||
35 | --- a/src/maint/hediag.c | ||
36 | +++ b/src/maint/hediag.c | ||
37 | @@ -9,6 +9,7 @@ | ||
38 | #include <linux/atmdev.h> | ||
39 | #include <linux/sonet.h> | ||
40 | #include <linux/atm_he.h> | ||
41 | +#include <string.h> | ||
42 | |||
43 | struct reg_table { | ||
44 | unsigned addr; | ||
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm/0002-Fix-build-with-gcc-15.patch b/meta-networking/recipes-support/linux-atm/linux-atm/0002-Fix-build-with-gcc-15.patch new file mode 100644 index 0000000000..1cbd6a5831 --- /dev/null +++ b/meta-networking/recipes-support/linux-atm/linux-atm/0002-Fix-build-with-gcc-15.patch | |||
@@ -0,0 +1,91 @@ | |||
1 | From 2a9d42b2b190d533cf126a93bcad842cea825bbe Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <martin.jansa@gmail.com> | ||
3 | Date: Sat, 26 Apr 2025 13:04:56 +0200 | ||
4 | Subject: [PATCH] Fix build with gcc-15 | ||
5 | |||
6 | * taken from: | ||
7 | https://github.com/sbwml/package_network_utils_linux-atm/blob/1d1c3f884daf9ee4bce077f3db9d990617683669/patches/901-linux-atm-dont-use-bool-keyword.patch | ||
8 | |||
9 | * fixes: | ||
10 | http://errors.yoctoproject.org/Errors/Details/852979/ | ||
11 | |||
12 | In file included from load_lex.l:11: | ||
13 | ../../../linux-atm-2.5.2/src/lane/load_lex.h:27:10: error: two or more data types in declaration specifiers | ||
14 | 27 | Bool_t bool; | ||
15 | | ^~~~ | ||
16 | ../../../linux-atm-2.5.2/src/lane/load_lex.h:27:14: warning: declaration does not declare anything | ||
17 | 27 | Bool_t bool; | ||
18 | | ^ | ||
19 | In file included from ../../../linux-atm-2.5.2/src/lane/load.c:29: | ||
20 | ../../../linux-atm-2.5.2/src/lane/load_lex.h:27:10: error: two or more data types in declaration specifiers | ||
21 | 27 | Bool_t bool; | ||
22 | | ^~~~ | ||
23 | ../../../linux-atm-2.5.2/src/lane/load_lex.h:27:14: warning: declaration does not declare anything | ||
24 | 27 | Bool_t bool; | ||
25 | | ^ | ||
26 | load_lex.l: In function 'yylex': | ||
27 | load_lex.l:47:11: error: expected identifier before 'bool' | ||
28 | load_lex.l:51:11: error: expected identifier before 'bool' | ||
29 | ../../../linux-atm-2.5.2/src/lane/load.c: In function 'load_vars': | ||
30 | ../../../linux-atm-2.5.2/src/lane/load.c:501:29: error: expected identifier before 'bool' | ||
31 | 501 | g_return.bool==BL_TRUE?"True":"False"); | ||
32 | | ^~~~ | ||
33 | ../../../linux-atm-2.5.2/src/lane/load.c:502:51: error: expected identifier before 'bool' | ||
34 | 502 | set_var_bool(curr_unit, varname, g_return.bool); | ||
35 | | ^~~~ | ||
36 | make[3]: *** [Makefile:513: load.o] Error 1 | ||
37 | |||
38 | Upstream-Status: Inappropriate [Upstream is dead] | ||
39 | Signed-off-by: Martin Jansa <martin.jansa@gmail.com> | ||
40 | --- | ||
41 | src/lane/load.c | 4 ++-- | ||
42 | src/lane/load_lex.h | 2 +- | ||
43 | src/lane/load_lex.l | 4 ++-- | ||
44 | 3 files changed, 5 insertions(+), 5 deletions(-) | ||
45 | |||
46 | diff --git a/src/lane/load.c b/src/lane/load.c | ||
47 | index 39d4672..1cc2202 100644 | ||
48 | --- a/src/lane/load.c | ||
49 | +++ b/src/lane/load.c | ||
50 | @@ -498,8 +498,8 @@ load_vars(const char *file) | ||
51 | break; | ||
52 | case BOOLEAN: | ||
53 | Debug_unit(&load_unit, "Variable is boolean: %s", | ||
54 | - g_return.bool==BL_TRUE?"True":"False"); | ||
55 | - set_var_bool(curr_unit, varname, g_return.bool); | ||
56 | + g_return.b==BL_TRUE?"True":"False"); | ||
57 | + set_var_bool(curr_unit, varname, g_return.b); | ||
58 | break; | ||
59 | case INTEGER: | ||
60 | Debug_unit(&load_unit, "Variable is integer: %d", g_return.intti); | ||
61 | diff --git a/src/lane/load_lex.h b/src/lane/load_lex.h | ||
62 | index 2384e70..72b8f9b 100644 | ||
63 | --- a/src/lane/load_lex.h | ||
64 | +++ b/src/lane/load_lex.h | ||
65 | @@ -24,7 +24,7 @@ | ||
66 | #define END 0 | ||
67 | |||
68 | typedef struct { | ||
69 | - Bool_t bool; | ||
70 | + Bool_t b; | ||
71 | int intti; | ||
72 | AtmAddr_t *atmaddress; | ||
73 | LaneDestination_t *destaddr; | ||
74 | diff --git a/src/lane/load_lex.l b/src/lane/load_lex.l | ||
75 | index c184795..1d412e3 100644 | ||
76 | --- a/src/lane/load_lex.l | ||
77 | +++ b/src/lane/load_lex.l | ||
78 | @@ -44,11 +44,11 @@ H [0-9a-fA-F] | ||
79 | return ATMADDRESS; | ||
80 | } | ||
81 | True | | ||
82 | -true {g_return.bool = BL_TRUE; | ||
83 | +true {g_return.b = BL_TRUE; | ||
84 | return BOOLEAN; | ||
85 | } | ||
86 | False | | ||
87 | -false {g_return.bool = BL_FALSE; | ||
88 | +false {g_return.b = BL_FALSE; | ||
89 | return BOOLEAN; | ||
90 | } | ||
91 | \#.* {} | ||
diff --git a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb index 391e0e4ab6..3d679d7dc7 100644 --- a/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb +++ b/meta-networking/recipes-support/linux-atm/linux-atm_2.5.2.bb | |||
@@ -16,6 +16,8 @@ SRC_URI = "http://nchc.dl.sourceforge.net/project/${BPN}/${BPN}/${PV}/${BPN}-${P | |||
16 | file://0001-make-Add-PREFIX-knob.patch \ | 16 | file://0001-make-Add-PREFIX-knob.patch \ |
17 | file://0001-include-string-h-from-memcpy-and-strcpy-function-pro.patch \ | 17 | file://0001-include-string-h-from-memcpy-and-strcpy-function-pro.patch \ |
18 | file://0001-configure-Check-for-symbol-from-libresolv-instead-of.patch \ | 18 | file://0001-configure-Check-for-symbol-from-libresolv-instead-of.patch \ |
19 | file://0001-Fix-implicit-declaration-error.patch \ | ||
20 | file://0002-Fix-build-with-gcc-15.patch \ | ||
19 | " | 21 | " |
20 | 22 | ||
21 | SRC_URI:append:libc-musl = " file://musl-no-on_exit.patch" | 23 | SRC_URI:append:libc-musl = " file://musl-no-on_exit.patch" |
@@ -32,7 +34,3 @@ inherit autotools pkgconfig | |||
32 | EXTRA_OEMAKE += "ROOTPREFIX=${root_prefix}" | 34 | EXTRA_OEMAKE += "ROOTPREFIX=${root_prefix}" |
33 | 35 | ||
34 | FILES:${PN} += "${nonarch_base_libdir}/firmware" | 36 | FILES:${PN} += "${nonarch_base_libdir}/firmware" |
35 | |||
36 | # http://errors.yoctoproject.org/Errors/Details/766901/ | ||
37 | # linux-atm-2.5.2/src/led/conn.c:414:57: error: passing argument 3 of 'accept' from incompatible pointer type [-Wincompatible-pointer-types] | ||
38 | CFLAGS += "-Wno-error=incompatible-pointer-types" | ||