diff options
3 files changed, 108 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace/0001-Use-correct-enum-type.patch b/meta-oe/recipes-devtools/ltrace/ltrace/0001-Use-correct-enum-type.patch new file mode 100644 index 0000000000..01a35842c8 --- /dev/null +++ b/meta-oe/recipes-devtools/ltrace/ltrace/0001-Use-correct-enum-type.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From df490528d1e81a98ba2991c700c92a8e6c969083 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 6 Mar 2017 21:32:22 -0800 | ||
4 | Subject: [PATCH 1/2] Use correct enum type | ||
5 | |||
6 | Clang warns about wrong enum initializtion | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | sysdeps/linux-gnu/aarch64/fetch.c | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/sysdeps/linux-gnu/aarch64/fetch.c b/sysdeps/linux-gnu/aarch64/fetch.c | ||
14 | index 2744df0..1dcf7cc 100644 | ||
15 | --- a/sysdeps/linux-gnu/aarch64/fetch.c | ||
16 | +++ b/sysdeps/linux-gnu/aarch64/fetch.c | ||
17 | @@ -173,7 +173,7 @@ static struct fetch_script | ||
18 | pass_arg(struct fetch_context const *context, | ||
19 | struct process *proc, struct arg_type_info *info) | ||
20 | { | ||
21 | - enum fetch_method cvt = CVT_NOP; | ||
22 | + enum convert_method cvt = CVT_NOP; | ||
23 | |||
24 | size_t sz = type_sizeof(proc, info); | ||
25 | if (sz == (size_t) -1) | ||
26 | -- | ||
27 | 2.12.0 | ||
28 | |||
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace/0002-Fix-const-qualifier-error.patch b/meta-oe/recipes-devtools/ltrace/ltrace/0002-Fix-const-qualifier-error.patch new file mode 100644 index 0000000000..c152771923 --- /dev/null +++ b/meta-oe/recipes-devtools/ltrace/ltrace/0002-Fix-const-qualifier-error.patch | |||
@@ -0,0 +1,76 @@ | |||
1 | From 4d3ec1a514f9b1df8ce3a1b04c8a2823d977377f Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 6 Mar 2017 21:34:01 -0800 | ||
4 | Subject: [PATCH 2/2] Fix const qualifier error | ||
5 | |||
6 | Fixes clang warning | ||
7 | error: duplicate 'const' declaration specifier [-Werror,-Wduplicate-decl-specifier] | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | dict.h | 2 +- | ||
12 | library.c | 2 +- | ||
13 | vect.h | 2 +- | ||
14 | 3 files changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | Index: git/dict.h | ||
17 | =================================================================== | ||
18 | --- git.orig/dict.h | ||
19 | +++ git/dict.h | ||
20 | @@ -90,7 +90,7 @@ int dict_clone(struct dict *target, cons | ||
21 | assert(_source_d->values.elt_size == sizeof(VALUE_TYPE)); \ | ||
22 | /* Check that callbacks are typed properly. */ \ | ||
23 | void (*_key_dtor_cb)(KEY_TYPE *, void *) = DTOR_KEY; \ | ||
24 | - int (*_key_clone_cb)(KEY_TYPE *, const KEY_TYPE *, \ | ||
25 | + int (*_key_clone_cb)(KEY_TYPE *, KEY_TYPE *, \ | ||
26 | void *) = CLONE_KEY; \ | ||
27 | void (*_value_dtor_cb)(VALUE_TYPE *, void *) = DTOR_VALUE; \ | ||
28 | int (*_value_clone_cb)(VALUE_TYPE *, const VALUE_TYPE *, \ | ||
29 | Index: git/library.c | ||
30 | =================================================================== | ||
31 | --- git.orig/library.c | ||
32 | +++ git/library.c | ||
33 | @@ -353,7 +353,7 @@ static void | ||
34 | library_exported_names_init(struct library_exported_names *names) | ||
35 | { | ||
36 | DICT_INIT(&names->names, | ||
37 | - const char*, uint64_t, | ||
38 | + char*, uint64_t, | ||
39 | dict_hash_string, dict_eq_string, NULL); | ||
40 | DICT_INIT(&names->addrs, | ||
41 | uint64_t, struct vect*, | ||
42 | Index: git/vect.h | ||
43 | =================================================================== | ||
44 | --- git.orig/vect.h | ||
45 | +++ git/vect.h | ||
46 | @@ -66,7 +66,7 @@ int vect_clone(struct vect *target, cons | ||
47 | assert(_source_vec->elt_size == sizeof(ELT_TYPE)); \ | ||
48 | /* Check that callbacks are typed properly. */ \ | ||
49 | void (*_dtor_callback)(ELT_TYPE *, void *) = DTOR; \ | ||
50 | - int (*_clone_callback)(ELT_TYPE *, const ELT_TYPE *, \ | ||
51 | + int (*_clone_callback)(ELT_TYPE *, ELT_TYPE *, \ | ||
52 | void *) = CLONE; \ | ||
53 | vect_clone((TGT_VEC), _source_vec, \ | ||
54 | (int (*)(void *, const void *, \ | ||
55 | Index: git/value_dict.c | ||
56 | =================================================================== | ||
57 | --- git.orig/value_dict.c | ||
58 | +++ git/value_dict.c | ||
59 | @@ -40,7 +40,7 @@ val_dict_init(struct value_dict *dict) | ||
60 | } | ||
61 | |||
62 | static int | ||
63 | -value_clone_cb(struct value *tgt, const struct value *src, void *data) | ||
64 | +value_clone_cb(struct value *tgt, struct value *src, void *data) | ||
65 | { | ||
66 | return value_clone(tgt, src); | ||
67 | } | ||
68 | @@ -53,7 +53,7 @@ value_dtor(struct value *val, void *data | ||
69 | |||
70 | static int | ||
71 | named_value_clone(struct named_value *tgt, | ||
72 | - const struct named_value *src, void *data) | ||
73 | + struct named_value *src, void *data) | ||
74 | { | ||
75 | tgt->name = strdup(src->name); | ||
76 | if (tgt->name == NULL) | ||
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb index 8f4e5b1e6e..a5960f5b0c 100644 --- a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb +++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb | |||
@@ -10,14 +10,16 @@ LICENSE = "GPLv2" | |||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
11 | 11 | ||
12 | PE = "1" | 12 | PE = "1" |
13 | PV = "7.3+git${SRCPV}" | 13 | PV = "7.91+git${SRCPV}" |
14 | SRCREV = "01b10e191e99d8cb147e5a2b7da8196e0ec6fb94" | 14 | SRCREV = "c22d359433b333937ee3d803450dc41998115685" |
15 | 15 | ||
16 | DEPENDS = "elfutils" | 16 | DEPENDS = "elfutils" |
17 | RDEPENDS_${PN} = "elfutils" | 17 | RDEPENDS_${PN} = "elfutils" |
18 | SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=master \ | 18 | SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=master \ |
19 | file://configure-allow-to-disable-selinux-support.patch \ | 19 | file://configure-allow-to-disable-selinux-support.patch \ |
20 | file://0001-replace-readdir_r-with-readdir.patch \ | 20 | file://0001-replace-readdir_r-with-readdir.patch \ |
21 | file://0001-Use-correct-enum-type.patch \ | ||
22 | file://0002-Fix-const-qualifier-error.patch \ | ||
21 | " | 23 | " |
22 | S = "${WORKDIR}/git" | 24 | S = "${WORKDIR}/git" |
23 | 25 | ||