diff options
-rw-r--r-- | meta-oe/recipes-kernel/libtracefs/libtracefs/0001-makefile-Do-not-preserve-ownership-in-cp-command.patch | 9 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/libtracefs/libtracefs/0001-tracefs-perf-Add-missing-headers-for-syscall-and-SYS.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/libtracefs/libtracefs_1.8.0.bb (renamed from meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb) | 3 |
3 files changed, 4 insertions, 39 deletions
diff --git a/meta-oe/recipes-kernel/libtracefs/libtracefs/0001-makefile-Do-not-preserve-ownership-in-cp-command.patch b/meta-oe/recipes-kernel/libtracefs/libtracefs/0001-makefile-Do-not-preserve-ownership-in-cp-command.patch index 7ae0856f85..7eaf29e4c4 100644 --- a/meta-oe/recipes-kernel/libtracefs/libtracefs/0001-makefile-Do-not-preserve-ownership-in-cp-command.patch +++ b/meta-oe/recipes-kernel/libtracefs/libtracefs/0001-makefile-Do-not-preserve-ownership-in-cp-command.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 6650d0e79eea330b53635574885208a138fef97e Mon Sep 17 00:00:00 2001 | 1 | From ab6f78bfd6811c648ee71663cfc4dc8be151a519 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 21 Dec 2022 22:50:56 -0800 | 3 | Date: Wed, 21 Dec 2022 22:50:56 -0800 |
4 | Subject: [PATCH] makefile: Do not preserve ownership in cp command | 4 | Subject: [PATCH] makefile: Do not preserve ownership in cp command |
@@ -14,10 +14,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/Makefile b/Makefile | 16 | diff --git a/Makefile b/Makefile |
17 | index 27d425c..3aea142 100644 | 17 | index 7f4f5c3..1ba7b9d 100644 |
18 | --- a/Makefile | 18 | --- a/Makefile |
19 | +++ b/Makefile | 19 | +++ b/Makefile |
20 | @@ -273,7 +273,7 @@ endif # DESTDIR = "" | 20 | @@ -296,7 +296,7 @@ endif # DESTDIR = "" |
21 | 21 | ||
22 | install_libs: libs install_pkgconfig | 22 | install_libs: libs install_pkgconfig |
23 | $(Q)$(call do_install,$(LIBTRACEFS_SHARED),$(libdir_SQ)); \ | 23 | $(Q)$(call do_install,$(LIBTRACEFS_SHARED),$(libdir_SQ)); \ |
@@ -26,6 +26,3 @@ index 27d425c..3aea142 100644 | |||
26 | $(Q)$(call do_install,$(src)/include/tracefs.h,$(includedir_SQ),644) | 26 | $(Q)$(call do_install,$(src)/include/tracefs.h,$(includedir_SQ),644) |
27 | $(Q)$(call install_ld_config) | 27 | $(Q)$(call install_ld_config) |
28 | 28 | ||
29 | -- | ||
30 | 2.39.0 | ||
31 | |||
diff --git a/meta-oe/recipes-kernel/libtracefs/libtracefs/0001-tracefs-perf-Add-missing-headers-for-syscall-and-SYS.patch b/meta-oe/recipes-kernel/libtracefs/libtracefs/0001-tracefs-perf-Add-missing-headers-for-syscall-and-SYS.patch deleted file mode 100644 index a24dd1315b..0000000000 --- a/meta-oe/recipes-kernel/libtracefs/libtracefs/0001-tracefs-perf-Add-missing-headers-for-syscall-and-SYS.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From f539d96ef4a34ad23d33c552d1770ab429b0220e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 14 Jun 2023 00:24:36 -0700 | ||
4 | Subject: [PATCH] tracefs-perf: Add missing headers for syscall() and SYS_* | ||
5 | defines | ||
6 | |||
7 | These headers are needed to provide prototype definitions for functions | ||
8 | e.g. close(), syscall(), getpagesize(), getpid() | ||
9 | |||
10 | The issue is observed with clang-16+ compiler on musl systems | ||
11 | |||
12 | Upstream-Status: Submitted [https://lore.kernel.org/linux-trace-devel/20230614072759.316154-1-raj.khem@gmail.com/T/#u] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | src/tracefs-perf.c | 3 ++- | ||
16 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/src/tracefs-perf.c b/src/tracefs-perf.c | ||
19 | index 96d12cd..62c1508 100644 | ||
20 | --- a/src/tracefs-perf.c | ||
21 | +++ b/src/tracefs-perf.c | ||
22 | @@ -1,4 +1,5 @@ | ||
23 | -#include <asm/unistd.h> | ||
24 | +#include <unistd.h> | ||
25 | +#include <sys/syscall.h> | ||
26 | #include <sys/mman.h> | ||
27 | #include <signal.h> | ||
28 | #include <linux/perf_event.h> | ||
29 | -- | ||
30 | 2.41.0 | ||
31 | |||
diff --git a/meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb b/meta-oe/recipes-kernel/libtracefs/libtracefs_1.8.0.bb index 9a408ba13c..c90ac19fa7 100644 --- a/meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb +++ b/meta-oe/recipes-kernel/libtracefs/libtracefs_1.8.0.bb | |||
@@ -9,10 +9,9 @@ LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 | |||
9 | SECTION = "libs" | 9 | SECTION = "libs" |
10 | DEPENDS = "libtraceevent bison-native flex-native" | 10 | DEPENDS = "libtraceevent bison-native flex-native" |
11 | 11 | ||
12 | SRCREV = "aebab37379d0fbadc702d64aca0fe5cf18676404" | 12 | SRCREV = "67f3b2ab9f836e6c9c70c94db7aac3251119a263" |
13 | SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git;branch=${BPN};protocol=https \ | 13 | SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git;branch=${BPN};protocol=https \ |
14 | file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch \ | 14 | file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch \ |
15 | file://0001-tracefs-perf-Add-missing-headers-for-syscall-and-SYS.patch \ | ||
16 | " | 15 | " |
17 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
18 | 17 | ||