diff options
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/0001-ppc-Fix-signature-for-co_create-API.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb | 1 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-ppc-Fix-signature-for-co_create-API.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-ppc-Fix-signature-for-co_create-API.patch new file mode 100644 index 0000000000..1f36c657ed --- /dev/null +++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-ppc-Fix-signature-for-co_create-API.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From be4032079c931704f52e29f5da5c01cde24ac842 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 16 Jan 2020 10:44:58 -0800 | ||
4 | Subject: [PATCH] ppc: Fix signature for co_create API | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/fluent/fluent-bit/pull/1886] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | lib/flb_libco/ppc.c | 6 ++++-- | ||
10 | 1 file changed, 4 insertions(+), 2 deletions(-) | ||
11 | |||
12 | diff --git a/lib/flb_libco/ppc.c b/lib/flb_libco/ppc.c | ||
13 | index e6536d56..533256b3 100644 | ||
14 | --- a/lib/flb_libco/ppc.c | ||
15 | +++ b/lib/flb_libco/ppc.c | ||
16 | @@ -279,7 +279,9 @@ static uint32_t* co_create_(unsigned size, uintptr_t entry) { | ||
17 | return t; | ||
18 | } | ||
19 | |||
20 | -cothread_t co_create(unsigned int size, void (*entry_)(void)) { | ||
21 | +cothread_t co_create(unsigned int size, void (*entry_)(void), | ||
22 | + size_t *out_size) { | ||
23 | + | ||
24 | uintptr_t entry = (uintptr_t)entry_; | ||
25 | uint32_t* t = 0; | ||
26 | |||
27 | @@ -325,7 +327,7 @@ cothread_t co_create(unsigned int size, void (*entry_)(void)) { | ||
28 | t[10] = (uint32_t)(sp >> shift >> shift); | ||
29 | t[11] = (uint32_t)sp; | ||
30 | } | ||
31 | - | ||
32 | + *out_size = size; | ||
33 | return t; | ||
34 | } | ||
35 | |||
36 | -- | ||
37 | 2.25.0 | ||
38 | |||
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb index aad1499b94..d8cb8b5e85 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb +++ b/meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb | |||
@@ -15,6 +15,7 @@ SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \ | |||
15 | file://jemalloc.patch \ | 15 | file://jemalloc.patch \ |
16 | file://cross-build-init-system-detection.patch \ | 16 | file://cross-build-init-system-detection.patch \ |
17 | file://builtin-nan.patch \ | 17 | file://builtin-nan.patch \ |
18 | file://0001-ppc-Fix-signature-for-co_create-API.patch \ | ||
18 | " | 19 | " |
19 | SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747" | 20 | SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747" |
20 | SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789" | 21 | SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789" |