summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb')
-rw-r--r--meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb
new file mode 100644
index 0000000000..cc3f2ee1dd
--- /dev/null
+++ b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Network scanning and manipulation tool"
2DESCRIPTION = "Scapy is a powerful interactive packet manipulation program. \
3It is able to forge or decode packets of a wide number of protocols, send \
4them on the wire, capture them, match requests and replies, and much more. \
5It can easily handle most classical tasks like scanning, tracerouting, probing, \
6unit tests, attacks or network discovery (it can replace hping, 85% of nmap, \
7arpspoof, arp-sk, arping, tcpdump, tethereal, p0f, etc.). It also performs very \
8well at a lot of other specific tasks that most other tools can't handle, like \
9sending invalid frames, injecting your own 802.11 frames, combining technics \
10(VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted channel, ...), etc."
11SECTION = "security"
12LICENSE = "GPL-2.0-only"
13
14LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
15
16# If you want ptest support, use the git repo
17# UTscapy does not exist in the pypi pkg
18#
19SRCREV = "9473f77d8b548c8e478e52838bdd4c12f5d4f4ff"
20SRC_URI = "git://github.com/secdev/scapy.git;branch=master;protocol=https \
21 file://run-ptest"
22
23S = "${WORKDIR}/git"
24
25UPSTREAM_CHECK_COMMITS = "1"
26
27inherit setuptools3 ptest
28
29do_install:append() {
30 mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
31}
32
33do_install_ptest() {
34 install -m 0644 ${S}/scapy/tools/UTscapy.py ${D}${PTEST_PATH}
35 install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH}
36 sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest
37}
38
39RDEPENDS:${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \
41 ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-fcntl"