diff options
Diffstat (limited to 'meta-networking/recipes-devtools/python')
-rw-r--r-- | meta-networking/recipes-devtools/python/python3-scapy/run-ptest | 2 | ||||
-rw-r--r-- | meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb (renamed from meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb) | 6 |
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-scapy/run-ptest b/meta-networking/recipes-devtools/python/python3-scapy/run-ptest index 797d8ecf78..417e21053c 100644 --- a/meta-networking/recipes-devtools/python/python3-scapy/run-ptest +++ b/meta-networking/recipes-devtools/python/python3-scapy/run-ptest | |||
@@ -1,4 +1,4 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | UTscapy3 -t regression.uts -f text -l -C \ | 2 | python3 UTscapy.py -t regression.uts -f text -l -C \ |
3 | -o @PTEST_PATH@/scapy_ptest_$(date +%Y%m%d-%H%M%S).log \ | 3 | -o @PTEST_PATH@/scapy_ptest_$(date +%Y%m%d-%H%M%S).log \ |
4 | 2>&1 | sed -e 's/^passed None/PASS:/' -e 's/^failed None/FAIL:/' | 4 | 2>&1 | sed -e 's/^passed None/PASS:/' -e 's/^failed None/FAIL:/' |
diff --git a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb index 0f66dfd784..cc3f2ee1dd 100644 --- a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb +++ b/meta-networking/recipes-devtools/python/python3-scapy_2.5.0.bb | |||
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
16 | # If you want ptest support, use the git repo | 16 | # If you want ptest support, use the git repo |
17 | # UTscapy does not exist in the pypi pkg | 17 | # UTscapy does not exist in the pypi pkg |
18 | # | 18 | # |
19 | SRCREV = "32cd7eb0f620d9adf171c48d55514e8326a538d7" | 19 | SRCREV = "9473f77d8b548c8e478e52838bdd4c12f5d4f4ff" |
20 | SRC_URI = "git://github.com/secdev/scapy.git;branch=master;protocol=https \ | 20 | SRC_URI = "git://github.com/secdev/scapy.git;branch=master;protocol=https \ |
21 | file://run-ptest" | 21 | file://run-ptest" |
22 | 22 | ||
@@ -28,14 +28,14 @@ inherit setuptools3 ptest | |||
28 | 28 | ||
29 | do_install:append() { | 29 | do_install:append() { |
30 | mv ${D}${bindir}/scapy ${D}${bindir}/scapy3 | 30 | mv ${D}${bindir}/scapy ${D}${bindir}/scapy3 |
31 | mv ${D}${bindir}/UTscapy ${D}${bindir}/UTscapy3 | ||
32 | } | 31 | } |
33 | 32 | ||
34 | do_install_ptest() { | 33 | do_install_ptest() { |
34 | install -m 0644 ${S}/scapy/tools/UTscapy.py ${D}${PTEST_PATH} | ||
35 | install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH} | 35 | install -m 0644 ${S}/test/regression.uts ${D}${PTEST_PATH} |
36 | sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest | 36 | sed -i 's,@PTEST_PATH@,${PTEST_PATH},' ${D}${PTEST_PATH}/run-ptest |
37 | } | 37 | } |
38 | 38 | ||
39 | RDEPENDS:${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \ | 39 | RDEPENDS:${PN} = "tcpdump ${PYTHON_PN}-compression ${PYTHON_PN}-cryptography ${PYTHON_PN}-netclient \ |
40 | ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \ | 40 | ${PYTHON_PN}-netserver ${PYTHON_PN}-pydoc ${PYTHON_PN}-pkgutil ${PYTHON_PN}-shell \ |
41 | ${PYTHON_PN}-threading ${PYTHON_PN}-numbers" | 41 | ${PYTHON_PN}-threading ${PYTHON_PN}-numbers ${PYTHON_PN}-fcntl" |