summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools/files/always-use-libdevmapper.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/files/always-use-libdevmapper.patch')
-rw-r--r--meta-oe/recipes-support/multipath-tools/files/always-use-libdevmapper.patch57
1 files changed, 0 insertions, 57 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/files/always-use-libdevmapper.patch b/meta-oe/recipes-support/multipath-tools/files/always-use-libdevmapper.patch
deleted file mode 100644
index 33834f6b80..0000000000
--- a/meta-oe/recipes-support/multipath-tools/files/always-use-libdevmapper.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1From c4f0dba4e86bfa20252fcc8218398e7468ca9149 Mon Sep 17 00:00:00 2001
2From: Aws Ismail <aws.ismail@windriver.com>
3Date: Mon, 22 Sep 2014 17:22:32 -0700
4Subject: [PATCH] Always use devmapper
5
6Do not try to compute several _API_ make variables
7from host information when cross-compiling.
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
12Signed-off-by: Joe Slater <joe.slater@windriver.com>
13---
14 libmultipath/Makefile | 27 ++++-----------------------
15 1 file changed, 4 insertions(+), 23 deletions(-)
16
17diff --git a/libmultipath/Makefile b/libmultipath/Makefile
18index 495cebe..9626e69 100644
19--- a/libmultipath/Makefile
20+++ b/libmultipath/Makefile
21@@ -20,29 +20,10 @@ ifdef SYSTEMD
22 endif
23 endif
24
25-LIBDM_API_FLUSH = $(shell grep -Ecs '^[a-z]*[[:space:]]+dm_task_no_flush' /usr/include/libdevmapper.h)
26-
27-ifneq ($(strip $(LIBDM_API_FLUSH)),0)
28- CFLAGS += -DLIBDM_API_FLUSH -D_GNU_SOURCE
29-endif
30-
31-LIBDM_API_COOKIE = $(shell grep -Ecs '^[a-z]*[[:space:]]+dm_task_set_cookie' /usr/include/libdevmapper.h)
32-
33-ifneq ($(strip $(LIBDM_API_COOKIE)),0)
34- CFLAGS += -DLIBDM_API_COOKIE
35-endif
36-
37-LIBUDEV_API_RECVBUF = $(shell grep -Ecs '^[a-z]*[[:space:]]+udev_monitor_set_receive_buffer_size' /usr/include/libudev.h)
38-
39-ifneq ($(strip $(LIBUDEV_API_RECVBUF)),0)
40- CFLAGS += -DLIBUDEV_API_RECVBUF
41-endif
42-
43-LIBDM_API_DEFERRED = $(shell grep -Ecs '^[a-z]*[[:space:]]+dm_task_deferred_remove' /usr/include/libdevmapper.h)
44-
45-ifneq ($(strip $(LIBDM_API_DEFERRED)),0)
46- CFLAGS += -DLIBDM_API_DEFERRED
47-endif
48+CFLAGS += -DLIBDM_API_FLUSH -D_GNU_SOURCE
49+CFLAGS += -DLIBDM_API_COOKIE
50+CFLAGS += -DLIBUDEV_API_RECVBUF
51+CFLAGS += -DLIBDM_API_DEFERRED
52
53 OBJS = memory.o parser.o vector.o devmapper.o callout.o \
54 hwtable.o blacklist.o util.o dmparser.o config.o \
55--
562.11.0
57