summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch')
-rw-r--r--meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch19
1 files changed, 0 insertions, 19 deletions
diff --git a/meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch b/meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch
deleted file mode 100644
index 271c5323fd..0000000000
--- a/meta-oe/recipes-support/openipmi/files/makefile-add-ldflags.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1Add LDFLAGS variable to Makefile.am, make sure the extra linker flags can be passed.
2
3Upstream-Status: Pending
4
5Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
6
7diff --git a/swig/perl/Makefile.am b/swig/perl/Makefile.am
8index 2f9ee4c..3a18892 100644
9--- a/swig/perl/Makefile.am
10+++ b/swig/perl/Makefile.am
11@@ -20,7 +20,7 @@ OpenIPMI_SRC = OpenIPMI_perl.c
12 OpenIPMI_OBJ = OpenIPMI_wrap.lo OpenIPMI_perl.lo
13
14 OpenIPMI.so: $(OpenIPMI_OBJ)
15- $(LIBTOOL) --mode=link $(CC) -shared -module -avoid-version -o $(@:.so=.la) $^ $(OPENIPMI_SWIG_LIBS) $(PERL_POSIX_LIB) -rpath $(PERL_INSTALL_DIR)/auto/OpenIPMI
16+ $(LIBTOOL) --mode=link $(CC) -shared -module -avoid-version $(LDFLAGS) -o $(@:.so=.la) $^ $(OPENIPMI_SWIG_LIBS) $(PERL_POSIX_LIB) -rpath $(PERL_INSTALL_DIR)/auto/OpenIPMI
17 rm -f OpenIPMI.so
18 mv .libs/OpenIPMI.so .
19