summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch')
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch44
1 files changed, 23 insertions, 21 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
index 553f4a5171..4ad0afa954 100644
--- a/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
+++ b/meta-oe/recipes-support/syslog-ng/files/fix-config-libnet.patch
@@ -6,25 +6,28 @@ This would avoid a implicit auto-detecting result.
6 6
7Signed-off-by: Ming Liu <ming.liu@windriver.com> 7Signed-off-by: Ming Liu <ming.liu@windriver.com>
8Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 8Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
9
10Update for 3.24.1.
11Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
9--- 12---
10 configure.ac | 27 +++++++++++++++++---------- 13 configure.ac | 28 ++++++++++++++++------------
11 1 files changed, 17 insertions(+), 10 deletions(-) 14 1 file changed, 16 insertions(+), 12 deletions(-)
12 15
13Index: syslog-ng-3.8.1/configure.ac 16diff --git a/configure.ac b/configure.ac
14=================================================================== 17index 00eb566..e7d5ac1 100644
15--- syslog-ng-3.8.1.orig/configure.ac 18--- a/configure.ac
16+++ syslog-ng-3.8.1/configure.ac 19+++ b/configure.ac
17@@ -104,6 +104,9 @@ AC_CONFIG_HEADERS(config.h) 20@@ -143,6 +143,9 @@ AC_CONFIG_HEADERS(config.h)
18 dnl *************************************************************************** 21 dnl ***************************************************************************
19 dnl Arguments 22 dnl Arguments
20 23
21+AC_ARG_ENABLE(libnet, 24+AC_ARG_ENABLE(libnet,
22+ [ --enable-libnet Enable libnet support.],, enable_libnet="no") 25+ [ --enable-libnet Enable libnet support.],, enable_libnet="no")
23+ 26+
24 AC_ARG_WITH(libnet, 27 AC_ARG_WITH(libnet,
25 [ --with-libnet=path use path to libnet-config script], 28 [ --with-libnet=path use path to libnet-config script],
26 , 29 ,
27@@ -893,22 +896,26 @@ dnl ************************************ 30@@ -1047,19 +1050,20 @@ dnl ***************************************************************************
28 dnl libnet headers/libraries 31 dnl libnet headers/libraries
29 dnl *************************************************************************** 32 dnl ***************************************************************************
30 AC_MSG_CHECKING(for LIBNET) 33 AC_MSG_CHECKING(for LIBNET)
@@ -39,7 +42,14 @@ Index: syslog-ng-3.8.1/configure.ac
39+ else 42+ else
40+ LIBNET_CONFIG="$with_libnet/libnet-config" 43+ LIBNET_CONFIG="$with_libnet/libnet-config"
41+ fi 44+ fi
42+ 45
46-if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
47- LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
48- LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
49- AC_MSG_RESULT(yes)
50-dnl libnet-config does not provide the _DEFAULT_SOURCE define, that can cause warning during build
51-dnl as upstream libnet-config does uses _DEFAULT_SOURCE this is just a fix till
52- LIBNET_CFLAGS="$LIBNET_CFLAGS -D_DEFAULT_SOURCE"
43+ if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then 53+ if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
44+ LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`" 54+ LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
45+ LIBNET_LIBS="`$LIBNET_CONFIG --libs`" 55+ LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
@@ -48,16 +58,8 @@ Index: syslog-ng-3.8.1/configure.ac
48+ AC_MSG_ERROR([Could not find libnet, and libnet support was explicitly enabled.]) 58+ AC_MSG_ERROR([Could not find libnet, and libnet support was explicitly enabled.])
49+ fi 59+ fi
50 60
51-if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
52- LIBNET_CFLAGS="`$LIBNET_CONFIG --defines`"
53- LIBNET_LIBS="`$LIBNET_CONFIG --libs`"
54- AC_MSG_RESULT(yes)
55 else 61 else
56 LIBNET_LIBS= 62 LIBNET_LIBS=
57 AC_MSG_RESULT(no) 63--
58 fi 642.7.4
59 65
60-
61 if test "x$enable_spoof_source" = "xauto"; then
62 AC_MSG_CHECKING(whether to enable spoof source support)
63 if test "x$LIBNET_LIBS" != "x"; then