summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity/gateone/gateone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-connectivity/gateone/gateone_git.bb')
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone_git.bb22
1 files changed, 14 insertions, 8 deletions
diff --git a/meta-python/recipes-connectivity/gateone/gateone_git.bb b/meta-python/recipes-connectivity/gateone/gateone_git.bb
index 7eae12a8bf..5ff753eda6 100644
--- a/meta-python/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-python/recipes-connectivity/gateone/gateone_git.bb
@@ -3,14 +3,13 @@ LICENSE = "AGPL-3.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne" 4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
5 5
6PV = "1.2" 6PV = "1.2+git${SRCPV}"
7SRCREV = "1528d324088fc1c180b7fdf50f5b5c1af057eef6" 7SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034"
8SRC_URI = "git://github.com/liftoff/GateOne.git \ 8SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
9 file://0001-configuration.py-Hack-around-broken-gethostname-thin.patch \
10 file://gateone-avahi.service \ 9 file://gateone-avahi.service \
11 file://80oe.conf \ 10 file://80oe.conf.in \
12 file://gateone.service \ 11 file://gateone.service.in \
13 file://gateone-init \ 12 file://gateone-init.in \
14" 13"
15 14
16S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
@@ -28,7 +27,12 @@ DISTUTILS_INSTALL_ARGS = "--root=${D} \
28do_install_append() { 27do_install_append() {
29 28
30 # fix up hardcoded paths 29 # fix up hardcoded paths
31 sed -i -e s:/usr/bin:${bindir}:g ${WORKDIR}/gateone.service 30 for file in gateone.service gateone-init 80oe.conf; do
31 sed -e s:@bindir@:${bindir}:g \
32 -e s:@localstate@:${localstatedir}:g \
33 < ${WORKDIR}/$file.in \
34 > ${WORKDIR}/$file
35 done
32 36
33 install -d ${D}${systemd_unitdir}/system 37 install -d ${D}${systemd_unitdir}/system
34 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system 38 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
@@ -49,6 +53,7 @@ FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYT
49RDEPENDS_${PN} = "mime-support \ 53RDEPENDS_${PN} = "mime-support \
50 openssh-ssh \ 54 openssh-ssh \
51 python-compression \ 55 python-compression \
56 python-contextlib \
52 python-crypt \ 57 python-crypt \
53 python-datetime \ 58 python-datetime \
54 python-email \ 59 python-email \
@@ -76,6 +81,7 @@ RDEPENDS_${PN} = "mime-support \
76 python-tornado \ 81 python-tornado \
77 python-unixadmin \ 82 python-unixadmin \
78 python-xml \ 83 python-xml \
84 python-html5lib \
79 bash \ 85 bash \
80" 86"
81 87