diff options
Diffstat (limited to 'meta-python/recipes-devtools/python-jsonref')
3 files changed, 50 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python-jsonref/files/migrate-to-pdm-backend.patch b/meta-python/recipes-devtools/python-jsonref/files/migrate-to-pdm-backend.patch new file mode 100644 index 0000000000..805d9edce1 --- /dev/null +++ b/meta-python/recipes-devtools/python-jsonref/files/migrate-to-pdm-backend.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 1b594cf12e5a69aa25f49f532c1201a6b39e280d Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Tue, 7 Nov 2023 10:43:32 +0000 | ||
4 | Subject: [PATCH] Migrate to pdm-backend | ||
5 | |||
6 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
7 | --- | ||
8 | pyproject.toml | 6 ++---- | ||
9 | 1 file changed, 2 insertions(+), 4 deletions(-) | ||
10 | |||
11 | diff --git a/pyproject.toml b/pyproject.toml | ||
12 | index f549376..c608213 100644 | ||
13 | --- a/pyproject.toml | ||
14 | +++ b/pyproject.toml | ||
15 | @@ -36,7 +36,5 @@ includes = [ | ||
16 | profile = "black" | ||
17 | |||
18 | [build-system] | ||
19 | -requires = [ | ||
20 | - "pdm-pep517>=1.0.0", | ||
21 | -] | ||
22 | -build-backend = "pdm.pep517.api" | ||
23 | +requires = ["pdm-backend"] | ||
24 | +build-backend = "pdm.backend" | ||
25 | -- | ||
26 | 2.39.2 | ||
27 | |||
diff --git a/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.0.1.bb b/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.0.1.bb deleted file mode 100644 index 5b842a462d..0000000000 --- a/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.0.1.bb +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | SUMMARY = "jsonref is a library for automatic dereferencing of JSON Reference objects for Python" | ||
2 | HOMEPAGE = "https://github.com/gazpachoking/jsonref" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a34264f25338d41744dca1abfe4eb18f" | ||
5 | |||
6 | SRC_URI[sha256sum] = "51d3e18b83ca7170ff51286a0e1a6719d8b7fcc7abdb16b189395a8536996b97" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | BBCLASSEXTEND = "native nativesdk" | ||
11 | |||
12 | RDEPENDS:${PN} += " \ | ||
13 | ${PYTHON_PN}-core \ | ||
14 | ${PYTHON_PN}-json \ | ||
15 | ${PYTHON_PN}-netclient \ | ||
16 | " | ||
diff --git a/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb b/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb new file mode 100644 index 0000000000..fae1da2686 --- /dev/null +++ b/meta-python/recipes-devtools/python-jsonref/python3-jsonref_1.1.0.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "jsonref is a library for automatic dereferencing of JSON Reference objects for Python" | ||
2 | HOMEPAGE = "https://github.com/gazpachoking/jsonref" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ac1cccee5d43e11fc4eddcf445be64a" | ||
5 | |||
6 | SRC_URI[sha256sum] = "32fe8e1d85af0fdefbebce950af85590b22b60f9e95443176adbde4e1ecea552" | ||
7 | |||
8 | SRC_URI += "file://migrate-to-pdm-backend.patch" | ||
9 | |||
10 | inherit pypi python_setuptools_build_meta | ||
11 | |||
12 | BBCLASSEXTEND = "native nativesdk" | ||
13 | |||
14 | DEPENDS += " \ | ||
15 | ${PYTHON_PN}-pdm-native \ | ||
16 | ${PYTHON_PN}-pdm-backend-native \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS:${PN} += " \ | ||
20 | ${PYTHON_PN}-core \ | ||
21 | ${PYTHON_PN}-json \ | ||
22 | ${PYTHON_PN}-netclient \ | ||
23 | " | ||